Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

How do i create site to site VPN with two ASA 5505s

I am fairly new to this forum, pretty new to cisco but I know I will get good help from here.

I have 2 pieces of ASA5505 and I want a site to site VPN for my network of two locations.Site A(HQ) and SiteB(branch)

The purpose is to access a server with local ip  10.1.50.201 in HQ from branch.I have two public ip addresses from ISP.

Can someone help me with all the configs that I need to get the VPN up and running.

9 REPLIES
Super Bronze

How do i create site to site VPN with two ASA 5505s

Hi,

Your post doesnt yet contain all the needed information. (networks, IP addresses, ASA software levels)

Perhaps you can share the current configurations (with changed public IP addresses) with us so we can determine the needed configurations.

- Jouni

New Member

How do i create site to site VPN with two ASA 5505s

Result of the command: "show run"

: Saved

:

ASA Version 8.2(5)

!

hostname ciscoasa

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 192.168.1.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address xxxx.xxxx.xxxx.xxxx 255.0.0.0

!

ftp mode passive

access-list outside_acl extended permit ip any any

access-list outside_1_cryptomap extended permit ip host 10.1.50.0 host 10.1.51.0

access-list inside_nat0_outbound extended permit ip host 10.1.50.0 host 10.1.51.0

pager lines 24

logging enable

logging asdm informational

mtu inside 1500

mtu outside 1500

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_nat0_outbound

nat (inside) 1 0.0.0.0 0.0.0.0

access-group outside_acl in interface outside

route outside 10.1.50.0 255.255.255.0 xxxx.xxxx.xxxx.xxxx

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

http server enable

http 192.168.1.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto map outside_map 1 match address outside_1_cryptomap

crypto map outside_map 1 set pfs group1

crypto map outside_map 1 set peer xxxx.xxxx.xxxx.xxxx

crypto map outside_map 1 set transform-set ESP-3DES-SHA

crypto map outside_map interface outside

crypto isakmp enable outside

crypto isakmp policy 10

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 86400

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd auto_config outside

!

dhcpd address 192.168.1.5-192.168.1.36 inside

dhcpd enable inside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

tunnel-group xxxx.xxxx.xxxx.xxxx type ipsec-l2l

tunnel-group xxxx.xxxx.xxxx.xxxx ipsec-attributes

pre-shared-key *****

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny 

  inspect sunrpc

  inspect xdmcp

  inspect sip 

  inspect netbios

  inspect tftp

  inspect ip-options

!

service-policy global_policy global

prompt hostname context

no call-home reporting anonymous

Cryptochecksum:3a09a2e324dffbfa9b945aa0875dce8d

: end

I want to erase the above config.I just need someone to send to me  a working config.

remote network address: 10.1.51.0 mask 255.0.0.0

someone can mail me a good config: olaibigbami@yahoo.com

xxxx.xxxx.xxxx.xxxx
Super Bronze

Re: How do i create site to site VPN with two ASA 5505s

Hi,

That is only one ASAs configuration.

But there are some clear problems there and with what you are asking.

  • Your "outside" interfaces mask is /8 = 255.0.0.0. I doubt that this is correct
  • Your NAT0 and VPN ACLs contain only single host addresses on each side. You should use a complete network.
  • Those same ACLs have a source address which isnt located on this ASA. You have local network 192.168.1.0/24 yet you use 10.1.x.x/yy addresses in the NAT0 and VPN ACLs as source

Majority of your configuration are correct but I would suggest correcting the networks and network masks in the configurations. After they are correct there should be no problem forming the L2L VPN connection. Naturally you have to make sure that the remote end doesnt have same problems.

- Jouni

New Member

Re: How do i create site to site VPN with two ASA 5505s

I have factory-default so I can star over again.I'm not good with CLI so i use asdm for setup.

I would not mind if anyone send me a working config of site 2 site VPN on ASA 5505 so i can use.

All i need is for remote network 192.168.1.0/24 to connect to a server in HQ(10.1.50.0)

Other usersin HQ(10.1.50.0) should be able to connect to server- nothing more.

my configs for the two sites are shown below and VPN is not comming up:

Result of the command: "show run"

: Saved

:

ASA Version 8.2(5)

!

hostname HQ

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 192.168.1.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address dhcp setroute

!

ftp mode passive

object-group network DM_INLINE_NETWORK_1

network-object host 10.1.50.0

network-object host 255.255.255.0

object-group network DM_INLINE_NETWORK_2

network-object host 192.168.1.0

network-object host 255.255.255.0

access-list outside_1_cryptomap extended permit ip object-group DM_INLINE_NETWORK_1 object-group DM_INLINE_NETWORK_2

access-list inside_nat0_outbound extended permit ip object-group DM_INLINE_NETWORK_1 object-group DM_INLINE_NETWORK_2

pager lines 24

logging enable

logging asdm informational

mtu outside 1500

mtu inside 1500

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_nat0_outbound

nat (inside) 1 0.0.0.0 0.0.0.0

route outside 0.0.0.0 0.0.0.0 x.x.x.x (HQ ip) 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

http server enable

http 192.168.1.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto map outside_map 1 match address outside_1_cryptomap

crypto map outside_map 1 set pfs group1

crypto map outside_map 1 set peer x.x.x.x(branch ip)

crypto map outside_map 1 set transform-set ESP-3DES-SHA

crypto map outside_map interface outside

crypto isakmp enable outside

crypto isakmp policy 10

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 86400

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd auto_config outside

!

dhcpd address 192.168.1.5-192.168.1.36 inside

dhcpd enable inside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

tunnel-group x.x.x.x type ipsec-l2l

tunnel-group x.x.x.x ipsec-attributes

pre-shared-key *****

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny 

  inspect sunrpc

  inspect xdmcp

  inspect sip 

  inspect netbios

  inspect tftp

  inspect ip-options

!

service-policy global_policy global

prompt hostname context

no call-home reporting anonymous

Cryptochecksum:4c56a2036a58f8637bb132a47347668e

: end

Result of the command: "show run"

: Saved

:

ASA Version 8.2(5)

!

hostname Branch

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 192.168.1.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address dhcp setroute

!

ftp mode passive

object-group network DM_INLINE_NETWORK_1

network-object host 10.1.50.0

network-object host 255.255.255.0

access-list outside_1_cryptomap extended permit ip 192.168.1.0 255.255.255.0 object-group DM_INLINE_NETWORK_1

access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 object-group DM_INLINE_NETWORK_1

pager lines 24

logging enable

logging asdm informational

mtu inside 1500

mtu outside 1500

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_nat0_outbound

nat (inside) 1 0.0.0.0 0.0.0.0

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

http server enable

http 192.168.1.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto map outside_map 1 match address outside_1_cryptomap

crypto map outside_map 1 set pfs group1

crypto map outside_map 1 set peer x.x.x.x (HQ ip)

crypto map outside_map 1 set transform-set ESP-3DES-SHA

crypto map outside_map interface outside

crypto isakmp enable outside

crypto isakmp policy 10

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 86400

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd auto_config outside

!

dhcpd address 192.168.1.5-192.168.1.36 inside

dhcpd enable inside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

tunnel-group x.x.x.x (HQ ip) type ipsec-l2l

tunnel-group x.x.x.x (HQ ip) ipsec-attributes

pre-shared-key *****

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny 

  inspect sunrpc

  inspect xdmcp

  inspect sip 

  inspect netbios

  inspect tftp

  inspect ip-options

!

service-policy global_policy global

prompt hostname context

no call-home reporting anonymous

Cryptochecksum:b38e9c7c9c055bd9aab301eea6d35c09

: end

Thanks for anticipated response.

Super Bronze

Re: How do i create site to site VPN with two ASA 5505s

Hi,

Both your NAT0 and VPN ACLs are wrong.

Both of your ASAs also have the same LAN network. Above it says HQ is 192.168.1.0/24?

You have to change the other devices LAN network to the correct one. You also have to change the ACLs I mentioned.

HQ

Add the new ones

access-list outside_1_cryptomap extended permit ip 10.1.50.0 255.255.255.0 192.168.1.0 255.255.255.0

access-list inside_nat0_outbound extended permit ip 10.1.50.0 255.255.255.0 192.168.1.0 255.255.255.0

Remove the old ones

no access-list outside_1_cryptomap extended permit ip object-group DM_INLINE_NETWORK_1 object-group DM_INLINE_NETWORK_2

no access-list inside_nat0_outbound extended permit ip object-group DM_INLINE_NETWORK_1 object-group DM_INLINE_NETWORK_2

BRANCH

Add the new ones

access-list outside_1_cryptomap extended permit ip 192.168.1.0 255.255.255.0 10.1.50.0 255.255.255.0

access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 10.1.50.0 255.255.255.0

Remove the old ones

no access-list outside_1_cryptomap extended permit ip 192.168.1.0 255.255.255.0 object-group DM_INLINE_NETWORK_1

no access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 object-group DM_INLINE_NETWORK_1

Also it seems that both of your ASAs are using DHCP for their "outside" interface? How are you going to keep the L2L VPN up for the 2 end points if they dont have a static public IP address?

Or does the ISP assing the same public IP address based on the device MAC address?

- Jouni

New Member

How do i create site to site VPN with two ASA 5505s

Thank you.

I have made the changes you recommended but both ASAs are still not forming VPN connection.

They are both tearing down TCP & UDP connections and translations to  & from outside.They are also denying incoming TCP.

The ISP gave me two public ip addresses.My modem is in bridge mode so the modems delivers public ip addresses to my WAN interfaces.

What else could be tearing down connections & translations? Please, help urgently.

New Member

How do i create site to site VPN with two ASA 5505s

Hello try this , this is detail step by step configuration ,

http://www.youtube.com/watch?v=lGbsQJOxjsI

Re:How do i create site to site VPN with two ASA 5505s

Sounds like you need to tell the ASA not to your internal networks that are traversing the VPN tunnel.

There is a Cisco config guide for this.

This is also dependant on which IOS version you are running

Sent from Cisco Technical Support Android App

-- CCNP, CCIP, CCDP, CCNA: Security/Wireless Blog: http://ccie-or-null.net/

Re:How do i create site to site VPN with two ASA 5505s

You ASDM. Cisco ASA is well known for its ASDM easy to configure everything.

Jawad

Jawad
1141
Views
0
Helpful
9
Replies
CreatePlease to create content