Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

HTTP redirection not succeeding

Here only what I'm receiving when using static NAT on PIX 501 6.3:

HTTP/1.1 400 Bad Request

Server: Microsoft-IIS/5.1

Date: Thu, 25 Jun 2009 14:37:37 GMT

Content-Type: text/html

Content-Length: 87

I'm using many static NATs and showing a correct result when showing (show xlate) also (show access-list).

Is it possible due of MTU on TCP packets? If yes, what command can change the TCP MTU? If not what's possible reason of the problem.

Regards,

Omar

7 REPLIES
Cisco Employee

Re: HTTP redirection not succeeding

try with

mtu outside 1500

New Member

Re: HTTP redirection not succeeding

It it possible also caused by the cache server? I'm receiving it rapidly.

I'm using a direct connection without a proxy, where it may be?

Cisco Employee

Re: HTTP redirection not succeeding

try with clear xlate and with clear local commands

New Member

Re: HTTP redirection not succeeding

I don't think so, the translations are right and working fine.

New Member

Re: HTTP redirection not succeeding

Fixed now!

It wasn't a Cisco problem, just the because the costumer IIS was using port 82 rather than the default 80

Thanks for all of you!

Bronze

Re: HTTP redirection not succeeding

Don't see how this could be an MTU issue...

You've established a successful HTTP connection and are receiving a 400 response code from the destination server. This looks like an application layer issue.

New Member

Re: HTTP redirection not succeeding

I fixed the problem before seeing your reply, but you gave the more logical reason.

Many thanks,

131
Views
5
Helpful
7
Replies
CreatePlease to create content