Cisco Support Community
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

I can't send image to my ASA with tftp


I have erased the startup config and reloaded ASA 5510. Now its not able to boot preoperly.

I used rommon mode to transferth image file to my ASA, the transfer is made succefully, but when i attempt to use copy tftp flash, i receive this error message :

ciscoasa# copy tftp flash

Address or name of remote host []?

Source filename [asa802-k8.bin]?

Destination filename [asa802-k8.bin]?

Accessing tftp://!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

%Error copying tftp:// (Not enough space on device)

when I execute dir and show flash command:

ciscoasa# dir

Directory of disk0:/

432 drw- 0 08:57:09 Jul 14 2007 crypto_archive

426 drwx 0 08:56:56 Jul 14 2007 log

0 bytes total (0 bytes free)

ciscoasa# sh flash:

--#-- --length-- -----date/time------ path

432 0 Jul 14 2007 08:57:09 crypto_archive

426 0 Jul 14 2007 08:56:56 log

0 bytes total (0 bytes free)

I though that there is no flash memory in my appliance then I use show version that display:

ciscoasa# show version

Cisco Adaptive Security Appliance Software Version 8.0(2)

Compiled on Fri 15-Jun-07 19:29 by builders

System image file is "tftp://"

Config file at boot was "startup-config"

ciscoasa up 36 mins 35 secs

Hardware: ASA5510-K8, 256 MB RAM, CPU Pentium 4 Celeron 1600 MHz

Internal ATA Compact Flash, 256MB

Slot 1: ATA Compact Flash, 32MB

BIOS Flash AT49LW080 @ 0xffe00000, 1024KB

Encryption hardware device : Cisco ASA-55x0 on-board accelerator (revision 0x0)

Boot microcode : CN1000-MC-BOOT-2.00

SSL/IKE microcode: CNLite-MC-SSLm-PLUS-2.01

IPSec microcode : CNlite-MC-IPSECm-MAIN-2.04

0: Ext: Ethernet0/0 : address is 0019.e8d9.4854, irq 9

1: Ext: Ethernet0/1 : address is 0019.e8d9.4855, irq 9

2: Ext: Ethernet0/2 : address is 0019.e8d9.4856, irq 9

3: Ext: Ethernet0/3 : address is 0019.e8d9.4857, irq 9

4: Ext: Management0/0 : address is 0019.e8d9.4858, irq 11

5: Int: Not used : irq 11

6: Int: Not used : irq 5

<--- More --->

The Running Activation Key is not valid, using default settings:

Licensed features for this platform:

Maximum Physical Interfaces : Unlimited

Maximum VLANs : 50

Inside Hosts : Unlimited

Failover : Disabled

VPN-DES : Enabled

VPN-3DES-AES : Disabled

Security Contexts : 0

GTP/GPRS : Disabled

VPN Peers : 250

WebVPN Peers : 2

Advanced Endpoint Assessment : Disabled

This platform has a Base license.

Serial Number: JMX1106K0XM

Running Activation Key: 0x00000000 0x00000000 0x00000000 0x00000000 0x00000000

Configuration register is 0x1

Configuration last modified by enable_15 at 09:01:10.061 UTC S

I used another externat flash as you can see in the output of sh version but I have alwase the same problem.

Can anyone help me Please.

Cisco Employee

Re: I can't send image to my ASA with tftp

Hi -

Based on what I see searching all open/closed TAC cases, it appears your ASA may have a corrupt flash, as is the case with a few other cases that I found.

I would suggest opening a TAC case under initial warranty to see if you can get a replacement.




Community Member

Re: I can't send image to my ASA with tftp

thanks for your help; but I think I found the solution.

What I did is I simply format the memory flash of ASA and after reboot, all things are good.

CreatePlease to create content