Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LAN ->- Cisco ASA 5510 ->- ADSL Router ->- Internet

We have a Cisco ASA 5510 FireWall. It has one interface connected to our LAN and one to our ADSL Router.

LAN ->- Cisco ASA 5510 ->- ADSL Router ->- Internet

It is happily talking to both, but I can't seem to communicate with the ADSL Router from our LAN. The IP Address of the router is 192.168.0.192 and it's interface card 192.168.0.12. The IP address of the interface card attached to our LAN is 192.0.1.10.

What steps am I missing to get it all communicating?

5 REPLIES
Purple

LAN ->- Cisco ASA 5510 ->- ADSL Router ->- Internet

Hi,

Post your firewall config.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

LAN ->- Cisco ASA 5510 ->- ADSL Router ->- Internet

ASA Version 8.4(1)

!

hostname ciscoasa

enable password kiHEhvaX9dUcYEU2 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

!

interface Ethernet0/0

nameif lan

security-level 0

ip address 192.0.1.10 255.255.254.0

!

interface Ethernet0/1

nameif internet

security-level 0

ip address dhcp setroute

!

interface Ethernet0/2

shutdown

no nameif

no security-level

no ip address

!

interface Ethernet0/3

shutdown

no nameif

no security-level

no ip address

!

interface Management0/0

nameif management

security-level 100

ip address 192.168.1.1 255.255.255.0

management-only

!

ftp mode passive

same-security-traffic permit inter-interface

object-group protocol TCPUDP

protocol-object udp

protocol-object tcp

pager lines 24

logging enable

logging asdm informational

mtu management 1500

mtu lan 1500

mtu internet 1500

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

dynamic-access-policy-record DfltAccessPolicy

http server enable

http 192.168.1.0 255.255.255.0 management

http 192.0.0.48 255.255.255.255 lan

http 192.0.1.19 255.255.255.255 lan

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart

telnet 192.0.1.19 255.255.255.255 lan

telnet timeout 5

ssh 192.0.0.48 255.255.255.255 lan

ssh 192.0.1.19 255.255.255.255 lan

ssh timeout 5

console timeout 0

dhcp-client client-id interface internet

dhcpd address 192.168.1.2-192.168.1.254 management

dhcpd enable management

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

username admin password 0dHnjNaOhSVHVDU. encrypted privilege 15

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny 

  inspect sunrpc

  inspect xdmcp

  inspect sip 

  inspect netbios

  inspect tftp

  inspect ip-options

  inspect icmp

  inspect icmp error

!

service-policy global_policy global

prompt hostname context

Cryptochecksum:64381222acaa2f1f19d3333c7d6da4ab

: end

Purple

LAN ->- Cisco ASA 5510 ->- ADSL Router ->- Internet

Hi,

verify you have  route to your LAN subnet on the router and configure NAT on the ASA.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

LAN ->- Cisco ASA 5510 ->- ADSL Router ->- Internet

I don't have a route setup, what would be the correct syntex?

Purple

LAN ->- Cisco ASA 5510 ->- ADSL Router ->- Internet

Hi,

the syntax is manufacturer dependent but you must have a route to

192.0.1.0  255.255.254.0 pointing to 192.168.0.12

Regards.

Alain.

Don't forget to rate helpful posts.
789
Views
0
Helpful
5
Replies
CreatePlease login to create content