Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
New Member

Need setup help with an ASA 5512

I am trying to setup a Cisco ASA 5512 in a lab for a proof of concept. The software version is 8.6(1)2.Any advice would be much appreciated.

The outside interface can ping the gateway but the inside can not:

Airfield1# ping outside 1.1.1.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/10 ms

Airfield1# ping inside 1.1.1.4

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.4, timeout is 2 seconds:

?????

Success rate is 0 percent (0/5)

The configuration is as follows:

Airfield1# sh run

: Saved

:

ASA Version 8.6(1)2

!

hostname Airfield1

enable password 2KFQnbNIdI.2KYOU encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

!

interface GigabitEthernet0/0

nameif outside

security-level 0

ip address 1.1.1.4 255.255.255.0

!

interface GigabitEthernet0/1

shutdown

no nameif

no security-level

no ip address

!

interface GigabitEthernet0/2

shutdown

no nameif

no security-level

no ip address

!

interface GigabitEthernet0/3

shutdown

no nameif

no security-level

no ip address

!

interface GigabitEthernet0/4

shutdown

no nameif

no security-level

no ip address

!

interface GigabitEthernet0/5

nameif inside

security-level 100

ip address 192.168.2.1 255.255.255.0

!

interface Management0/0

nameif management

security-level 100

ip address 192.168.0.1 255.255.255.0

management-only

!

banner exec ********************************************************

banner exec ATTENTION!

banner exec THIS IS A DOD COMPUTER SYSTEM. BEFORE PROCESSING

banner exec CLASSIFIED INFORMATION, CHECK THE SECURITY

banner exec ACCREDITATION LEVEL OF THIS SYSTEM. DO NOT PROCESS,

banner exec STORE OR TRANSMIT INFORMATION CLASSIFIED ABOVE

banner exec ACCREDITATON LEVEL OF THIS SYSTEM. THIS COMPUTER

banner exec SYSTEM, INCLUDING ALL RELATED EQUIPMENT, NETWORKS AND

banner exec NETWORK DEVICES (INCLUDES INTERNET ACCESS) ARE

banner exec PROVIDED ONLY FOR AUTHORIZED U.S. GOVERNMENT USE.

banner exec ********************************************************

banner login ************************************************************

banner login  WARNING!!! This is a U.S. Government Department of Defense Network

banner login

banner login This system is provided only for authorized U.S. Government use.

banner login DOD computer systems may be monitored for all lawful purposes,

banner login

banner login Use of this DOD computer system, authorized or unauthorized,

banner login constitutes consent to monitoring.

banner login

banner login Unauthorized use of this DOD computer system may subject you

banner login to criminal prosecution.

banner login

banner login Evidence of unauthorized use collected during monitoring may be used

banner login for administrative, criminal or other adverse action. Use of this

banner login system constitutes consent to monitoring for all lawful purposes.

banner login

banner login Disconnect IMMEDIATELY if you are not an authorized user!

banner login ********************************************************

banner motd *********************************************************

banner motd  WARNING!!! This is a U.S. Government Department of Defense Network

banner motd  Disconnect IMMEDIATELY if you are not an authorized user!

banner motd ********************************************************

banner asdm *********************************************************

banner asdm  WARNING!!! This is a U.S. Government Department of Defense Network

banner asdm  Disconnect IMMEDIATELY if you are not an authorized user!

banner asdm ********************************************************

ftp mode passive

same-security-traffic permit inter-interface

same-security-traffic permit intra-interface

access-list inside_access_in extended permit ip any any

access-list inside_access_in extended permit icmp any any

access-list outside_access_in extended permit icmp any any

pager lines 24

logging asdm informational

mtu management 1500

mtu outside 1500

mtu inside 1500

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

!

nat (inside,outside) after-auto source dynamic any interface

access-group outside_access_in in interface outside

access-group inside_access_in in interface inside

route outside 0.0.0.0 0.0.0.0 1.1.1.3 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

user-identity default-domain LOCAL

http server enable

http 192.168.0.0 255.255.255.0 management

http 192.168.2.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart

telnet 192.168.2.0 255.255.255.0 inside

telnet timeout 5

ssh 192.168.2.0 255.255.255.0 inside

ssh timeout 5

console timeout 0

dhcpd address 192.168.0.2-192.168.0.254 management

dhcpd enable management

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny

  inspect sunrpc

  inspect xdmcp

  inspect sip

  inspect netbios

  inspect tftp

  inspect ip-options

!

service-policy global_policy global

prompt hostname context

call-home reporting anonymous prompt 1

call-home

profile CiscoTAC-1

  no active

  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService

  destination address email callhome@cisco.com

  destination transport-method http

  subscribe-to-alert-group diagnostic

  subscribe-to-alert-group environment

  subscribe-to-alert-group inventory periodic monthly 12

  subscribe-to-alert-group configuration periodic monthly 12

  subscribe-to-alert-group telemetry periodic daily

Cryptochecksum:e8add3822edb16f3b25f638d9223c6e7

: end

Airfield1#

1 ACCEPTED SOLUTION

Accepted Solutions

Need setup help with an ASA 5512

Hi Mathew,

The ASA as a security device will not allow you to ping  a distant interface....

What is a distant interface?

As  an example imagine you are on a host behind the inside interface.. You  will be able to ping the inside interface but you wil NOT be able to  ping the DMZ or outside interface... This because they are distant  interface for the inside host..

There is nothing you can do to change that behavior, this is done as a security meassure by the ASA ( Built-in feature)

By design, Cisco does not allow pinging cross interfaces like that.

According to Cisco's own documentation...

http://www.cisco.com/en/US/docs/security/asa/asa71/configuration/guide/trouble.html

http://www.cisco.com/en/US/docs/security/asa/asa71/configuration/guide/trouble.html#wp1059645

"For  security purposes the security appliance does not support far-end  interface ping, that is pinging the IP address of the outside interface  from the inside network."

Please rate.

2 REPLIES

Need setup help with an ASA 5512

Hi Mathew,

The ASA as a security device will not allow you to ping  a distant interface....

What is a distant interface?

As  an example imagine you are on a host behind the inside interface.. You  will be able to ping the inside interface but you wil NOT be able to  ping the DMZ or outside interface... This because they are distant  interface for the inside host..

There is nothing you can do to change that behavior, this is done as a security meassure by the ASA ( Built-in feature)

By design, Cisco does not allow pinging cross interfaces like that.

According to Cisco's own documentation...

http://www.cisco.com/en/US/docs/security/asa/asa71/configuration/guide/trouble.html

http://www.cisco.com/en/US/docs/security/asa/asa71/configuration/guide/trouble.html#wp1059645

"For  security purposes the security appliance does not support far-end  interface ping, that is pinging the IP address of the outside interface  from the inside network."

Please rate.

New Member

Re: Need setup help with an ASA 5512

Thank you sachinga. I was able to ping across the VPN between hosts. So it looks good.

204
Views
0
Helpful
2
Replies
CreatePlease to create content