Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

NTP Through ASA 8.4 Issue

Hi All,

I am having an issue getting NTP from an inside host to a host on the outside.

My inside host is on an RFC 1918 address and it has a static source NAT translation to a registered internet address to any destination. My inside source is sending the NTP packets out with a source port of UDP 123 and also a destination port of UDP 123

I have access list rules in place on the inside interface to permit the traffic and can see the counters increasing with each attempt from the inside host.

When I try to packet trace the connectivity on the ASA using asdm the flow seems OK, however the output interface is showing as unknown.

The relevant parts of my config are shown below :

nat (inside,outside) source static cucme_host voice_external

access-list inside-access-out extended permit udp object cucme_host object NTP-Server eq 123

All of my other services for this host are working fine, DNS, SIP, RTP, RTCP etc etc

Anyone got an insight into this, as I seem to be going round in circles.



Everyone's tags (3)

NTP Through ASA 8.4 Issue

Hi Bro

I'm assuming from, you can PING to I'm also assuming your FW rules are correctly done.

access-list inside permit tcp host any eq 123

access-list inside permit udp host any eq 123

access-list inside permit icmp host host

In certain TCP peering, you'd need the TCP ports to be enabled as well. With this, all I can think of is the Public NTP Server that you're pointing to could be the cause here. Have you tried pointing to other Public NTP Servers e.g., and

P/S: If you think this comment is useful, please do rate them nicely :-)

Warm regards, Ramraj Sivagnanam Sivajanam Technical Specialist/Service Delivery Manager – Managed Service Department
New Member

NTP Through ASA 8.4 Issue


Thanks for the reply, all connectivity is fine and the router we are using as a client is sending UDP requests only.

I have managed to solve the unknown output issue, I was missing an ip verify reverse path interface outside command. So now the packet trace seems to work fine however my host on the inside will still not sync to the public server.

The public server I am using is :  Telehouse Europe, London E14 UK  NTP V4 secondary Sun UltraSPARC Solaris 8



New Member

NTP Through ASA 8.4 Issue


The ip verify reverse path interface outside command only appears to affect the first packet in the flow.

If I clear the connections, then try a packet trace the output is exactly what I expect, once the flow idles out the second flow come back with the unknown output interface as seen in the screenshot above.

Anyone got any further ideas ?



NTP Through ASA 8.4 Issue

Hi Steve,

Try with this command in your ASA.

ntp server x.x.x.x source inside or whichever interface initiating the traffic towards NTP.

Please do rate if the given information helps.