Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
New Member

Open port 3389

How do I open port 3389?

This is what I typed in, but it didn't work.

static (inside,outside) tcp x.x.x.x 3389 192.168.3.2 3389 netmask 55.255.255.255

access-list outside_in permit tcp host any host x.x.x.x eq 3389”

I don't know what to use for the access-list. I do not have a "outside_in" access list set up. These are the only access lists I have:

access-list tehama-vpn permit ip 192.168.0.0 255.255.255.0 192.168.3.0 255.255.255.0

access-list nonat permit ip 192.168.0.0 255.255.255.0 192.168.3.0 255.255.255.0

3 REPLIES
Green

Re: Open port 3389

Is x.x.x.x also the outside interface ip?

If so then it needs to be...

static (inside,outside) tcp interface 3389 192.168.3.2 3389 netmask 255.255.255.255

access-list outside_in permit tcp any host x.x.x.x eq 3389

access-group outside_in in interface outside

New Member

Re: Open port 3389

Here is my config file. What should I change?

interface ethernet0 auto

interface ethernet1 auto

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password xx encrypted

passwd xx encrypted

hostname fm-fw

domain-name sfcc.org

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list tehama-vpn permit ip 192.168.0.0 255.255.255.0 192.168.3.0 255.255.255.0

access-list nonat permit ip 192.168.0.0 255.255.255.0 192.168.3.0 255.255.255.0

access-list outside_in permit tcp host 1.2.3.4 host 7.7.7.7 eq 3389

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside 7.7.7.7 255.255.255.252

ip address inside 192.168.0.1 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list nonat

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

static (inside,outside) tcp 7.7.7.7 3389 192.168.3.2 3389 netmask 255.255.255.255 0 0

route outside 0.0.0.0 0.0.0.0 74.93.9.14 1

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 192.168.1.0 255.255.255.0 inside

http 192.168.0.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

sysopt ipsec pl-compatible

crypto ipsec transform-set sfccset esp-des esp-md5-hmac

crypto ipsec transform-set sfccaesset esp-aes-256 esp-md5-hmac

crypto dynamic-map sfccdmap 20 set transform-set sfccaesset

crypto map sfccmap 10 ipsec-isakmp

crypto map sfccmap 10 match address tehama-vpn

crypto map sfccmap 10 set peer 1.1.1.1

crypto map sfccmap 10 set transform-set sfccaesset

crypto map sfccmap interface outside

crypto map dyn-map 20 ipsec-isakmp dynamic sfccdmap

isakmp enable outside

isakmp key ******** address 0.0.0.0 netmask 0.0.0.0

isakmp key ******** address 1.1.1.1 netmask 255.255.255.255

isakmp identity address

isakmp nat-traversal 20

isakmp policy 5 authentication pre-share

isakmp policy 5 encryption aes-256

isakmp policy 5 hash sha

isakmp policy 5 group 1

isakmp policy 5 lifetime 86400

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption des

isakmp policy 10 hash md5

isakmp policy 10 group 1

isakmp policy 10 lifetime 1000

isakmp policy 20 authentication pre-share

isakmp policy 20 encryption des

isakmp policy 20 hash md5

isakmp policy 20 group 2

isakmp policy 20 lifetime 86400

telnet 0.0.0.0 0.0.0.0 inside

telnet timeout 60

ssh 1.1.1.1 255.255.255.255 outside

ssh 0.0.0.0 0.0.0.0 outside

ssh 0.0.0.0 0.0.0.0 inside

ssh timeout 60

console timeout 0

dhcpd ping_timeout 750

username daved password xxxx

privilege 15

terminal width 80

Green

Re: Open port 3389

Change...

static (inside,outside) tcp 7.7.7.7 3389 192.168.3.2 3389 netmask 255.255.255.255 0 0

to

static (inside,outside) tcp interface 3389 192.168.3.2 3389 netmask 255.255.255.255 0 0

416
Views
8
Helpful
3
Replies
CreatePlease to create content