Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

PIX 525 not saving SSH key

I just installed a 525 at a remote site. I made sure I had a good host name and FQDN in the config. I generated the RSA key pair. SSH statements are there as well allowing access to the inside interface. I was then able to SSH into the box via an IPSEC tunnel and do some further configuring. The next day, however, I tried getting back into the box and now nothing happens. I end up getting a ssh_exchange_identity:session closed by remote host error. Its as if the key is not there now. I had a local on-site engineer reload the box and everything came back up again. That lasted a day. The next day the same thing has happened. It's seems that for whatever reason the SSH server key keeps dropping out of the config.

Any ideas, because I'm definitely scratching my head.

FYI: The code is 6.3(3)xxxx something... and yes i've done a ca save all so the generated keys should stay in flash. All other traffic is working fine. I can even ping the inside interfae with no problems. SSH just keeps screwing up!

1 REPLY
Silver

Re: PIX 525 not saving SSH key

Make sure that you are saving the keys using "ca save all" command.

119
Views
0
Helpful
1
Replies