Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

PIX Transparent Mode

Hi All,

I am trying to configure an old PIX 515e i have brought this up to pix804, I would like this to run in transparent mode so i dont have to reconfigure the network.

It currently sits with the switch on the inside interface and a ethernet dsl modem in bridge mode on the ouside so the gateway is remote.

traffic isent pass out bound with this config can any one see anything simple i may have missed

: Saved
: Written by enable_15 at 20:16:50.013 UTC Mon Jul 12 2010
!
PIX Version 8.0(4)
!
firewall transparent
hostname pixfirewall
enable password xxxx encrypted
passwd xxxx encrypted
names
!
interface Ethernet0
speed 100
nameif outside
security-level 0
!
interface Ethernet1
speed 100
nameif inside
security-level 100
!
interface Ethernet2
shutdown
no nameif
no security-level
!
ftp mode passive
pager lines 24
mtu outside 1500
mtu inside 1500
ip address 172.16.32.5 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny 
  inspect sunrpc
  inspect xdmcp
  inspect sip 
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:453e0fdc6c257a3b509cc72abfc9479a
: end

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: PIX Transparent Mode

Hello,

I am assuming you just changed the security level of outside interface to 100 and added "same-security-traffic permit inter-interface". Is that correct? If that is the case, then I think you might have connected the inside and outside interfaces in reverse i.e. inside interface (Ethernet 1) is connected to the modem and outside interface (Ethernet 0) is connected to the LAN. Can you please verify that and change them accordingly. Also, once you change the cabling, change the outside interface security to 0 and see if the communication still works.

Hope this helps.

Regards,

NT

10 REPLIES
Cisco Employee

Re: PIX Transparent Mode

Hello,

What is the default gateway of the internal devices? Are they using private

IP or public IP? Can you ping the modem (if modem is acting as a router)? Is

your modem capable of doing NAT (in case you are using private IP on the

inside)?

Regards,

NT

Community Member

Re: PIX Transparent Mode

Hi,

The whole config is based on public ip's the modem is in bridge mode so it doesent have an ip the gateway is the remote internet router at the ISP so no local router and the inside host do have the remote router set as there gateway,

p.s. this works fine with out the pix inline

Cisco Employee

Re: PIX Transparent Mode

Hello,


Can you configure capture on the firewall to see if the traffic is traversing through the firewall?

access-list cap permit ip host any

access-list cap permit ip any host

capture capout access-list cap interface outside

capture capin access-list cap interface inside

Once you configure the capture, generate some traffic from the inside host. Then issue "show capture capin" and "show capture capout" on the firewall. If you see the packets souced from the inside interface on the outside interface, that means the firewall is letting the packets through from inside to outside interface. Similarly, if you see the reply packets from the internet server on the outside interface, your modem is letting the traffic through from internet to your network. Then check the inside capture to see if you are seeing any return traffic.

This should give us a fair idea of what could be the reason for failure in the communication.

Hope this helps.

Regards,

NT

Community Member

Re: PIX Transparent Mode

im seeing traffic on the inside interface but nothing on the outside

Cisco Employee

Re: PIX Transparent Mode

Hello,

Can you try to change the security level of the outside interface to 100 and configure "same-security-traffic permit inter-interface" command? Also, can you post the output of "show mac-address-table" command?

Regards,

NT

Community Member

Re: PIX Transparent Mode

Hi Again,

I've have made the changes to the security level and the other line you advised but no joy still although i am now seeing traffic on the capture on both inside and outside now but no through traffic.

Here is the mac address table

nterface                   mac  address          type      Age(min)
------------------------------------------------------------------
inside                     0014.bfb8.ac32          dynamic    4
inside                     0026.b0c0.6165          dynamic    5

Cisco Employee

Re: PIX Transparent Mode

Hello,

I guess the problem is that, since the firewall is not seeing any MAC addresses on the outside, it is not able to determine if the packet need to be sent outside or be blocked. Can you try to put your Modem in routed mode and see if you can send any traffic through the firewall?

Regards,

NT

Community Member

Re: PIX Transparent Mode

Hi, 

It seem to be working now with the below config but now it allow traffic in and out

: Saved
:
PIX Version 8.0(4)
!
firewall transparent
hostname pixfirewall
enable password xxxx encrypted
passwd xxxx encrypted
names
!
interface Ethernet0
speed 100
nameif outside
security-level 100
!
interface Ethernet1
speed 100
nameif inside
security-level 100
!
interface Ethernet2
shutdown
no nameif
no security-level
!
ftp mode passive
same-security-traffic permit inter-interface
pager lines 24
logging enable
logging asdm debugging
mtu outside 1500
mtu inside 1500
ip address 172.16.32.5 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image flash:/asdm-613.bin
no asdm history enable
arp timeout 14400
route outside 0.0.0.0 0.0.0.0 172.16.32.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 0.0.0.0 0.0.0.0 outside
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny 
  inspect sunrpc
  inspect xdmcp
  inspect sip 
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:f15e8720d01e997639ce355197d6efac
: end
asdm image flash:/asdm-613.bin
no asdm history enable
Cisco Employee

Re: PIX Transparent Mode

Hello,

I am assuming you just changed the security level of outside interface to 100 and added "same-security-traffic permit inter-interface". Is that correct? If that is the case, then I think you might have connected the inside and outside interfaces in reverse i.e. inside interface (Ethernet 1) is connected to the modem and outside interface (Ethernet 0) is connected to the LAN. Can you please verify that and change them accordingly. Also, once you change the cabling, change the outside interface security to 0 and see if the communication still works.

Hope this helps.

Regards,

NT

Community Member

Re: PIX Transparent Mode

Thanks you were spot on

534
Views
0
Helpful
10
Replies
CreatePlease to create content