Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

PIX506e vpn works, but not web page, behind single ip dsl

Tried to configure a web page on ip 192.168.1.251, I think it has something to do with having a single static ip and nat not configured correctly, any help would be appreciated.

PIX Version 6.3(5)

interface ethernet0 auto

interface ethernet1 auto

nameif ethernet0 outside security0

nameif ethernet1 inside security100

encrypted

hostname pixfirewall

domain-name ciscopix.com

clock timezone EST -5

clock summer-time EDT recurring

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list inside_outbound_nat0_acl permit ip host 192.168.1.250 192.168.1.192 255.255.255.192

access-list inside_outbound_nat0_acl permit ip host 192.168.1.250 192.168.1.192 255.255.255.224

access-list outside_cryptomap_dyn_20 permit ip any 192.168.1.192 255.255.255.224

access-list outside_access_in permit tcp any host 96.230.999.999 eq www

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside 96.x.x.138 255.255.255.0

ip address inside 192.168.1.3 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

ip local pool mfcd 192.168.1.200-192.168.1.220

pdm location 192.168.1.250 255.255.255.255 inside

pdm location 192.168.1.192 255.255.255.192 outside

pdm location 192.168.1.192 255.255.255.224 outside

pdm location 96.230.136.138 255.255.255.255 inside

pdm location 96.230.136.1 255.255.255.255 outside

pdm location 0.0.0.0 255.255.255.255 inside

pdm location 0.0.0.0 255.255.255.0 outside

pdm location 192.168.1.251 255.255.255.255 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 10 interface

nat (inside) 0 access-list inside_outbound_nat0_acl

nat (inside) 10 0.0.0.0 0.0.0.0 0 0

static (inside,outside) tcp 96.230.999.999 www 192.168.1.251 www netmask 255.255.255.255 0 0

access-group outside_access_in in interface outside

route outside 0.0.0.0 0.0.0.0 96.230.999.1 1

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server TACACS+ (inside) host 192.168.1.250 timeout 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 192.168.1.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20

crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5

crypto map inside_map client authentication LOCAL

crypto map inside_map interface inside

crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map

crypto map outside_map client authentication LOCAL

crypto map outside_map interface outside

isakmp enable outside

isakmp policy 20 authentication pre-share

isakmp policy 20 encryption 3des

isakmp policy 20 hash md5

isakmp policy 20 group 2

isakmp policy 20 lifetime 86400

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd address 192.168.1.40-192.168.1.100 inside

dhcpd dns 71.x.x.12 71.242.0.12

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd domain myhome.westell.com

dhcpd auto_config outside

dhcpd enable inside

terminal width 80

2 REPLIES
Cisco Employee

Re: PIX506e vpn works, but not web page, behind single ip dsl

What is the IP Address that the 192.168.1.251 is getting NATTed to. Is it by any chance the outside interface of the Pix.

In case if you are using the outside interface and doing port redirection, then you have to use the interface keyword when configuring Static if you want the traffic to hit the outside IP and get translated.

You must use the interface keyword instead of specifying the actual IP address when you want to include the IP address of a PIX Firewall interface in a static PAT entry

Please refer the below URL for details.

http://www.cisco.com/en/US/docs/security/pix/pix63/command/reference/s.html#wp1026694

Let me know if it helps.

Regards,

Arul

New Member

Re: PIX506e vpn works, but not web page, behind single ip dsl

I replaced the static with:

static (inside,outide) tcp interface www 192.168.1.251 www netmask 255.255.255.255 0.0

But still doesn't work?

280
Views
0
Helpful
2
Replies
CreatePlease to create content