Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

PIX515e 3 Interfaces Setup

I am doing some testing and would like to get the following to work.

1. E0 - Outside - ISP: 172.16.2.1 255.255.255.252

                         ISP Gateway: 172.16.2.2 255.255.255.252

2. E1 - Inside - IP: 192.168.100.50 255.255.255.0

3. E2 - DMZ IP: 192.168.2.1 255.255.255.0

I need to setup all hosts in the DMZ to be able to get to the internet via Outside interface. I want to use the DMZ as public internet access for hosts on the DMZ network. No Internet hosts will be accessing anything on the DMZ.

Inside Interface is really just for ease of management, no access form DMZ or Outside Interface.

What route and ACL rules do I need.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: PIX515e 3 Interfaces Setup

add this to your pix config under the policy-map global_policy

policy-map global_policy
    class inspection_default
     inspect icmp

this will allow you to ping from a pc on the DMZ to the pc with the default-gateway on the outside of the pix.

Edit - if you want to ping from the outside to a device on the dmz you will need an access-list to allow it. I said before you didn't need an acl because you don't want anything to connect into the dmz but if it is just for testing purposes you could set one up. See this doc for full details -

ICMP through Pix/ASA

Jon

5 REPLIES
Hall of Fame Super Blue

Re: PIX515e 3 Interfaces Setup

ronald.lawrimore wrote:

I am doing some testing and would like to get the following to work.

1. E0 - Outside - ISP: 172.16.2.1 255.255.255.252

                         ISP Gateway: 172.16.2.2 255.255.255.252

2. E1 - Inside - IP: 192.168.100.50 255.255.255.0

3. E2 - DMZ IP: 192.168.2.1 255.255.255.0

I need to setup all hosts in the DMZ to be able to get to the internet via Outside interface. I want to use the DMZ as public internet access for hosts on the DMZ network. No Internet hosts will be accessing anything on the DMZ.

Inside Interface is really just for ease of management, no access form DMZ or Outside Interface.

What route and ACL rules do I need.

None of the addresses above are public ones ie. none are routable on the internet. So does the Natting happen elsewhere or does the outside interface actually have a public IP.

If the NAT happens elsewhere -

nat (dmz) 0 0.0.0.0 0.0.0.0 <-- this will simply anot change the DMZ addresses as they leave the pix so they would need to be natted by something else

if the outside interface has a public IP -

nat (dmz) 1 0.0.0.0 0.0.0.0

global (outside) 1 interface

this will PAT all dmz host addresses to the outside IP of the pix.

As long as the security level of the dmz interface is higher than the outside security level, and it should be as outside is usally given a level of 0 then you do not need to use any access-lists anywhere. No internet hosts will be able to initiate connections to the dmz hosts, they will only be able to send return traffic to connections initiated from the dmz hosts and for this you don't need acls as the pix is a stateful firewall.

Edit - routing

you need a default-route on your firewall -

route outside 0.0.0.0 0.0.0.0 172.16.2.2

If you are patting all addresses to the outside interface of your firewall that's all you need as the ISP will know how to get to that address.

If you aren't ie. as above the NAT takes place elsewhere then either -

1) the ISP would need to add a route back to the dmz hosts

or

2) even if the NAT is happening elsewhere you could still PAT all dmz hosts to 172.16.2.1. That way the ISP would know where to send the return traffic.

Jon

Community Member

Re: PIX515e 3 Interfaces Setup

I do have an actual public IP address, just used the one as an example.

Hall of Fame Super Blue

Re: PIX515e 3 Interfaces Setup

ronald.lawrimore wrote:

I do have an actual public IP address, just used the one as an example.

Okay, then simply use the PAT example i gave and for routing you simply need a default route -

route outside 0.0.0.0 0.0.0.0

Jon

Community Member

Re: PIX515e 3 Interfaces Setup

This is my running config. I have a PC setup to be the ISP gateway at x.x.x.161 just to be able to test my pings and so forth. From the PC, I can ping my Outside interface, but from the PIX I cannot ping the x.x.x.161 address. I cannot ping from the DMZ to the x.x.x.161 address either.

PIX Version 8.0(4)
!
hostname pixfirewall
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0
nameif Outside
security-level 0
ip address x.x.x.162 255.255.255.252
!
interface Ethernet1
nameif inside
security-level 100
ip address 192.168.100.50 255.255.255.0
!
interface Ethernet2
nameif DMZ
security-level 50
ip address 192.168.2.1 255.255.255.0
!
ftp mode passive
same-security-traffic permit intra-interface
pager lines 24
logging asdm informational
mtu inside 1500
mtu DMZ 1500
mtu Outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image flash:/asdm-61551.bin
no asdm history enable
arp timeout 14400
global (Outside) 1 interface
nat (DMZ) 1 0.0.0.0 0.0.0.0
route Outside 0.0.0.0 0.0.0.0 x.x.x.161 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.100.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.100.51-192.168.100.254 inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny 
  inspect sunrpc
  inspect xdmcp
  inspect sip 
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:2231aafb63445593017c89d66a36096b
: end

Hall of Fame Super Blue

Re: PIX515e 3 Interfaces Setup

add this to your pix config under the policy-map global_policy

policy-map global_policy
    class inspection_default
     inspect icmp

this will allow you to ping from a pc on the DMZ to the pc with the default-gateway on the outside of the pix.

Edit - if you want to ping from the outside to a device on the dmz you will need an access-list to allow it. I said before you didn't need an acl because you don't want anything to connect into the dmz but if it is just for testing purposes you could set one up. See this doc for full details -

ICMP through Pix/ASA

Jon

431
Views
0
Helpful
5
Replies
CreatePlease to create content