Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

Port Forward Cisco ASA 5505

Hello,

I'm a Cisco Newbie here. Here is my show config-run (cleansed) :


ASA Version 8.2(5)
!

hostname ciscoasa
enable password x encrypted
passwd x encrypted
names
name 192.168.1.10 SBS2011
name 203.153.x.x AmcomWAN
!

interface Ethernet0/0
switchport access vlan 2
!

interface Ethernet0/1
!

interface Ethernet0/2
shutdown
!

interface Ethernet0/3
shutdown
!

interface Ethernet0/4
shutdown
!

interface Ethernet0/5
shutdown
!

interface Ethernet0/6
shutdown
!

interface Ethernet0/7
shutdown
!

interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.249 255.255.255.0
!

interface Vlan2
nameif outside
security-level 0
ip address AmcomWAN 255.255.255.252
!

ftp mode passive
clock timezone WST 8
object-group service RDP3389 tcp-udp
port-object eq 3389
object-group protocol TCPUDP
protocol-object udp
protocol-object tcp
object-group service DM_INLINE_SERVICE_1
service-object tcp-udp
service-object tcp eq pptp
access-list outside_access_in extended permit object-group DM_INLINE_SERVICE_1 any interface outside
access-list outside_access_in extended permit tcp any interface outside eq 3389 log disable
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 100 burst-size 10
icmp permit any inside
icmp permit any outside
no asdm history enable
arp timeout 14400
global (outside) 10 interface
nat (inside) 10 192.168.1.0 255.255.255.0
static (inside,outside) tcp interface pptp SBS2011 pptp netmask 255.255.255.255
static (inside,outside) tcp interface 3389 192.168.1.9 3389 netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 203.153.253.157 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community *****
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 5
console timeout 0

threat-detection basic-threat
threat-detection statistics access-list
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
ntp server 116.66.161.4 source outside prefer
webvpn
username x password x encrypted privilege 15
!

class-map inspection_default
match default-inspection-traffic
!

!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect ip-options
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect sip
inspect xdmcp
inspect icmp
!

service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
call-home
profile CiscoTAC-1
no active
destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
destination address email callhome@cisco.com
destination transport-method http
subscribe-to-alert-group diagnostic
subscribe-to-alert-group environment
subscribe-to-alert-group inventory periodic monthly
subscribe-to-alert-group configuration periodic monthly
subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:00768eea1a04af4dedb1f8fe4ce7ee98

end

WAN – outside (port0)
203.153.x.x

LAN – inside (port1)
192.168.1.0
ASA 192.168.1.249

I want to port-forward RDP port (3389) to 192.168.1.9 (Server 2012R2). No matter I create Static Route, its just won't go thru.

I need help please.

Thank you.

3 REPLIES

Hi there,

Hi there,

First remove your static NAT RDP entry and replace with:

!

object network srv2012r2

  host 192.168.1.9

!

object service RDP
service tcp source eq 3389

!

nat (inside, outside) source static srv2012r2 interface service RDP RDP

!

 

cheers,

Seb.

Community Member

Hi Seb, Thank you for your

Hi Seb,

 

I'm using ASA Version 8.2(5)

 

When I tried command :

ciscoasa(config)# nat (inside,outside) source static 192.168.1.9 interface service RDP RDP

nat (inside,outside) source static 192.168.1.9 interface service RDP RDP
           ^
ERROR: % Invalid input detected at '^' marker.
ciscoasa(config)#

 

Help please?

 

Cheers

Gerry

Community Member

Can you please try static

Can you please try

 

static (inside,outside) tcp 203.153.x.x 3389 192.168.1.9 3389 netmask 255.255.255.255

 

You can refer to 

 

http://www.cisco.com/c/en/us/td/docs/security/asa/asa82/configuration/guide/config/nat_staticpat.html

104
Views
0
Helpful
3
Replies
CreatePlease to create content