Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Port forwarding on ASA 5505 ver 8.4(7)

Hi Folks,

I am trying to setup a port forwarding configuration of ASA in local network. Scenario is internet connected with DSL modem and ASA connected with DSL Modem. Modem redirecting all traffic to the single LAN IP (ASA).

Somehow I have tried to configured and its doesnot worked out so I configured agian basic connectivity with internet. I have two servers in inside network 1) 10.10.10.22 (S1) and 2) 10.10.10.100 (S2). I can abel to reach intenet from inside network but failed to configured port forwarding in ASA.

I would like to access servers from outside network using custom port forwarding. Need to forward ports 8080,443, 554, 8000 for 10.10.10.22 so whenever I request 192.168.1.100:8080 then its redirect to 10.10.10.22:80, 192.168.1.100:8443 to 10.10.10.22:443 or 554:8554 or 8000:8000, I also like to forward 192.168.1.100:80 to 10.10.10.100:80 & 192.168.1.100:443 to 10.10.10.100:443, however ASDM & SSH already enabled it is possible to foreard 443 port as 9443 for ASDM, if request 192.168.1.100:9443 then its point ASDM??

Can some one guide how to configure above requirement in current configuration on ASA 5505 8.4(7).

This is my 'show run':

Firewall(config)# sh running-config

: Saved

:

ASA Version 8.4(7)

!

hostname Firewall

domain-name xyz.com

enable password 8Ry2YjytI7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 10.10.10.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address 192.168.1.100 255.255.255.0

!

ftp mode passive

dns server-group DefaultDNS

domain-name xyz.com

object network TEST

host 10.10.10.22

pager lines 24

mtu outside 1500

mtu inside 1500

no failover

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

no arp permit-nonconnected

!

object network TEST

nat (inside,outside) static interface service tcp 8080 8080

!

nat (inside,outside) after-auto source dynamic any interface

route outside 0.0.0.0 0.0.0.0 192.168.1.1 1

timeout xlate 3:00:00

timeout pat-xlate 0:00:30

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

user-identity default-domain LOCAL

aaa authentication http console LOCAL

aaa authentication ssh console LOCAL

http server enable

http 0.0.0.0 0.0.0.0 outside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart

telnet timeout 5

ssh 0.0.0.0 0.0.0.0 outside

ssh timeout 5

ssh version 2

ssh key-exchange group dh-group1-sha1

console timeout 0

dhcpd address 10.10.10.10-10.10.10.100 inside

dhcpd dns 192.168.1.1 10.10.10.1 interface inside

dhcpd domain ramkabir.in interface inside

dhcpd auto_config outside interface inside

dhcpd enable inside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

anyconnect-essentials

username harshil password zGuVcgsszE.QT3iL encrypted privilege 15

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect ip-options

  inspect netbios

  inspect rsh

  inspect rtsp

  inspect skinny

  inspect esmtp

  inspect sqlnet

  inspect sunrpc

  inspect tftp

  inspect sip

  inspect xdmcp

!

service-policy global_policy global

prompt hostname context

Many thanks

Everyone's tags (4)
2 REPLIES

Re: Port forwarding on ASA 5505 ver 8.4(7)

First create a network object-

object network 10.10.10.22-8080

host 10.10.10.22

Then add a NAT

nat (inside,outside) static interface service tcp 8080 8080


You can only have one NAT per object so you'll have to create an object for each port translation

object network 10.10.10.22-554

host 10.10.10.22

nat (inside,outside) static interface service tcp 554 554

object network 10.10.10.22-443

host 10.10.10.22

nat (inside,outside) static interface service tcp 443 443

etc ...

Re: Port forwarding on ASA 5505 ver 8.4(7)

Don't forget the ACL applied to the outside interface as well. Let us know if you need help with that.

1327
Views
5
Helpful
2
Replies
CreatePlease login to create content