Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

PPPoE - The return of the host mask

Seeing the problem described by this old post to NetPro (which has no resolution)...anybody recall or know the resolution?

-------

Hi

I have got a ASA 5510 running 7.2.1.

The outside interface recieves the IP address over pppoe. Normaly you don't need to configure a fix IP with pppoe, but for any reason I don't recieve an IP address until I hardcode it on the ASA. Then when I reboot the ASA the IP address of the outside interface is lost.Further, I'm not able to change the subnetmask, it changes always to a host subnetmask. Has someone already made the same experience? See below the configuration of the outside interface and the pppoe statements.

interface Ethernet0/0

nameif outside

security-level 0

pppoe client vpdn group any

ip address XXX.XXX.XXX.XXX 255.255.255.255 pppoe setroute

vpdn group any request dialout pppoe

vpdn group any localname username@switzerland.net

vpdn group any ppp authentication chap

vpdn username username@switzerland.net password ***** store-local

Best regards

Peter

Show All Messages | E-Mail this Message

Did you configure the ip address to... by cpembleton - Jul 10, 2006, 5:34am PST

Hi Chad, yes I tried it, but I neve... by pwenger - Jul 10, 2006, 6:05am PST

Hi Chad, Sorry to ask the obvious, ... by glen.messenger - Jul 10, 2006, 6:18am PST

Hi Glen I figured out now the bug. ... by pwenger - Jul 11, 2006, 4:49am PST

Posted by: pwenger - System Engineer, CASSARIUS AG - Jul 11, 2006, 4:49am PST

Hi Glen

I figured out now the bug. When I enter the IP address at the outside interface with for example a /30 subnetmask, it takes this command, but for any reason it changes the mask to /32 when you have a look in the running config a few seconds after you entered the command.

See this below:

ciscoasa(config-if)# ip address 213.200.233.189 255.255.255.252 pppoe setroutPPPoE is already enabled on outside interface - now clearing

ciscoasa(config-if)# sh int e0/0

Interface Ethernet0/0 "outside", is up, line protocol is up

Hardware is i82546GB rev03, BW 100 Mbps

Auto-Duplex(Full-duplex), Auto-Speed(100 Mbps)

MAC address 0012.d949.147e, MTU 1500

IP address unassigned

58 packets input, 4483 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 L2 decode drops

61 packets output, 4678 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collisions, 0 deferred

0 lost carrier, 0 no carrier

input queue (curr/max blocks): hardware (1/0) software (0/0)

output queue (curr/max blocks): hardware (0/3) software (0/0)

Traffic Statistics for "outside":

91 packets input, 5419 bytes

61 packets output, 2973 bytes

0 packets dropped

1 minute input rate 1 pkts/sec, 64 bytes/sec

1 minute output rate 0 pkts/sec, 34 bytes/sec

1 minute drop rate, 0 pkts/sec

5 minute input rate 0 pkts/sec, 0 bytes/sec

5 minute output rate 0 pkts/sec, 0 bytes/sec

5 minute drop rate, 0 pkts/sec

ciscoasa(config-if)#

ciscoasa(config-if)#

ciscoasa(config-if)#

ciscoasa(config-if)#

ciscoasa(config-if)#

ciscoasa(config-if)# sh run int e0/0

!

interface Ethernet0/0

nameif outside

security-level 0

pppoe client vpdn group any

ip address 213.200.233.189 255.255.255.252 pppoe setroute

ciscoasa(config-if)#

ciscoasa(config-if)#

ciscoasa(config-if)#

ciscoasa(config-if)# sh run int e0/0

!

interface Ethernet0/0

nameif outside

security-level 0

pppoe client vpdn group any

ip address 213.200.233.189 255.255.255.255 pppoe setroute

ciscoasa(config-if)#

Then when you reboot you get the following message:

ERROR: Bad mask 255.255.255.255 for address 213.200.233.189

*** Output from config line 16, " ip address 213.200.233...."

and for this message there is no IP anymore on the outside interface.

1 REPLY
Community Member

Re: PPPoE - The return of the host mask

Do you have a static IP address assigned to your from you ISP? Post your specific scrubbed config.

473
Views
0
Helpful
1
Replies
CreatePlease to create content