Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

problem with asa 5505 routing,nating

i have the asa 5505 with asdm 6.4(5). my inside lan is 192.168.0.0/24. the outside of asa is connected on lan 10.13.74.0/24 and i need over lan 10.13.74.0/24 connect on lan 10.15.100.0/24. i puted nat rule on asa 5505 and acl rule and users from lan 10.15.100.0/24 can connect on my server, but i can't connect on from inside of asa connecet on lan 10.15.100.0/24 and 10.13.74.0/24. my configuration asa is

Result of the command: "show running-config"

: Saved

:

ASA Version 8.4(2)

!

hostname ciscoasa

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

switchport access vlan 3

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 192.168.0.17 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address 10.13.74.33 255.255.255.0

!

ftp mode passive

object network obj_any

subnet 0.0.0.0 0.0.0.0

object network server

host 192.168.0.20

object service ParagrafLex

service tcp source eq 6190 destination eq 6190

object network sharepoint

host 192.168.0.22

access-list outside_access_in extended permit ip host 10.13.74.35 any

access-list outside_access_in_1 extended permit ip any object server

access-list outside_access_in_1 extended permit object ParagrafLex 10.15.100.0 255.255.255.0 object server

access-list outside_access_in_1 extended permit object ParagrafLex any object server

pager lines 24

logging asdm informational

mtu inside 1500

mtu outside 1500

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

!

object network obj_any

nat (inside,outside) dynamic interface

object network server

nat (any,any) static 10.13.74.34

access-group outside_access_in in interface outside control-plane

access-group outside_access_in_1 in interface outside

route inside 0.0.0.0 0.0.0.0 10.13.74.1 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

user-identity default-domain LOCAL

http server enable

http 192.168.1.0 255.255.255.0 inside

http 10.13.74.0 255.255.255.0 outside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd auto_config outside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny 

  inspect sunrpc

  inspect xdmcp

  inspect sip 

  inspect netbios

  inspect tftp

  inspect ip-options

!

service-policy global_policy global

prompt hostname context

no call-home reporting anonymous

Cryptochecksum:791a1fa6b6fcccaa3177fed821d1f392

: end

what i do that connect on lan 10.15.100.0/24. i cant ping my outside interface, puted rules on acl, i enabled sevice policy rule for icmp ,but nothing. pleas help me

thanks

3 REPLIES
New Member

problem with asa 5505 routing,nating

Hello,

I reviewed the configuration that you attached, and noticed that you have a static translation for one server and the Port Address Translation (PAT) for the internal host. In some cases, the NAT rules with "any,any" keywords can cause some issues with the proxy ARP feature on the ASA.

I would like to suggest you to change the following NAT rule in order to use the following:

Instead of:

object network server

nat (any,any) static 10.13.74.34

Use:

object network server

nat (inside,outside) static 10.13.74.34

Use the following command to enable ICMP inspection:

fixup protocol icmp

Also, please noticed that if you are not able to ping the ASA, you should check the ARP entries of the device that is doing the routing for 10.15.100.0/24 (it seems to be that 10.13.74.1 is the default gateway of the ASA, not sure if that is the routing device that provides connectivity to 10.15.100.0/24). If such device has an ARP entry for 10.13.74.33, it should be associated with the MAC address of the outside interface of the ASA.

Another test would be to try to ping from the ASA to an IP address that belongs to 10.15.100.0/24.

After you hace changed the NAT rules, please attach the show nat detail to this post so I can check if.

Let me know the results.

Thanks.

New Member

problem with asa 5505 routing,nating

my configuration asa 5505 is now

Result of the command: "show running-config"

: Saved

:

ASA Version 8.4(2)

!

hostname ciscoasa

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 192.168.0.17 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address 10.13.74.33 255.255.255.0

!

ftp mode passive

object network obj_any

subnet 0.0.0.0 0.0.0.0

object network server

host 192.168.0.20

object service ParagrafLex

service tcp source eq 6190 destination eq 6190

object network sharepoint

host 192.168.0.22

object network uzzpro

range 10.13.74.40 10.13.74.45

object network share

host 192.168.0.22

object-group network internalnetwork

network-object 192.168.0.0 255.255.255.0

object-group network uzzpro-1

network-object object uzzpro

access-list outside_access_in extended permit ip host 10.13.74.35 any

access-list outside_access_in_1 extended permit ip any object server

access-list outside_access_in_1 extended permit object ParagrafLex 10.15.100.0 255.255.255.0 object server

access-list outside_access_in_1 extended permit object ParagrafLex any object server

access-list outside_access_in_1 extended permit ip any object share

access-list outside_access_in_1 extended permit icmp any object sharepoint echo-reply

access-list inside_access_out extended permit ip any any

pager lines 24

logging asdm informational

mtu inside 1500

mtu outside 1500

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

!

object network obj_any

nat (inside,outside) dynamic interface

object network server

nat (inside,outside) static 10.13.74.34

object network share

nat (any,any) static 10.13.74.39

access-group inside_access_out out interface inside

access-group outside_access_in in interface outside control-plane

access-group outside_access_in_1 in interface outside

route inside 0.0.0.0 0.0.0.0 10.13.74.1 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

user-identity default-domain LOCAL

http server enable

http 192.168.1.0 255.255.255.0 inside

http 10.13.74.0 255.255.255.0 outside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd auto_config outside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny 

  inspect sunrpc

  inspect xdmcp

  inspect sip 

  inspect netbios

  inspect tftp

  inspect ip-options

  inspect icmp

!

service-policy global_policy global

prompt hostname context

no call-home reporting anonymous

Cryptochecksum:cde649be1382dd8249eca185657d9de7

: end

New Member

problem with asa 5505 routing,nating

my network configuration is: the asa 5505 connect LAN inside of asa 5505 (192.168.0.0/24) and WAN side of asa 5505 (10.13.74.0/24). the router is on 10.13.74.1. i want connect my LAN 192.168.0.0 with network 10.15.100.0. The administrator on router 10.13.74.1 is made the routes which connect two network 10.15.100.0 and 10.13.74.0. when i try ping network 10.15.100.0 from asa i can't do it. I also can't ping from my local LAN 192.168.0.0 outside interface, i can't also ping hosts on network 10.13.74.0(WAN side asa 5505). Hosts from Network 10.15.100.0 can ping NAT address of my server 10.13.74.34 and outside interface of my asa 5505.

what i do?

thanks

285
Views
0
Helpful
3
Replies
CreatePlease login to create content