Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

problem with some inside hosts not able to reach the outside interface (asa 5505)

There is a scrubbed config file at the end of this post.       Symptoms:   Some hosts connected to the inside interface cannot reach websites or even ping our gateway, but some can.   They can ping the LAN's gateway and other hosts on the inside, as well as hosts on the second and thir internal VLAN. I have the security plus and the unlimited user upgrade licenses installed.   There are 4 vlans, inside (lan), outside (internet), mz (servers), and dmz (web-facing servers).    Again, some users can reach the internet, and some cannot.    I do not understand why.   Any help is greatly appreciated.


ASA Version 7.2(4)
!
hostname ciscoasa
domain-name communitytech.local
enable password xxx encrypted
passwd xxx encrypted
names
name 10.1.10.20 ad-3
name 10.1.10.32 PhoneSystem
name 10.3.10.61 web-1
name 10.3.10.135 support
name 216.x.x.x support_public
name 216.x.x.x PhoneSystem_public
name 10.3.10.20 apritest
name 216.x.x.x ridev_public
name 10.3.10.24 ridev
name 216.x.x.x web-1_pubic
name 216.x.x.x apritest_public
name 216.x.x.x ad-3_public
!
interface Vlan1
description lan
nameif inside
security-level 100
ip address 10.1.10.1 255.255.255.0
!
interface Vlan2
description internet
nameif outside
security-level 0
ip address 74.x.x.x 255.255.255.240
!
interface Vlan3
description demilitarized zone
nameif dmz
security-level 50
ip address 10.3.10.1 255.255.255.0
!
interface Vlan4
description servers
nameif mz
security-level 100
ip address 10.2.10.1 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
speed 100
!
interface Ethernet0/1
switchport access vlan 3
speed 100
!
interface Ethernet0/2
switchport access vlan 4
speed 100
!
interface Ethernet0/3
speed 100
!
interface Ethernet0/4
speed 100
!
interface Ethernet0/5
speed 100
!
interface Ethernet0/6
speed 100
!
interface Ethernet0/7
speed 100
!
ftp mode passive
clock timezone CST -6
dns domain-lookup inside
dns domain-lookup outside
dns domain-lookup dmz
dns domain-lookup mz
dns server-group DefaultDNS
name-server ad-3
name-server 66.196.212.10
name-server 216.201.128.10
name-server 66.196.216.10
domain-name communitytech.local
same-security-traffic permit inter-interface
access-list dmz_outbound extended permit tcp any any eq smtp
access-list dmz_outbound extended permit tcp any any eq www
access-list dmz_outbound extended permit tcp any any eq https
access-list dmz_outbound extended permit udp any any eq domain
access-list dmz_outbound extended permit tcp any any eq domain
access-list dmz_outbound extended permit icmp any any
access-list dmz_outbound extended permit icmp any any echo
access-list dmz_outbound extended permit icmp any any echo-reply
access-list dmz_outbound extended permit tcp any any eq 137
access-list dmz_outbound extended permit udp any any eq netbios-ns
access-list dmz_outbound extended permit udp any any eq netbios-dgm
access-list dmz_outbound extended permit tcp any any eq 138
access-list dmz_outbound extended permit tcp any any eq 445
access-list dmz_outbound extended permit udp any any eq 445
access-list dmz_outbound extended permit tcp any any eq 5666
access-list dmz_outbound extended permit tcp any any eq ssh
access-list dmz_outbound extended permit gre any any
access-list dmz_outbound extended permit tcp any any eq 3690
access-list dmz_outbound extended permit tcp any any eq 123
access-list dmz_outbound extended permit udp any any eq ntp
access-list dmz_inbound extended permit tcp any any eq smtp
access-list dmz_inbound extended permit tcp any any eq www
access-list dmz_inbound extended permit tcp any any eq https
access-list dmz_inbound extended permit udp any any eq domain
access-list dmz_inbound extended permit tcp any any eq domain
access-list dmz_inbound extended permit icmp any any
access-list dmz_inbound extended permit icmp any any echo
access-list dmz_inbound extended permit icmp any any echo-reply
access-list dmz_inbound extended permit tcp any any eq 137
access-list dmz_inbound extended permit udp any any eq netbios-ns
access-list dmz_inbound extended permit udp any any eq netbios-dgm
access-list dmz_inbound extended permit tcp any any eq 138
access-list dmz_inbound extended permit tcp any any eq 445
access-list dmz_inbound extended permit udp any any eq 445
access-list dmz_inbound extended permit tcp any any eq 5666
access-list dmz_inbound extended permit tcp any any eq ssh
access-list dmz_inbound extended permit gre any any
access-list dmz_inbound extended permit tcp any any eq 3690
access-list dmz_inbound extended permit udp any any eq ntp
access-list dmz_inbound extended permit tcp any any eq 123
access-list dmz_inbound extended permit tcp any any eq 3309
access-list outside_inbound extended permit icmp any any
access-list outside_inbound extended permit icmp any any echo
access-list outside_inbound extended permit icmp any any echo-reply
access-list outside_inbound extended permit udp any any eq domain
access-list outside_inbound extended permit tcp any any eq domain
access-list outside_inbound extended permit tcp any any eq 137
access-list outside_inbound extended permit udp any any eq netbios-ns
access-list outside_inbound extended permit udp any any eq netbios-dgm
access-list outside_inbound extended permit tcp any any eq 138
access-list outside_inbound extended permit tcp any any eq 445
access-list outside_inbound extended permit udp any any eq 445
access-list outside_inbound extended permit tcp any any eq 5666
access-list outside_inbound extended permit tcp any any eq smtp
access-list outside_inbound extended permit tcp any any eq www
access-list outside_inbound extended permit tcp any any eq https
access-list outside_inbound extended permit tcp any any eq pptp
access-list outside_inbound extended permit tcp any any eq ssh
access-list outside_inbound extended permit gre any host ad-3
access-list outside_inbound extended permit tcp any host ad-3
access-list outside_inbound extended permit tcp any any eq 3690
access-list outside_inbound extended permit gre any any
access-list outside_inbound extended permit tcp any any eq 123
access-list outside_inbound extended permit udp any any eq ntp
pager lines 24
logging enable
logging asdm warnings
mtu inside 1500
mtu outside 1500
mtu dmz 1500
mtu mz 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 216.x.x.x-216.x.x.x
global (outside) 1 74.x.x.x-74.x.x.x
global (outside) 1 interface
nat (inside) 1 10.1.10.0 255.255.255.0
static (dmz,outside) tcp apritest_public https apritest https netmask 255.255.255.255
static (dmz,outside) tcp apritest_public www apritest www netmask 255.255.255.255
static (dmz,outside) tcp support_public www support www netmask 255.255.255.255
static (dmz,outside) tcp support_public https support https netmask 255.255.255.255
static (dmz,outside) tcp web-1_pubic https web-1 https netmask 255.255.255.255
static (dmz,outside) tcp web-1_pubic www web-1 www netmask 255.255.255.255
static (dmz,outside) tcp apritest_public ssh apritest ssh netmask 255.255.255.255
static (dmz,outside) tcp ridev_public ssh ridev ssh netmask 255.255.255.255
static (dmz,outside) tcp ridev_public www ridev www netmask 255.255.255.255
static (dmz,outside) tcp ridev_public https ridev https netmask 255.255.255.255
static (dmz,outside) tcp support_public 3690 support 3690 netmask 255.255.255.255
static (inside,outside) tcp ad-3_public pptp ad-3 pptp netmask 255.255.255.255
static (inside,mz) 10.1.10.0 10.1.10.0 netmask 255.255.255.0
static (inside,dmz) 10.1.10.0 10.1.10.0 netmask 255.255.255.0
static (dmz,inside) 10.3.10.0 10.3.10.0 netmask 255.255.255.0
static (inside,outside) ad-3_public ad-3 netmask 255.255.255.255
access-group outside_inbound in interface outside
access-group dmz_inbound in interface dmz
access-group dmz_outbound out interface dmz
route outside 0.0.0.0 0.0.0.0 74.213.6.97 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 10.1.10.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh 10.1.10.0 255.255.255.0 inside
ssh timeout 30
console timeout 0

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect icmp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:cea3539f83e1a40cd1c325eaa14c0cee

Everyone's tags (3)
8 REPLIES
Cisco Employee

Re: problem with some inside hosts not able to reach the outsid

Please tell us with ip are failing what is their destination and what interface they are behind.

PK

Community Member

Re: problem with some inside hosts not able to reach the outsid

I can ping any IP behind the firewall.     All the vlans (except outside) can ping and access each other.       Hosts behind the dmz and mz vlans have no issues.     Some hosts on the inside interface (our workstations) can ping the outside world (our ISP's router, google, etc).    Some cannot ping anything on the outside vlan at all.   They cannot load webpages.    It doesn't not give a "server" not found error, but rather a "server" responding too slow error.  For other hosts on the inside interface, none of this happens.  

to summarize:

Inside hosts (not all) fail to communicate with anything attached to the outside interface (which is only connected to our ISP's router via a crossover cable).

They cannot ping either of the gateways we have available (both the 216.x.x.x subnet and the 74.x.x.x subnet)

They cannot ping google, cnn, or any other external hosts.

They are all connnected to the inside interface (the LAN).

Community Member

Re: problem with some inside hosts not able to reach the outsid

When I do the "show local-host detail" command, this is the output:

Interface mz: 0 active, 8 maximum active, 0 denied
Interface dmz: 0 active, 6 maximum active, 0 denied
Interface outside: 0 active, 92 maximum active, 0 denied
Interface inside: 1 active, 22 maximum active, 0 denied
Interface _internal_loopback: 0 active, 0 maximum active, 0 denied


on the inside interface is says 22 maximum active... is this the max number of hosts that can connect to the inside interface?   I thought i could have an unlimited number of connections?

Cisco Employee

Re: problem with some inside hosts not able to reach the outsid

The maximum active is the maximum number of conns the interface saw at any point.

PK

Community Member

Re: problem with some inside hosts not able to reach the outsid

That makes sense.     Any obvious errors in the posted config file?

Cisco Employee

Re: problem with some inside hosts not able to reach the outsid

No obvious errors.

Please enable logging and get the logs while you initiate a failure. Make sure you keep the ip of the computer failing and lets check what the logs say.

PK

Bronze

Re: problem with some inside hosts not able to reach the outsid

- How many IPs do you have in these ranges?

global (outside) 1 216.x.x.x-216.x.x.x
global (outside) 1 74.x.x.x-74.x.x.x

- How many inside hosts do you have?

- Have you tested to see, for the working client PCs, which of those two pools they're getting IPs from?

- (If neither) Are the client PCs taking on the outside IP of the firewall?

-> You can see what the IP is by visiting www.whatismyip.com on the working clients

James

Cisco Employee

Re: problem with some inside hosts not able to reach the outsid

James,

Pls. enable logging and add "logging buffered 7" and watch the logs for these inside IPs that have trouble reaching the internet.

sh logg | i x.x.x.x

where x.x.x.x is the IP of the problem client on the inside.

you are patting to the interface so, you should be able to provide translation for the inside host.  In any case what ever the problem is logs will show you what is wrong. If you don't see it in the logs may be the buffer logs are wraping too quickly and you can increase the buffer size

logging buffer-size 1048576

clear logg buff

and then try the "sh logg | i x.x.x.x" again.

Let us know what you see.

Remember for any flow to work through the firewall you need RTP

Route

Translation

Permission

-KS

1068
Views
0
Helpful
8
Replies
CreatePlease to create content