Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

"Duplicate IP address" with ASA inside interface - proxyarp/VPN

We've had issues with our Exchange 2010 server (running on ESXi 4.1) since its default gateway was changed to our new ASA 5510.  They manifested as frequent Outlook client connection dropouts or as IP address conflicts whenever Exchange was rebooted.  The temporary fix was to disable the Exchange server NIC, bounce the ASA and enable the server's NIC again.  We saw poor performance from Exchange after a while again, but after some research and testing I realised that disabling proxyarp on the inside interface fixed the problem permanently.

However I've now realised that the client VPN no longer routes properly because proxyarp is disabled on the inside interface, so I still have a problem.

Can anyone think of a way to stop the ASA grabbing hold of the Exchange server's IP address, but allow the VPN traffic to come in on the inside interface?

  • Firewalling
Everyone's tags (8)
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

"Duplicate IP address" with ASA inside interface - proxyarp/VPN

HI Gareth

Do you have the VPN pool address overlapping the lan addresses?

Craig

10 REPLIES
New Member

"Duplicate IP address" with ASA inside interface - proxyarp/VPN

HI Gareth

Do you have the VPN pool address overlapping the lan addresses?

Craig

New Member

"Duplicate IP address" with ASA inside interface - proxyarp/VPN

Hi Craig, I don't believe so.  The VPN pool was functioning perfectly right up till I disabled proxyarp.

New Member

"Duplicate IP address" with ASA inside interface - proxyarp/VPN

Hi Gareth

Are you able to post the configuration, omit any sensitive inforation.

Regards Craig

New Member

Re: "Duplicate IP address" with ASA inside interface - proxyarp/

Here's the edited config.  Basically the Exchange server has a NAT rule to allow http/https/smtp, which is how the ARP issue arose.  Would the ARPRetryCount command be any use, if I enable proxyarp again?

: Written by enable_15 at 11:01:37.416 UTC Tue Apr 3 2012

!

ASA Version 8.2(5)

!

hostname

enable password xxxxxxxxxxxxxxxx encrypted

passwd xxxxxxxxxxxxxxxx encrypted

names

name 10.48.254.0 vpnclients-network

name srvex01-external

name 10.48.1.3 srvex01-internal

name scotty-external

!

interface Ethernet0/0

nameif outside

security-level 0

ip address 255.255.255.248

!

interface Ethernet0/1

nameif inside

security-level 100

ip address 10.48.1.254 255.255.0.0

!

interface Ethernet0/2

shutdown

no nameif

no security-level

no ip address

!

interface Ethernet0/3

shutdown

no nameif

no security-level

no ip address

!

interface Management0/0

shutdown

nameif management

security-level 0

no ip address

management-only

!

ftp mode passive

object-group service DM_INLINE_TCP_1 tcp

port-object eq www

port-object eq https

port-object eq smtp

access-list inside_nat0_outbound extended permit ip any vpnclients-network 255.255.255.192

access-list outside_access_in extended permit tcp any host srvex01-external object-group DM_INLINE_TCP_1

pager lines 24

logging enable

logging asdm informational

mtu outside 1500

mtu inside 1500

mtu management 1500

ip local pool vpnclients 10.48.254.1-10.48.254.32 mask 255.255.0.0

icmp unreachable rate-limit 1 burst-size 1

icmp deny any outside

no asdm history enable

arp timeout 14400

global (outside) 101 interface

nat (inside) 0 access-list inside_nat0_outbound

nat (inside) 101 0.0.0.0 0.0.0.0

static (inside,outside) srvex01-external srvex01-internal netmask 255.255.255.255

static (outside,inside) srvex01-internal srvex01-external netmask 255.255.255.255

access-group outside_access_in in interface outside

route outside 0.0.0.0 0.0.0.0 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

http server enable

http 10.48.0.0 255.255.0.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

sysopt noproxyarp inside

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map outside_map interface outside

crypto isakmp enable outside

crypto isakmp policy 10

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 86400

telnet timeout 5

ssh timeout 5

console timeout 0

threat-detection basic-threat

threat-detection statistics access-list

threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200

ntp server 10.48.1.2 source inside

webvpn

group-policy DfltGrpPolicy attributes

banner value ** Warning: you are connecting to the network. **

banner value

banner value This connection is for authorised users only.  If you are not authorised to use this connection you should disconnect immediately.  For acceptable use guidelines please refer to the Company IT Policy (HR 062).

group-policy clientvpn internal

group-policy clientvpn attributes

dns-server value 10.48.1.2

vpn-tunnel-protocol IPSec

default-domain value .local

username password oMmrrMbNRhqeKCzM encrypted privilege 0

username attributes

vpn-group-policy clientvpn

username password CPuKILOZBCZIv1IN encrypted privilege 0

username attributes

vpn-group-policy clientvpn

tunnel-group clientvpn type remote-access

tunnel-group clientvpn general-attributes

address-pool vpnclients

default-group-policy clientvpn

tunnel-group clientvpn ipsec-attributes

pre-shared-key *

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect sqlnet

  inspect skinny 

  inspect sunrpc

  inspect xdmcp

  inspect sip 

  inspect netbios

  inspect tftp

  inspect ip-options

!

service-policy global_policy global

prompt hostname context

no call-home reporting anonymous

Cryptochecksum:fc67b04ada9eb738b4a9f63b93cb1400

New Member

"Duplicate IP address" with ASA inside interface - proxyarp/VPN

Hi Gareth

Looking at your configuration the inside network has a class B so the VPN clients are assigned address that overlap with the assigned addresses.

Please see the following.

Overlapping Private Networks

Problem

If you are unable to access the internal network after the tunnel establishment, check the IP address assigned to the VPN client that overlaps with the internal network behind the head-end device.

Solution

Always make sure that the IP addresses in the pool to be assigned for the VPN clients, the internal network of the head-end device and the VPN Client internal network must be in different networks. You can assign the same major network with different subnets, but sometimes the routing issues occur.

Regards Craig

New Member

"Duplicate IP address" with ASA inside interface - proxyarp/VPN

Thanks Craig, so perhaps the VPN only worked correctly beforehand was  because the proxyarp was making up the shortfall?  Would you suggest a  completely different subnet?

New Member

"Duplicate IP address" with ASA inside interface - proxyarp/VPN

Hi

That sounds correct, yeah I would use a different subnet (not used anywhere in the network).

Regards Craig

New Member

"Duplicate IP address" with ASA inside interface - proxyarp/VPN

Thanks Craig, I think you're right as I've found another thread with a similar issue to mine and the same answer -

https://supportforums.cisco.com/message/885685#885685

I tried changing the vpnclients subnet to something completely different and it really upset one of our older switches on the LAN and caused chaos!

The business is really busy this weekend with easter, so I'll wait till next week before trying this again and cycling the old switch afterwards if need be. 

New Member

Re: "Duplicate IP address" with ASA inside interface - proxyarp/

Thanks Craig you were spot on.  I also had to go into Routing and Remote Access on our old ISA server (the LAN's current default gateway) and create a static route for the VPN traffic before I could close out the issue.

6438
Views
0
Helpful
10
Replies
This widget could not be displayed.