Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

Random (extremely brief) disconnects on ASA 5505

Hello all,

I am dealing with a frustrating issue.  Most of our sites are experiencing extremely brief interruptions in their internet connectivity. Basically, we have upgraded all of our ASA’s (One 5510 and 10 5505’s) from version 7.2(4) to version 9.1(2). We let the ASA ‘migrate’ incrementally as required/recommended by Cisco. We then made the required adjustments to get the configs to work properly and thought all was well.

The first thing we noticed was that our RDP sessions (over L2L VPN) would disconnect repeatedly, especially if we tried to transfer large amounts of data over them. We then got disconnect complaints from one site that uses a piece of software that needs constant communication with a remote site over an Anyconnect session.

I swapped out the ASA with a spare unit, downgraded to version 8.4.7 but the issue persists. I’m leaning towards a config problem, but I’m no pro when it comes to the Cisco gear. All of the sites use the same config (with appropriate changes) and most have this problem, but two don’t.

In the end, I went back to version 7.2(4) and the original configuration to fix the problem. What could be going on? I really want to run more current software, but I can’t have this issue as it’s too disruptive.

Thanks!

Z

Also, I know that 192.9.201.x should not be used internally, that's something we're going to fix another day.

: Saved
:
ASA Version 9.1(2)
!
hostname T5505
enable password edited encrypted
passwd edited encrypted
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.9.201.254 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 1.2.3.52 255.255.255.248
!
banner motd *********************************WARNING!!!*********************************
banner motd UNAUTHORIZED USE IS PROHIBITED!!!
banner motd This system is solely for the use of authorized users for official purposes.
banner motd You have no expectation of privacy in its use and to ensure that the system
banner motd is functioning properly, individuals using this computer system are subject
banner motd to having all of their activities monitored and recorded by system
banner motd personnel.  Use of this system evidences an express consent to such
banner motd monitoring and agreement that if such monitoring reveals evidence of
banner motd possible abuse or criminal activity, system personnel may provide the
banner motd results of such monitoring to appropriate officials.
banner motd ****************************************************************************
banner asdm *************************WARNING!!!*************************
banner asdm UNAUTHORIZED USE IS PROHIBITED!!!
banner asdm This system is solely for the use of authorized users for official purposes.
banner asdm You have no expectation of privacy in its use and to ensure that the system
banner asdm is functioning properly, individuals using this computer system are subject
banner asdm to having all of their activities monitored and recorded by system
banner asdm personnel.  Use of this system evidences an express consent to such
banner asdm monitoring and agreement that if such monitoring reveals evidence of
banner asdm possible abuse or criminal activity, system personnel may provide the
banner asdm results of such monitoring to appropriate officials.
banner asdm ************************************************************
boot system disk0:/asa912-k8.bin
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network obj_any
subnet 0.0.0.0 0.0.0.0
object network obj-192.9.201.0
subnet 192.9.201.0 255.255.255.0
object network obj-192.168.0.0
subnet 192.168.0.0 255.255.255.0
access-list inside_access_in extended permit ip object obj-192.9.201.0 object obj-192.168.0.0
access-list inside_access_in extended permit ip object obj-192.9.201.0 any4
access-list outside_1_cryptomap extended permit ip object obj-192.9.201.0 object obj-192.168.0.0
access-list inside_nat0_outbound extended permit ip 192.9.201.0 255.255.255.0 192.168.0.0 255.255.255.0
access-list outside_nat0_outbound extended permit ip any4 object obj-192.9.201.0
access-list outside_nat0_inbound extended permit ip 192.168.0.0 255.255.255.0 192.9.201.0 255.255.255.0
access-list outside_access_in extended permit ip object obj-192.168.0.0 object obj-192.9.201.0
access-list default_rip_in_acl standard deny any4
access-list default_rip_out_acl standard permit host 0.0.0.0
access-list default_out_rip_acl standard deny any4
pager lines 40
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,outside) source static obj-192.9.201.0 obj-192.9.201.0 destination static obj-192.168.0.0 obj-192.168.0.0 no-proxy-arp route-lookup
nat (inside,outside) source dynamic obj_any interface
!
object network obj_any
nat (inside,outside) dynamic interface
object network obj-192.9.201.0
nat (inside,outside) dynamic interface
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
!
route outside 0.0.0.0 0.0.0.0 1.2.3.49 1
route outside 192.168.0.0 255.255.255.0 5.6.7.158 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
nac-policy DfltGrpPolicy-nac-framework-create nac-framework
reval-period 36000
sq-period 300
aaa authentication telnet console LOCAL
aaa authentication ssh console LOCAL
http server enable
http 192.9.201.0 255.255.255.0 inside
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association pmtu-aging infinite
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set peer 5.6.7.158
crypto map outside_map 1 set ikev1 transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto ca trustpool policy
crypto ca certificate map DefaultCertificateMap 1
crypto isakmp identity address
crypto isakmp nat-traversal 21
crypto ikev1 enable outside
crypto ikev1 policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime none
telnet 192.9.201.0 255.255.255.0 inside
telnet 192.168.0.0 255.255.255.0 inside
telnet timeout 60
ssh 192.9.201.0 255.255.255.0 inside
ssh 192.168.0.0 255.255.255.0 inside
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
management-access inside

dhcpd lease 28800
dhcpd auto_config outside
!
dhcpd address 192.9.201.128-192.9.201.155 inside
dhcpd dns 209.18.47.61 209.18.47.62 interface inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics host
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ssl encryption des-sha1 rc4-md5
group-policy DfltGrpPolicy attributes
vpn-idle-timeout none
ipsec-udp enable
nac-settings value DfltGrpPolicy-nac-framework-create
tunnel-group 5.6.7.158 type ipsec-l2l
tunnel-group 5.6.7.158 ipsec-attributes
ikev1 pre-shared-key ****
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect icmp
class class-default
  user-statistics accounting
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:667a3d855e4f3dd05239b794d2fe488b
: end

144
Views
0
Helpful
0
Replies
CreatePlease to create content