Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
New Member

ROUTER ADSL 800 WITH A FIREWALL

Hello,

I want to configure a router CISCO 800 adsl, with a firewall behind. Does somebody have some configuration of this type?. Do I need two public ip, one for the router and another for the fire wall? Or with a public ip it is enough? In other router marks (3com, etc) the public ip has it the firewall the router only makes of switch, but with Cisco I have not configured none, with a firewall behind

Thank you for the attention

2 REPLIES

Re: ROUTER ADSL 800 WITH A FIREWALL

Hi,

You can use either one public IP (and PAT to router IP) or more. The more, the better in terms of services (VPN, server available from the internet and so on).

Everything you wanted to know about 800:

http://cisco.com/en/US/products/hw/routers/ps380/prod_configuration_examples_list.html

Please rate if this helped.

Regards,

Daniel

New Member

Re: ROUTER ADSL 800 WITH A FIREWALL

Hwllo,

You will need a public address for the router and one for the external interface of the firewall.

The router is then setup as ip unnumbered as shown below.

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname router

!

boot-start-marker

boot-end-marker

!

enable secret 5

!

no aaa new-model

!

resource policy

!

!

!

ip cef

no ip domain lookup

!

!

!

username router password router

!

!

!

!

!

interface Ethernet0

description ### Connected to Firewall ###

ip address x.x.x.x 255.255.255.x

hold-queue 100 out

!

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

hold-queue 224 in

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface FastEthernet1

duplex auto

speed auto

!

interface FastEthernet2

duplex auto

speed auto

!

interface FastEthernet3

duplex auto

speed auto

!

interface FastEthernet4

duplex auto

speed auto

!

interface Dialer1

description ### Connection to Internet ###

ip unnumbered Ethernet0

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp chap hostname

ppp chap password

!

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

no ip http secure-server

!

!

dialer-list 1 protocol ip permit

!

control-plane

!

!

line con 0

password

logging synchronous

login

no modem enable

transport output all

line aux 0

transport output all

line vty 0 4

password

logging synchronous

login

transport input all

transport output all

!

scheduler max-task-time 5000

end

Andy.

233
Views
0
Helpful
2
Replies
CreatePlease to create content