Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Setting up my first firewall

Hello,

I am setting up 2 PIX 506E's as firewalls. I am not Cisco trained or certified and I'm trying to figure some of this stuff out as I go. Not the ideal situation, but we're a nonprofit without tons of cash for training so there it is.

Anyway, I do have over 20 years in IT so I'm not completely lost, but I am stuck on this particular problem. My 506E will not let me ping the outside interface from the inside interface. It does let me ping the inside interface from a computer on the inside network. I am hoping someone can give me a command to allow pinging the outside interface from the inside network.

I would paste my config here but I'm not sure which parts are relevant and I don't want to go over the character limit.

Thanks.

JP

2 ACCEPTED SOLUTIONS

Accepted Solutions
Green

Re: Setting up my first firewall

You acl is wrong, you do not refer to the destination by the private ip address.

access-list inbound permit tcp any host 192.168.2.1 eq www

should be...

access-list inbound permit tcp any host 200.1.1.2 eq www

Green

Re: Setting up my first firewall

no access-group inbound in interface inside

13 REPLIES
Hall of Fame Super Blue

Re: Setting up my first firewall

Hi JP

You can't do this on the pix at least on version 6.x which you are probably using as a pix 506E desn't support v7.x.

You can ping the inside interface from a machien on the inside and you can ping the outside interface from a machine on the outside but not the outside interface from the inside.

HTH

Jon

By the way, your config would probably not go over the limit and you can always attacj the config as a text file. Just make sure you remove any sensitive information.

New Member

Re: Setting up my first firewall

Thank you, you probably saved me 4 days of reading.

By the way, anyone who can point me to free newbie webcasts (video or audio) or even print courses, I would appreciate it. I belong to IEEE Computer, so I'll be looking there as well.

Just for kicks, here's my config (yes, it's much smaller than I feared, all the networks are internal and please don't laugh at the newbie)

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list acl_outbound permit ip any any

access-list acl_outbound permit tcp any any

access-list outside permit icmp any any

access-list outside permit ip any any

access-list inside permit icmp any any

access-list inside permit ip any any

access-list outbound permit tcp any host 192.168.2.254

access-list outbound permit icmp any host 192.168.2.254

access-list 90 permit ip 192.168.1.0 255.255.255.0 200.1.1.0 255.255.255.0

pager lines 40

mtu outside 1500

mtu inside 1500

ip address outside 200.1.1.1 255.255.255.0

ip address inside 192.168.2.254 255.255.255.0

ip audit info action alarm

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

aaa authentication telnet console LOCAL

aaa authentication http console LOCAL

http server enable

http 192.168.2.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt noproxyarp outside

telnet 192.168.2.0 255.255.255.0 inside

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd auto_config outside

username administrator password xxxxxxxxxxxxx encrypted privilege 15

terminal width 80

Cryptochecksum:xxxxxxxxxxxxxxxxxxxxxx

: end

New Member

Re: Setting up my first firewall

OK, here's some more of the problem - since I can't ping my external interface, can I ping another address on the same network as that interface? My understanding is that there's no communication from a lower-security interface to a higher-security interface, but isn't internet communication almost always two-way? That's what ACL's are for, isn't it? So could I set up an ACL to allow an ICMP packet through the 506e, or is it ICMP specifically that's not allowed through?

Thanks,

JP

Green

Re: Setting up my first firewall

"since I can't ping my external interface, can I ping another address on the same network as that interface?"

Yes, you can ping from the inside to something outside the pix with the correct acl to allow the ping reply in the outside interface.

" My understanding is that there's no communication from a lower-security interface to a higher-security interface, but isn't internet communication almost always two-way?"

Yes, there is no communication allowed from lower to higher security levels unless allowed by an acl. Yes, it is two way but the traffic is "initiated" from the inside, not the outside.

"So could I set up an ACL to allow an ICMP packet through the 506e, or is it ICMP specifically that's not allowed through?"

Sure, you already have it in your config...

access-list outside permit icmp any any

only problem is none of your acl's are applied with the "access-group" command.

access-group outside in interface outside

New Member

Re: Setting up my first firewall

Thank you. I did that, and I have the other PIX on the outside network, interface ip = 200.1.1.2. After applying the access-group, I tried to ping that second pix from inside my first pix, and I'm getting a "request timed out". I am able to ping the second pix from the CLI on the first pix. Any thoughts?

Thanks!

Green

Re: Setting up my first firewall

global (outside) 1 interface

nat (inside) 1 0.0.0.0 0.0.0.0

New Member

Re: Setting up my first firewall

wrong post

New Member

Re: Setting up my first firewall

Thanks for the suggestion, that's exactly what I needed. I am now able to ping other ip's on my outside network. Thanks very much to everyone who helped!

New Member

Re: Setting up my first firewall

Now I have the second PIX set up identical to the first one, but that's not quite right. I want to have a web server inside pix2, able to be accessed by a client on the inside interface of pix1. The outside interfaces of pix1 and pix2 are on the same network, connected through a hub. As I have said before in this post, I can now ping from inside pix1 to the outside of pix2. I have tried to follow directions to set up a static, an access-list, and an access-group to allow access to a web server inside pix2 but I can't access it either from a host on the 200.1.1.0 network (the outside interface network) or from a host on the inside network of pix1. I've pasted my current configs (which are different than the configs from before) and I wonder if anyone has suggestions.

Thanks.

JP

--------------------------

pixfirewall2(config)# sho run

: Saved

:

PIX Version 6.3(5)

interface ethernet0 auto

interface ethernet1 auto

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password xxx encrypted

passwd xxx encrypted

hostname pixfirewall2

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list inbound permit tcp any host 192.168.2.1 eq www

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside 200.1.1.2 255.255.255.0

ip address inside 192.168.2.254 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

static (inside,outside) tcp interface www 192.168.2.1 www netmask 255.255.255.255 0 0

access-group inbound in interface outside

access-group inbound in interface inside

route outside 0.0.0.0 0.0.0.0 200.1.1.1 1

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

aaa authentication telnet console LOCAL

aaa authentication http console LOCAL

http server enable

http 192.168.2.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

telnet 192.168.2.0 255.255.255.0 inside

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd auto_config outside

username administrator password xxx encrypted privilege 15

terminal width 80

Cryptochecksum:xxx

: end

-------------------

Green

Re: Setting up my first firewall

You acl is wrong, you do not refer to the destination by the private ip address.

access-list inbound permit tcp any host 192.168.2.1 eq www

should be...

access-list inbound permit tcp any host 200.1.1.2 eq www

New Member

Re: Setting up my first firewall

Thanks - that did it. Now for the VPN!

New Member

Re: Setting up my first firewall

While I'm at it, if anyone sees anything in my configs that should be removed, I'm accepting comments. Thanks.

Green

Re: Setting up my first firewall

no access-group inbound in interface inside

171
Views
5
Helpful
13
Replies
CreatePlease to create content