Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Trunk port configuration on ASA

Hi All,

Do i need to configure trunk configuration on ASA interface which is carrying multiple VLAN traffic ?

Thanks

Madan

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Trunk port configuration on ASA

Just leave the physical interface as it is

Your config steps would be something like this...

int e0/1

no shut

hostname(config)# interface ethernet0/1.1

hostname(config-subif)# vlan 100

hostname(config-subif)# nameif inside100

hostname(config-subif)# security-level 100

hostname(config-subif)# ip address 10.0.0.1 255.255.255.0

hostname(config)# interface ethernet0/1.2

hostname(config-subif)# vlan 200

hostname(config-subif)# nameif inside200

hostname(config-subif)# security-level 100

hostname(config-subif)# ip address 20.0.0.1 255.255.255.0

For more you can refer here

http://www.cisco.com/en/US/docs/security/asa/asa72/configuration/guide/intrface.html#wp1044006

3 REPLIES

Re: Trunk port configuration on ASA

Hi,

On the ASA interface you need to create subinterfaces and put the VLAN id. And connect the physical port to the Trunk port on the switch.

Suppose if you are creating subinterfaces for interface e0/1 for vlans 100 and 200,

hostname(config)# interface ethernet0/1.1

hostname(config-subif)# vlan 100

hostname(config)# interface ethernet0/1.2

hostname(config-subif)# vlan 200

New Member

Re: Trunk port configuration on ASA

What about the interface configuration

Interface e0/1 ?

Re: Trunk port configuration on ASA

Just leave the physical interface as it is

Your config steps would be something like this...

int e0/1

no shut

hostname(config)# interface ethernet0/1.1

hostname(config-subif)# vlan 100

hostname(config-subif)# nameif inside100

hostname(config-subif)# security-level 100

hostname(config-subif)# ip address 10.0.0.1 255.255.255.0

hostname(config)# interface ethernet0/1.2

hostname(config-subif)# vlan 200

hostname(config-subif)# nameif inside200

hostname(config-subif)# security-level 100

hostname(config-subif)# ip address 20.0.0.1 255.255.255.0

For more you can refer here

http://www.cisco.com/en/US/docs/security/asa/asa72/configuration/guide/intrface.html#wp1044006

509
Views
0
Helpful
3
Replies