Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Unable to ping from ASA to directly connected switch

Hi Everyone,

I am working on new setup where switch is directly connected to ASA.

ASA int config

interface GigabitEthernet0/2

no nameif

no security-level

no ip address

!

interface GigabitEthernet0/2.1

description Central_Visitor

vlan 360

nameif CentralVisitor

security-level 50

ip address 192.168.1.3 255.255.255.128

!

interface GigabitEthernet0/2.2

vlan 2

nameif MGMT

security-level 90

ip address 10.31.2.3 255.255.255.240

interface GigabitEthernet0/2

no nameif

no security-level

no ip address

!

Switch has vlan 2 as management vlan and has default gateway to ASA  IP 10.31.2.3.

all inetrfaces are up up at both devices.

from switch i am unable to ping its default gateway which is ASA  IP 10.31.2.3.

Regards

Mahesh

2 ACCEPTED SOLUTIONS

Accepted Solutions

Unable to ping from ASA to directly connected switch

Hello Mahesh,

Can you share the interface configuration from the SWITCH (SVI and Trunk to the ASA)?

Rate all of the helpful posts!!!

Regards,

Jcarvaja

Follow me on http://laguiadelnetworking.com

Looking for some Networking Assistance? Contact me directly at jcarvaja@laguiadelnetworking.com I will fix your problem ASAP. Cheers, Julio Carvajal Segura http://laguiadelnetworking.com

Unable to ping from ASA to directly connected switch

Hello Mahesh,

Excellent sometimes we just need to look twice to see those kind of things

Rate all of the helpful posts!!!

Regards,

Jcarvaja

Follow me on http://laguiadelnetworking.com

Looking for some Networking Assistance? Contact me directly at jcarvaja@laguiadelnetworking.com I will fix your problem ASAP. Cheers, Julio Carvajal Segura http://laguiadelnetworking.com
5 REPLIES

Unable to ping from ASA to directly connected switch

Hello Mahesh,

Can you share the interface configuration from the SWITCH (SVI and Trunk to the ASA)?

Rate all of the helpful posts!!!

Regards,

Jcarvaja

Follow me on http://laguiadelnetworking.com

Looking for some Networking Assistance? Contact me directly at jcarvaja@laguiadelnetworking.com I will fix your problem ASAP. Cheers, Julio Carvajal Segura http://laguiadelnetworking.com
New Member

Unable to ping from ASA to directly connected switch

Hi Julio,

Seems no switch port is configured as trunk.

h run int gigabitEthernet 0/1
Building configuration...

Current configuration : 110 bytes
!
interface GigabitEthernet0/1
  switchport access vlan 2
switchport mode access

Regards

Mahesh

New Member

Re: Unable to ping from ASA to directly connected switch

Had you creat the SVI on the swith for the VLAN 2 .. if not then do the follwoing steps :

int vlan 2

ip add 10.31.2.X  X.X.X.X

then start the ping.

New Member

Unable to ping from ASA to directly connected switch

Hi Julio,

Switch side was set to access port and thats the reason port was showing up up on both ends.

But switch port was not learning mac address from Firewall mode.

I changed switch port to trunk and ping works fine now.

Regards

Mahesh

Unable to ping from ASA to directly connected switch

Hello Mahesh,

Excellent sometimes we just need to look twice to see those kind of things

Rate all of the helpful posts!!!

Regards,

Jcarvaja

Follow me on http://laguiadelnetworking.com

Looking for some Networking Assistance? Contact me directly at jcarvaja@laguiadelnetworking.com I will fix your problem ASAP. Cheers, Julio Carvajal Segura http://laguiadelnetworking.com
357
Views
0
Helpful
5
Replies