Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Upgrade FWSM 2.3(3) to which version?

Hi Sir,

I implemented FWSMs (software version 2.3(3)) on a pair of Cisco Catalyst 6513 (Native IOS) about a year ago.

So far, there are issues occassionally, such as unexpected failover, FWSM hang, etc.

I just checked Software Download on cisco.com. There are newer versions, e.g. 2.3(3.2), 2.3(4), 3.1(1), and 3.1(3).

What's the most stable version would you recommend for me to upgrade my version 2.3(3) to?

Thank you.

B.Rgds,

Lim TS

4 REPLIES

Re: Upgrade FWSM 2.3(3) to which version?

Hello Lim,

log onto CCO and get the release notes of these softwares. See for the open caveats and feature advancements and select the right software.. People would normally look at putting the latest software, but just have a look at the release notes...

hope this helps..

Raj

Bronze

Re: Upgrade FWSM 2.3(3) to which version?

Hello,

My recommendation is to either go with the latest/greatest version 3.1(3)9 (interim release, fixes some bugs) - but I'm not sure I have a lot of faith in the 3.1 code right now.

Personally, I'd go to 2.3(4) or wait a few months for the 3.1 train to work some more bugs out.

--Jason

Please rate this message if it solved some or all of your issue.

New Member

Re: Upgrade FWSM 2.3(3) to which version?

Hi Jason,

Thanks for the info.

Is there a drastic change in 3.1 code compared to 2.3 code, in terms of features, CLI commands, etc? Something like the PIX software 6.3 -> 7.x.

Your suggestion is good to go to 2.3(4) first and wait a few months for the 3.1 train. I most likely will upgrade it to 2.3(4).

Please advise further.

Thank you.

B.Rgds,

Lim TS

Bronze

Re: Upgrade FWSM 2.3(3) to which version?

Lim,

You are exactly correct. Going to the 3.x train from FWSM 2.3 is just like going to the 7.x train from pix 6.3. A lot more features, but because so much of the code is new/re-written, a lot more bugs.

--Jason

317
Views
0
Helpful
4
Replies
CreatePlease to create content