Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
New Member

Wan failover asa5505

Hi

I have a asa5505 with sec plus license and have configured this for wan failover, when the primary isp link goes down the route changes to the backup and all is fine, but when the primary comes back on line the route stays at the backup ?. I have tried all the debugging on sla monitor, but to be honest not a lot is reported.

I am fairly new to the cisco stuff, but this doesnt seem right to me ?

Device is running asa803-6-k8.bin, primary isp is through external router, backup isp is on pppoe.

The only way is to drop the backup connection and it reverts back to the primary ok

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Wan failover asa5505

Damian,

Thanks for sharing the config.

I noticed you entered the route staticaly:

route ISP_Backup 0.0.0.0 0.0.0.0 185.72.214.36 254

This should be learned automatically from the PPPoE when you have the setroute keyword.

interface Vlan22

ip address pppoe setroute

If the pppoe client route distance command is entered after a route is learned from PPPoE, the administrative distance specified does not affect the existing learned route. Only routes learned after the command was entered have the specified administrative distance.

Then you can shutdown the backup link and enable it again so that the commands can take effect.

Please try that and look at the 'show route' when you change to the backup link.

Regards,

Felipe

6 REPLIES
Bronze

Wan failover asa5505

Andrew,

Could you share your config?

Also could you share the "show route" output while you are on the Backup ISP Link?

Regards,

Felipe.

Bronze

Wan failover asa5505

Andrew,

Routes learned through PPPoE are given an administrative distance of 1 by default.

So the SLA can't go back to the primary route if the backup route also has a metric of 1.

You may need this command to increase the metric of the backup route.

Interface VlanX

pppoe client route distance 254

See the command reference for more information.

http://www.cisco.com/en/US/docs/security/asa/asa84/command/reference/p.html#wp2136231

Regards,

Felipe.

New Member

Wan failover asa5505

Running config, IP address have been changed etc

ASA Version 8.0(3)6
!
hostname ciscoasa
domain-name
enable password xxxxxxxxx encrypted
passwd xxxxxxx encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 232.26.201.21 255.255.255.248
!
interface Vlan12
no forward interface Vlan1
nameif dmz
security-level 50
ip address 10.0.0.55 255.255.255.0
!
interface Vlan22
nameif ISP_Backup
security-level 0
pppoe client vpdn group ISP_Backup
pppoe client route distance 254
ip address pppoe setroute
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
switchport access vlan 22
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
switchport access vlan 12
!
ftp mode passive
clock timezone GMT/BST 0
clock summer-time GMT/BDT recurring last Sun Mar 1:00 last Sun Oct 2:00
dns domain-lookup outside
dns server-group DefaultDNS
name-server x.x.x.x
domain-name xxxxxxx
access-list outside_access_in extended permit tcp any host 232.26.201.19 eq http
s
access-list outside_access_in remark SMTP
access-list outside_access_in extended permit tcp any host 232.26.201.19 eq smtp

access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 19
2.168.2.0 255.255.255.240
access-list dmz_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.1
68.2.0 255.255.255.240
access-list skvpn_splitTunnelAcl standard permit 192.168.1.0 255.255.255.0
access-list backup extended permit tcp any interface ISP_Backup eq smtp
pager lines 24
logging enable
logging monitor debugging
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
mtu ISP_Backup 1500
ip local pool vpnpool 192.168.2.5-192.168.2.10 mask 255.255.255.0
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-602.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
global (dmz) 1 10.0.0.60-10.0.0.90 netmask 255.0.0.0
global (ISP_Backup) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 192.168.1.0 255.255.255.0
nat (dmz) 0 access-list dmz_nat0_outbound
nat (dmz) 1 10.0.0.0 255.255.255.0
static (inside,outside) tcp 232.26.201.19 https 192.168.1.175 https netmask 255.2
55.255.255
static (inside,outside) tcp 232.26.201.19 smtp 192.168.1.175 smtp netmask 255.255
.255.255
static (inside,ISP_Backup) tcp interface smtp 192.168.1.175 smtp netmask 255.255.
255.255
access-group outside_access_in in interface outside
access-group backup in interface ISP_Backup
route outside 0.0.0.0 0.0.0.0 232.26.201.22 1 track 1
route ISP_Backup 0.0.0.0 0.0.0.0 185.72.214.36 254
timeout xlate 3:00:00
timeout conn 3:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
sla monitor 123
type echo protocol ipIcmpEcho 232.32.144.161 interface outside
num-packets 3
frequency 30
sla monitor schedule 123 life forever start-time now
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128
-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256
-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto map outside_map interface ISP_Backup
crypto isakmp enable outside
crypto isakmp enable ISP_Backup
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
!
track 1 rtr 123 reachability
management-access inside
vpdn group ISP_Backup request dialout pppoe
vpdn group ISP_Backup localname xxxxxxxxxxx
vpdn group ISP_Backup ppp authentication chap
vpdn username xxxxxxxxxxxxxx password *********
dhcpd auto_config outside
!

threat-detection basic-threat
threat-detection statistics

class-map inspection_default
match default-inspection-traffic

policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
: end

Bronze

Wan failover asa5505

Damian,

Thanks for sharing the config.

I noticed you entered the route staticaly:

route ISP_Backup 0.0.0.0 0.0.0.0 185.72.214.36 254

This should be learned automatically from the PPPoE when you have the setroute keyword.

interface Vlan22

ip address pppoe setroute

If the pppoe client route distance command is entered after a route is learned from PPPoE, the administrative distance specified does not affect the existing learned route. Only routes learned after the command was entered have the specified administrative distance.

Then you can shutdown the backup link and enable it again so that the commands can take effect.

Please try that and look at the 'show route' when you change to the backup link.

Regards,

Felipe

New Member

Wan failover asa5505

Felipe

The removal of the static route and the inclusion of pppoe client route distance sorted it.

Many thanks

Damian

Bronze

Wan failover asa5505

Damian,

You're wellcome, I'm glad it is working now.

Regards,

Felipe.

1584
Views
0
Helpful
6
Replies
CreatePlease to create content