Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

Webserver is not able to access from outside the network, VPN in not accepting

Hi Gurus,

My webserver is not able to access from outside the network. Also cisco vpn is not acceepting any connection.

For Webserver internal address is 192.168.1.2 => 64.168.82.251

My configuration is given below, please help


: Saved
:
ASA Version 7.2(4)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 64.168.82.250 255.255.255.248
!
interface Vlan3
no forward interface Vlan1
nameif dmz
security-level 50
no ip address
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group service DM_INLINE_TCP_1 tcp
port-object eq www
port-object eq https
object-group service DM_INLINE_TCP_2 tcp
port-object eq ftp
port-object eq ftp-data
port-object eq www
access-list inside_access_in extended permit tcp any any object-group DM_INLINE_
TCP_1
access-list inside_access_in extended permit ip any any
access-list inside_nat0_outbound extended permit ip any 10.10.100.0 255.255.255.
128
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 10
.10.100.0 255.255.255.128
access-list outside_access_in extended permit tcp any host 64.168.82.251 object-
group DM_INLINE_TCP_2
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool vpnpool 10.10.100.1-10.10.100.100 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (outside,inside) 64.168.82.251 192.168.1.2 netmask 255.255.255.255
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 64.168.82.254 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac
crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set TRANS_ESP_3DES_SHA
crypto dynamic-map outside_dyn_map 40 set pfs group1
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 60 set pfs group1
crypto dynamic-map outside_dyn_map 60 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 30
authentication crack
encryption 3des
hash sha
group 2
lifetime 86400
client-update enable
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 60
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.2-192.168.1.33 inside
dhcpd dns 4.2.2.1 4.2.2.2 interface inside
dhcpd enable inside
!

group-policy DefaultRAGroup internal
group-policy DefaultRAGroup attributes
dns-server value 4.2.2.2 4.2.2.1
vpn-tunnel-protocol l2tp-ipsec
default-domain value test.local
group-policy CiscoASA internal
group-policy CiscoASA attributes
dns-server value 4.2.2.2
vpn-tunnel-protocol IPSec
group-policy ciscoasa internal
group-policy ciscoasa attributes
dns-server value 4.2.2.2
vpn-tunnel-protocol IPSec
username siva password xaI3t+nY5wjYQ2thSKJfoQ== nt-encrypted privilege 0
tunnel-group DefaultRAGroup general-attributes
address-pool vpnpool
default-group-policy DefaultRAGroup
tunnel-group DefaultRAGroup ipsec-attributes
pre-shared-key *
tunnel-group CiscoASA type ipsec-ra
tunnel-group CiscoASA general-attributes
address-pool vpnpool
default-group-policy CiscoASA
tunnel-group ciscoasa type ipsec-ra
tunnel-group ciscoasa general-attributes
address-pool vpnpool
default-group-policy ciscoasa
tunnel-group ciscoasa ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect pptp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:1f9bd65614b7affc944713d8d0f5d7ac
: end
ciscoasa#
ciscoasa#

3 ACCEPTED SOLUTIONS

Accepted Solutions

Re: Webserver is not able to access from outside the network, V

You still have not answered me if from the VPN clients you can PING 192.168.1.1?

And if 192.168.1.1 is the deafult gateway for the local LAN behind the ASA?

Federico.

Re: Webserver is not able to access from outside the network, V

Siva,

The reason you're not able to access the inside network from the VPN clients, is because your NAT 0 statement looks like this:

access-list inside_nat0_outbound extended permit ip 192.168.100.0 255.255.255.0
192.168.100.0 255.255.255.128

Should look like this:

access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0
192.168.100.0 255.255.255.128

Also, the reason that you lose Internet when connecting with VPN is because there's no split-tunneling configured:

access-list split-tunneling extended permit ip 192.168.100.0 255.255.255.0
192.168.100.0 255.255.255.128

group-policy ciscovpn attributes

      split-tunnel-policy tunnelspecified
      split-tunnel-network-list value split-tunneling

tunnel-group ciscovpn general-attributes

     default-group-policy ciscovpn

Federico.

Re: Webserver is not able to access from outside the network, V

Your split-tunneling list looks like this:
access-list split-tunneling extended permit ip 192.168.100.0 255.255.255.0 192.168.100.0 255.255.255.128

Should look like this:
access-list split-tunneling extended permit ip 192.168.1.0 255.255.255.0 192.168.100.0 255.255.255.128

Federico.

19 REPLIES

Re: Webserver is not able to access from outside the network, V

Hi,

This command:
static (outside,inside) 64.168.82.251 192.168.1.2 netmask 255.255.255.255
Should look like this:
static (inside,outside) 64.168.82.251 192.168.1.2 netmask 255.255.255.255

That should take care of the web server.

For the VPN client:
Enable the command:
management-access inside

And post the output from:
sh cry isa sa
sh cry ips sa

When attempting to connect from the VPN client.

Federico.

Community Member

Re: Webserver is not able to access from outside the network, V

Webserver - : I have changed the static to (inside, outside), still it did not work, any more help will be really appreciated.

VPN: --   Here is the output

ciscoasa(config)# sh cry isa sa

There are no isakmp sas
ciscoasa(config)# sh cry ips sa

There are no ipsec sas

I have observed the log while connecting the VPN and it show some mismatching. Here is below.

Removing peer from correlator table failed, no match!

All IPSec SA proposals found unacceptable!

3 May 12 2010 22:28:35 713902    Group = ciscoasa, Username = siva, IP = 99.20.130.132, QM FSM error (P2 struct &0x437a098, mess id 0x3b6718ce)!

3 May 12 2010 22:28:35 713902    Group = ciscoasa, Username = siva, IP = 99.20.130.132, Removing peer from correlator table failed, no match!

4 May 12 2010 22:28:35 113019    Group = ciscoasa, Username = siva, IP = 99.20.130.132, Session disconnected. Session Type: IPSec, Duration: 0h:00m:00s, Bytes xmt: 0, Bytes rcv: 0, Reason: Phase 2 Mismatch

5 May 12 2010 22:28:35 713904    IP = 99.20.130.132, Received encrypted packet with no matching SA, dropping

Re: Webserver  is not able to access from outside the network, VPN in not accepting

Re: Webserver is not able to access from outside the network, V

Check with the command:
sh access-list inside_access_in
that port 80 traffic is getting hitted to the ACL from the outside.
This is because if I do a ''telnet 64.168.82.251 80'' the traffic seems to hit the server.

Question:
Can you reach the webserver from inside the ASA?

Regarding the VPN:
Phase 2 is not matching.
Please post the output from:
debug cry ipse 127

Federico.

Community Member

Re: Webserver is not able to access from outside the network, V

Thanks for your reply.

I just reconfigured the VPN part and client is able to connect the VPN successfully. But two problmes still facing.

VPN client is not able to ping or access any resources from INISIDE the network. VPN disconnects after 30 minutes.

I am still working on the webserver access from aoutside part.

Any help will be highly appreciated.

Thanks

Siva

Cisco Employee

Re: Webserver is not able to access from outside the network, V

Hi Siva,

Just tested to browse: http://64.168.82.251, and it works OK (it's the Apache 2 Test Page). Seems like the webserver is now up and working.

For the VPN access, to ping the internal subnet after you are connected, please add the following:

crypto isakmp nat-traversal 25

policy-map global_policy
  class inspection_default
       inspect icmp

Also, can you ping 192.168.1.1 after connected via VPN?

Hope that helps.

Community Member

Re: Webserver is not able to access from outside the network, V

Good Morning.

Yes, I fixed the webserver access from outside yesterday. It was the NAT issue and below lines added (it might help someone too, so I am pasting).

Static nat for webserver


static (inside,outside) 64.168.82.251 192.168.1.50 netmask 255.255.255.255
access-list outside_access_in permit tcp any host 64.168.82.251  80
access-group outside_access_in in interface outside

---------------------------------------------------------------------------------------

For VPN , I am  connecting from home, receiving the IP from VPN-POOL (10.10.100.2) and I can ping locally. But not any other IP address such as

192.168.1.1, 4.2.2.2.    Even local internet won't work if I connect VPN.

any thoughts?

Thanks,

Re: Webserver is not able to access from outside the network, V

Glad for the webserver.

For the VPN, check if by adding the commands:

management-access inside

crypto isakmp nat-t

sysopt connection permit-vpn

Can you PING 192.168.1.1 now?

Make sure that anything else that you want to reach has a default gateway pointing to the ASA.

Federico.

Community Member

Re: Webserver is not able to access from outside the network, V

I have added the commands.  VPN connecting and receiving the IP address from the Pool.  Still cant ping the inside hosts.  Please Help......

===========================================================================

hostname ciscoasa
domain-name default.domain.invalid
enable password ibUNfy.Nk1xsLSb/ encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 192.168.1.60 Windows-Server description 192.168.1.60
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 64.168.82.250 255.255.255.248
!
interface Vlan3
no forward interface Vlan1
nameif dmz
security-level 50
ip address 10.10.10.1 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
switchport access vlan 3
!
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group service DM_INLINE_TCP_1 tcp
port-object eq ftp
port-object eq ftp-data
port-object eq www
port-object eq https
port-object eq ssh
port-object eq telnet
object-group service DM_INLINE_TCP_2 tcp
port-object eq ftp
port-object eq ftp-data
access-list ciscovpn_splitTunnelAcl standard permit any
access-list inside_nat0_outbound extended permit ip any 10.10.50.0 255.255.255.1
92
access-list outside_access_in extended permit tcp any host 64.168.82.251 object-
group DM_INLINE_TCP_1 inactive
access-list outside_access_in extended permit tcp any host 64.168.82.252 object-
group DM_INLINE_TCP_2 inactive
access-list outside_access_in extended permit tcp any host 64.168.82.252 eq 3389
inactive
access-list outside_access_in extended permit tcp any host 64.168.82.253 eq pptp
inactive
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool ciscovpn-pool 10.10.50.1-10.10.50.50 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 64.168.82.251 192.168.1.50 netmask 255.255.255.255
static (inside,outside) 64.168.82.252 192.168.1.4 netmask 255.255.255.255
static (inside,outside) 64.168.82.253 Windows-Server netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 64.168.82.254 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 99.20.130.132 255.255.255.255 outside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp nat-traversal  25
client-update enable
telnet 192.168.1.0 255.255.255.255 inside
telnet timeout 5
ssh 99.20.130.132 255.255.255.255 outside
ssh timeout 5
console timeout 0
management-access inside
dhcpd auto_config outside
!
dhcpd address 192.168.1.2-192.168.1.33 inside
dhcpd dns 4.2.2.1 4.2.2.2 interface inside
dhcpd enable inside
!

group-policy ciscovpn internal
group-policy ciscovpn attributes
dns-server value 4.2.2.1 4.2.2.2
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value ciscovpn_splitTunnelAcl
username siva password j/596TABe3tp0Rk9 encrypted privilege 0
username siva attributes
vpn-group-policy ciscovpn
tunnel-group ciscovpn type ipsec-ra
tunnel-group ciscovpn general-attributes
address-pool ciscovpn-pool
default-group-policy ciscovpn
tunnel-group ciscovpn ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect pptp
  inspect icmp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:adb49ff11e18f4ce1d260f6edda06fce
: end
ciscoa

Re: Webserver is not able to access from outside the network, V

You still have not answered me if from the VPN clients you can PING 192.168.1.1?

And if 192.168.1.1 is the deafult gateway for the local LAN behind the ASA?

Federico.

Community Member

Re: Webserver is not able to access from outside the network, V

sorry for the late reply.

I could not ping 192.168.1.1 or any IP. But VPN is connecting successfully. ANother thing I had noticed is after connecting VPN I could not browse locally Also.

Please see my current configuration attached in txt file.

Re: Webserver is not able to access from outside the network, V

Siva,

The reason you're not able to access the inside network from the VPN clients, is because your NAT 0 statement looks like this:

access-list inside_nat0_outbound extended permit ip 192.168.100.0 255.255.255.0
192.168.100.0 255.255.255.128

Should look like this:

access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0
192.168.100.0 255.255.255.128

Also, the reason that you lose Internet when connecting with VPN is because there's no split-tunneling configured:

access-list split-tunneling extended permit ip 192.168.100.0 255.255.255.0
192.168.100.0 255.255.255.128

group-policy ciscovpn attributes

      split-tunnel-policy tunnelspecified
      split-tunnel-network-list value split-tunneling

tunnel-group ciscovpn general-attributes

     default-group-policy ciscovpn

Federico.

Community Member

Re: Webserver is not able to access from outside the network, V

Internet access is working now. But still not able to ping 192.168.1.1    Thanks againg for your time and help.

here is the current configuration:

ciscoasa(config)# show run
: Saved
:
ASA Version 7.2(4)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 64.168.82.250 255.255.255.248
!
interface Vlan3
no forward interface Vlan1
nameif dmz
security-level 50
no ip address
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
object-group service DM_INLINE_TCP_1 tcp
port-object eq www
port-object eq https
port-object eq ssh
port-object eq telnet
object-group service rdp tcp
description rdp
port-object eq 3389
object-group service DM_INLINE_TCP_2 tcp
group-object rdp
port-object eq www
access-list outside_access_in extended permit tcp any host 64.168.82.253 eq pptp

access-list outside_access_in extended permit tcp any host 64.168.82.252 object-
group DM_INLINE_TCP_2
access-list outside_access_in extended permit tcp any host 64.168.82.251 object-
group DM_INLINE_TCP_1
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 19
2.168.100.0 255.255.255.128
access-list split-tunneling extended permit ip 192.168.100.0 255.255.255.0 192.1
68.100.0 255.255.255.128
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool cisco-vpn 192.168.100.1-192.168.100.100
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 64.168.82.252 192.168.1.4 netmask 255.255.255.255
static (inside,outside) 64.168.82.251 192.168.1.50 netmask 255.255.255.255
static (inside,outside) 64.168.82.253 192.168.1.60 netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 64.168.82.254 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp nat-traversal  20
client-update enable
telnet timeout 5
ssh timeout 5
console timeout 0
management-access inside
dhcpd auto_config outside
!
dhcpd address 192.168.1.2-192.168.1.33 inside
dhcpd dns 4.2.2.2 interface inside
dhcpd enable inside
!

group-policy ciscovpn internal
group-policy ciscovpn attributes
dns-server value 4.2.2.2
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value split-tunneling
username siva password j/596TABe3tp0Rk9 encrypted privilege 0
username siva attributes
vpn-group-policy ciscovpn
tunnel-group ciscovpn type ipsec-ra
tunnel-group ciscovpn general-attributes
address-pool cisco-vpn
default-group-policy ciscovpn
tunnel-group ciscovpn ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:c7e5ebc2e4c40ed9d7ee39b12d1aa18f
: end
ciscoasa(config)#

Re: Webserver is not able to access from outside the network, V

Add this commands on the ASA and see if you can PING:

sysopt connection permit-vpn   --> this might not take it

crypto isakmp nat-t

Disconnect the VPN client, and connect and try again.

Federico.

Community Member

Re: Webserver is not able to access from outside the network, V

I have addeded.

But no luck,  Could not ping 1923168.1.1 or any host inside.   Any other suggessions?

Thanks,

Siva

Re: Webserver is not able to access from outside the network, V

Remove this command and try connecting again:

crypto dynamic-map outside_dyn_map 20 set pfs group1

If still does not work, then post the output of:

sh cry isa sa

sh cry ips sa

To check if the ASA is receiving packets and sending packets through the tunnel.

Federico.

Community Member

Re: Webserver is not able to access from outside the network, V

Here is the output

ciscoasa(config)# sh cry isa sa

   Active SA: 1
    Rekey SA: 0 (A tunnel will report 1 Active and 1 Rekey SA during rekey)
Total IKE SA: 1

1   IKE Peer: 99.20.130.132
    Type    : user            Role    : responder
    Rekey   : no              State   : AM_ACTIVE
ciscoasa(config)#
ciscoasa(config)# sh cry ips sa
interface: outside
    Crypto map tag: outside_dyn_map, seq num: 20, local addr: 64.168.82.250

      local ident (addr/mask/prot/port): (0.0.0.0/0.0.0.0/0/0)
      remote ident (addr/mask/prot/port): (192.168.100.2/255.255.255.255/0/0)
      current_peer: 99.20.130.132, username: siva
      dynamic allocated peer ip: 192.168.100.2

      #pkts encaps: 0, #pkts encrypt: 0, #pkts digest: 0
      #pkts decaps: 4, #pkts decrypt: 4, #pkts verify: 4
      #pkts compressed: 0, #pkts decompressed: 0
      #pkts not compressed: 0, #pkts comp failed: 0, #pkts decomp failed: 0
      #pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0
      #PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0
      #send errors: 0, #recv errors: 0

      local crypto endpt.: 64.168.82.250/4500, remote crypto endpt.: 99.20.130.1
32/4661
      path mtu 1500, ipsec overhead 66, media mtu 1500
      current outbound spi: 9FFDF002

    inbound esp sas:
      spi: 0xF407C8B6 (4094150838)
         transform: esp-3des esp-sha-hmac none
         in use settings ={RA, Tunnel,  NAT-T-Encaps, }
         slot: 0, conn_id: 12, crypto-map: outside_dyn_map
         sa timing: remaining key lifetime (sec): 28798
         IV size: 8 bytes
         replay detection support: Y
    outbound esp sas:
      spi: 0x9FFDF002 (2684219394)
         transform: esp-3des esp-sha-hmac none
         in use settings ={RA, Tunnel,  NAT-T-Encaps, }
         slot: 0, conn_id: 12, crypto-map: outside_dyn_map
         sa timing: remaining key lifetime (sec): 28794
         IV size: 8 bytes
         replay detection support: Y

ciscoasa(config)#
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Here is the log while connecting:-

6|May 17 2010|19:44:39|302016|192.168.100.2|192.168.100.255|Teardown UDP connection 1660 for outside:192.168.100.2/137 to outside:192.168.100.255/137 duration 0:00:00 bytes 0 (siva)
6|May 17 2010|19:44:38|302016|192.168.100.2|192.168.100.255|Teardown UDP connection 1659 for outside:192.168.100.2/137 to outside:192.168.100.255/137 duration 0:00:00 bytes 0 (siva)
6|May 17 2010|19:44:38|302016|192.168.100.2|192.168.100.255|Teardown UDP connection 1658 for outside:192.168.100.2/137 to outside:192.168.100.255/137 duration 0:00:00 bytes 0 (siva)
6|May 17 2010|19:44:37|302016|192.168.100.2|192.168.100.255|Teardown UDP connection 1657 for outside:192.168.100.2/137 to outside:192.168.100.255/137 duration 0:00:00 bytes 0 (siva)
6|May 17 2010|19:44:37|302016|192.168.100.2|192.168.100.255|Teardown UDP connection 1656 for outside:192.168.100.2/137 to outside:192.168.100.255/137 duration 0:00:00 bytes 0 (siva)
6|May 17 2010|19:44:36|302016|192.168.100.2|192.168.100.255|Teardown UDP connection 1655 for outside:192.168.100.2/137 to outside:192.168.100.255/137 duration 0:00:00 bytes 0 (siva)
6|May 17 2010|19:44:35|302016|192.168.100.2|192.168.100.255|Teardown UDP connection 1654 for outside:192.168.100.2/137 to outside:192.168.100.255/137 duration 0:00:00 bytes 0 (siva)
6|May 17 2010|19:44:34|302016|192.168.100.2|192.168.100.255|Teardown UDP connection 1653 for outside:192.168.100.2/137 to outside:192.168.100.255/137 duration 0:00:00 bytes 0 (siva)
6|May 17 2010|19:44:34|302016|192.168.100.2|192.168.100.255|Teardown UDP connection 1652 for outside:192.168.100.2/137 to outside:192.168.100.255/137 duration 0:00:00 bytes 0 (siva)
6|May 17 2010|19:44:33|302016|192.168.100.2|192.168.100.255|Teardown UDP connection 1651 for outside:192.168.100.2/137 to outside:192.168.100.255/137 duration 0:00:00 bytes 0 (siva)
6|May 17 2010|19:44:32|335004|||NAC is disabled for host - 192.168.100.2.
5|May 17 2010|19:44:32|713120|||Group = ciscovpn, Username = siva, IP = 99.20.130.132, PHASE 2 COMPLETED (msgid=b11432b9)
6|May 17 2010|19:44:32|602303|||IPSEC: An inbound remote access SA (SPI= 0x4423EA93) between 64.168.82.250 and 99.20.130.132 (user= siva) has been created.
6|May 17 2010|19:44:32|602303|||IPSEC: An outbound remote access SA (SPI= 0x31A07BBA) between 64.168.82.250 and 99.20.130.132 (user= siva) has been created.
5|May 17 2010|19:44:32|713049|||Group = ciscovpn, Username = siva, IP = 99.20.130.132, Security negotiation complete for User (siva)  Responder, Inbound SPI = 0x4423ea93, Outbound SPI = 0x31a07bba
5|May 17 2010|19:44:32|713075|||Group = ciscovpn, Username = siva, IP = 99.20.130.132, Overriding Initiator's IPSec rekeying duration from 2147483 to 28800 seconds
3|May 17 2010|19:44:32|713119|||Group = ciscovpn, Username = siva, IP = 99.20.130.132, PHASE 1 COMPLETED
6|May 17 2010|19:44:30|713228|||Group = ciscovpn, Username = siva, IP = 99.20.130.132, Assigned private IP address 192.168.100.2 to remote user
6|May 17 2010|19:44:30|713184|||Group = ciscovpn, Username = siva, IP = 99.20.130.132, Client Type: WinNT  Client Application Version: 5.0.06.0160
5|May 17 2010|19:44:30|713130|||Group = ciscovpn, Username = siva, IP = 99.20.130.132, Received unsupported transaction mode attribute: 5
6|May 17 2010|19:44:29|113008|||AAA transaction status ACCEPT : user = siva
6|May 17 2010|19:44:29|113009|||AAA retrieved default group policy (ciscovpn) for user = siva
6|May 17 2010|19:44:29|113011|||AAA retrieved user specific group policy (ciscovpn) for user = siva
6|May 17 2010|19:44:29|113003|||AAA group policy for user siva is being set to ciscovpn
6|May 17 2010|19:44:29|113012|||AAA user authentication Successful : local database : user = siva
6|May 17 2010|19:44:24|713172|||Group = ciscovpn, IP = 99.20.130.132, Automatic NAT Detection Status:     Remote end   IS   behind a NAT device     This   end is NOT behind a NAT device
6|May 17 2010|19:44:24|302015|99.20.130.132|64.168.82.250|Built inbound UDP connection 1650 for outside:99.20.130.132/4549 (99.20.130.132/4549) to NP Identity Ifc:64.168.82.250/4500 (64.168.82.250/4500)
6|May 17 2010|19:44:24|302015|99.20.130.132|64.168.82.250|Built inbound UDP connection 1649 for outside:99.20.130.132/4548 (99.20.130.132/4548) to NP Identity Ifc:64.168.82.250/500 (64.168.82.250/500)
5|May 17 2010|19:44:20|713904|||IP = 99.20.130.132, Received encrypted packet with no matching SA, dropping
4|May 17 2010|19:44:20|113019|||Group = ciscovpn, Username = siva, IP = 99.20.130.132, Session disconnected. Session Type: IPSecOverNatT, Duration: 0h:02m:27s, Bytes xmt: 7905, Bytes rcv: 0, Reason: User Requested
6|May 17 2010|19:44:20|602304|||IPSEC: An outbound remote access SA (SPI= 0xDECCE24C) between 64.168.82.250 and 99.20.130.132 (user= siva) has been deleted.
6|May 17 2010|19:44:20|602304|||IPSEC: An inbound remote access SA (SPI= 0x7B031657) between 64.168.82.250 and 99.20.130.132 (user= siva) has been deleted.
5|May 17 2010|19:44:20|713050|||Group = ciscovpn, Username = siva, IP = 99.20.130.132, Connection terminated for peer siva.  Reason: Peer Terminate  Remote Proxy 192.168.100.2, Local Proxy 0.0.0.0
6|May 17 2010|19:44:18|302016|192.168.100.2|192.168.100.255|Teardown UDP connection 1648 for outside:192.168.100.2/138 to outside:192.168.100.255/138 duration 0:00:00 bytes 0 (siva)

Re: Webserver is not able to access from outside the network, V

Your split-tunneling list looks like this:
access-list split-tunneling extended permit ip 192.168.100.0 255.255.255.0 192.168.100.0 255.255.255.128

Should look like this:
access-list split-tunneling extended permit ip 192.168.1.0 255.255.255.0 192.168.100.0 255.255.255.128

Federico.

Community Member

Re: Webserver is not able to access from outside the network, V

Thanks a lot. You rock. Amazing.

All working now

Re: Webserver is not able to access from outside the network, V

Very glad to hear that is working  ;p

Thank you for the feedback.

Federico.

2403
Views
0
Helpful
19
Replies
CreatePlease to create content