Cisco Support Community
Step-by-Step Configuration and Troubleshooting Best Practices for the NGFW, NGIPS and AMP Technologies A Visual Guide to the Cisco Firepower Threat Defense (FTD)
Community Member

Wrong NETBIOS name to IP mapping in DNS when client is behind PIX515(7.2)


Following is the setup in which I am facing some problem:


Client real IP:

Client NATed IP:

Client computer Name: COMPUTERA

There is a static NAT on the PIX firewall with DNS re-write option for the client. Client is successfully joining the domain. But in the DNS 'A' records following entry is coming


I have checked on the PIX & found that all relevant inspects(netbios & dns) are enabled but I am wondering why the NATed IP is not appearing on the DNS .....I think this has some thing to do with NETBIOS rewrite on the PIX.......

Following is the config on the PIX

interface Ethernet0
nameif outside
security-level 0
ip address
interface Ethernet1
nameif inside
security-level 100
ip address

access-list outside_access_in extended permit ip any any
access-list outside_access_in extended permit icmp any any
access-list inside_access_in extended permit ip any any
access-list inside_access_in extended permit icmp any any

static (inside,outside) netmask dns

access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
route outside 1

class-map inspection_default
match default-inspection-traffic
policy-map type inspect dns preset_dns_map
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp
  inspect dns preset_dns_map
service-policy global_policy global

PIX# show version

Cisco PIX Security Appliance Software Version 7.2(2)

Cisco Employee

Re: Wrong NETBIOS name to IP mapping in DNS when client is behin

I believe this may be due to DNS re-write. Why do you have DNS re-write? Do people on the inside try to access the server with its address?


Community Member

Re: Wrong NETBIOS name to IP mapping in DNS when client is behin

I have removed dns re-write option but the problem still persists. I think dns re-write option shouldn't affect b/c this problem might be related to NETBIOS......

CreatePlease to create content