cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
625
Views
5
Helpful
1
Replies

2 dhcp server in a network

ddicky
Level 1
Level 1

I have a 3750 acting as a dhcp server with a range of IP pool and a linksys router with another set of pool. Is there anyway I can configure that certain workstation getting IP from 3750 and certain workstation obtaining from the linksys router?Both are running on different vlan with routing on the 3750.

1 Reply 1

John Blakley
VIP Alumni
VIP Alumni

Well first, you can have separate DHCP servers as long as they are on:

a) Separate subnets

b) serving different scopes

That in mind, if you have a dhcp scope on your 3750, you would need a vlan interface that is addressed in that same scope:

int vlan 50

ip address 192.168.50.1 255.255.255.0

ip dhcp pool VLAN50

network 192.168.50.0 255.255.255.0

default-router 192.168.50.1

dns-server 4.2.2.1

On the OTHER DHCP server that you want to get your addresses from, you would need a separate VLAN interface configured with an IP address like:

int VLAN 100

ip address 192.168.100.1 255.255.255.0

ip helper-address 192.168.100.50

Anything coming in on VLAN 100 will go to the 192.168.100.50 to get an address. You would need a pool for 192.168.100.0 on the DHCP server for that.

I wouldn't recommend using separate DHCP servers though because you can use just the one DHCP server (Linux/Windows) to serve multiple scopes. All VLANs in your switch would have the helper-address assigned as your one DHCP server.

int vlan 50

ip address 10.50.1.1 255.255.255.0

ip helper-address 192.168.100.50

int vlan 225

ip address 172.22.225.1 255.255.255.0

ip helper-address 192.168.100.50

int vlan 322

ip address 192.168.32.1 255.255.255.0

ip helper-address 192.168.100.50

On the DHCP server, you would have:

Scope

10.50.1.0

172.22.225.0

192.168.32.0

You would set all of your options that you need to assign under those scopes.

HTH,

John

HTH, John *** Please rate all useful posts ***
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card