Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

2511 as a terminal server

I have a 2511 with an octal cable attached to the Async 1-8 port. Config is listed below:

sh run

Building configuration...

Current configuration:

!

version 11.2

no service password-encryption

no service udp-small-servers

no service tcp-small-servers

!

hostname TermServer

!

enable password cisco

!

partition flash 2 8 8

!

ip subnet-zero

no ip domain-lookup

!

interface Loopback0

ip address 100.100.100.100 255.255.255.255

!

interface Ethernet0

ip address <address removed>

!

interface Serial0

no ip address

shutdown

!

interface Serial1

no ip address

shutdown

!

interface Async1

no ip address

async mode interactive

!

interface Async2

no ip address

async mode interactive

!

!

ip classless

!

line con 0

password cisco

logging synchronous

login

line 1 16

no exec

exec-timeout 0 0

transport input all

stopbits 1

flowcontrol hardware

line aux 0

line vty 0 4

exec-timeout 0 0

privilege level 15

password cisco

logging synchronous

login local

transport input telnet

!

end

TermServer#

This is a capture of a session. The problem is that it I can make a connection to the remote device, but I cannot gain control of that device.

TermServer#telnet 100.100.100.100 2001

Trying 100.100.100.100, 2001 ... Open

TermServer#sh line

Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns

* 0 CTY - - - - - 5 0 0/0

* 1 TTY 9600/9600 - - - - - 3 0 0/0

* 2 TTY 9600/9600 - - - - - 2 0 0/0

3 TTY 9600/9600 - - - - - 0 0 0/0

4 TTY 9600/9600 - - - - - 0 0 0/0

5 TTY 9600/9600 - - - - - 0 0 0/0

6 TTY 9600/9600 - - - - - 0 0 0/0

7 TTY 9600/9600 - - - - - 0 0 0/0

8 TTY 9600/9600 - - - - - 0 0 0/0

9 TTY 9600/9600 - - - - - 0 0 0/0

10 TTY 9600/9600 - - - - - 0 0 0/0

11 TTY 9600/9600 - - - - - 0 0 0/0

12 TTY 9600/9600 - - - - - 0 0 0/0

13 TTY 9600/9600 - - - - - 0 0 0/0

14 TTY 9600/9600 - - - - - 0 0 0/0

15 TTY 9600/9600 - - - - - 0 0 0/0

16 TTY 9600/9600 - - - - - 0 0 0/0

17 AUX 9600/9600 - - - - - 0 0 0/0

18 VTY - - - - - 2 0 0/0

19 VTY - - - - - 0 0 0/0

20 VTY - - - - - 0 0 0/0

21 VTY - - - - - 0 0 0/0

--More--

TermServer#

When the connection shows open, pressing return multiple times does nothing. I can only regain control by shift-control 6 -X. Then I do a show line and you can see that I made a connection via the line.

So, the problem is that I am making a reverse telnet connection to the remote device by not gaining control. I have tried 3 different remote devices with different IOSs on them and three different ports on the Async

12 REPLIES
New Member

Re: 2511 as a terminal server

From your ws, have you tried telneting to it without specifiy the port range? ie: telnet 100.100.100.100 without 2001. does it work?

New Member

Re: 2511 as a terminal server

from my workstation, I can telnet TO the terminal server with no problems. Once in the terminal server, I cannot reverse telnet to another device. From the terminal server, if I execute the command "telnet 100.100.100.100" without a line number, it works as expected. I telnet to myself and can log in with no issues

Hall of Fame Super Gold

Re: 2511 as a terminal server

Jeffrey

There are a couple of possibilities that you should check:

- is it possible that the octal cable is not connected on the first set of lines but is connected to the second set? if you telnet 100.100.100.100 2009 what happens?

- is it possible that the device that you are attempting to reverse telnet to is just not responding? If you disconnect the octal cable and connect with a console cable from your PC does the connection work?

- is it possible that the cable is faulty?

HTH

Rick

New Member

Re: 2511 as a terminal server

Rick -

The sets of lines (and the corresponding physical interface are labelled on the router, but just to be sure, I tried to telnet to 2009 and nothing. Once I clear the line and disconnect the octal cable, I can console to the remote device with no issues. I replaced the octal cable with another and the same thing. I also tried a separate "leg" on the octal cabe going into another device (line 2 going into a switch console port with the same results

Jeff

Silver

Re: 2511 as a terminal server

Try this config:

--------------------------------

line 1 16

exec-timeout 0 0

logging synchronous

transport input telnet

---------------------------------

remove the line 'stopbits 1'

let us know - i'm sure we can get to the bottom of this.

Ajaz

Re: 2511 as a terminal server

Try removing the hardware flow control as well.

New Member

Re: 2511 as a terminal server

removed flow control hardware also and still no change

New Member

Re: 2511 as a terminal server

I just tried another test. I added a second octal calbe to the second Async interface and tried to telnet to 2009. Same results. I get a connection but no control. Target machine was a different router from the device connected via line 2001

New Member

Re: 2511 as a terminal server

Ajaz -

I added logging sychronous and removed the stopbits 1. No change

Silver

Re: 2511 as a terminal server

Jeffrey

Did you match the config which i posted?

Can you please paste here the current config under line 1 16

thanks in advance

Ajaz

New Member

Re: 2511 as a terminal server

Ajaz -

Current config under line 1 16

no exec

exec-timeout 0 0

logging synchronous

transport input telnet

Re: 2511 as a terminal server

Here (attached) is the config of my own lab terminal server, which works fine. See if you can spot the difference from yours.

Just a silly thought ... are you sure you are using the right cable from the octal connector to correspond to the TCP port you are trying to access?

Kevin Dorrell

Luxembourg

214
Views
0
Helpful
12
Replies
CreatePlease to create content