Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2811 + HWIC-4ESW - DHCP on the switch ports ?

Hello,

i have a Cisco router 2811 (IOS 12.4) with a etherswitch modul HWIC-4ESW and i want DHCP

on the switch ports. Is this possible ?

I get DHCP working on the router ports, but

not on the switch ports and i wonder if that

is possible at all.. i don't want to use an

external DHCP server.

If it not possible with the HWIC-4ESW card,

would it be possible with the NME-16ES-1G

card ? Anyone knows this ?

Thanks

Ralf

1 ACCEPTED SOLUTION

Accepted Solutions

Re: 2811 + HWIC-4ESW - DHCP on the switch ports ?

Hi,

I think that IOS DHCP functionality can operate with the HWIC-4ESW with no problems, can you please post your configurations, you should need to configure interface vlan 1 (assuming that you are operating the HWIC ports as layer 2 ports in VLAN1)with the IP address of the default gateway of the DHCP pool, please give it a try and feed back us.

HTH,

Mohammed Mahmoud.

4 REPLIES

Re: 2811 + HWIC-4ESW - DHCP on the switch ports ?

Hi,

I think that IOS DHCP functionality can operate with the HWIC-4ESW with no problems, can you please post your configurations, you should need to configure interface vlan 1 (assuming that you are operating the HWIC ports as layer 2 ports in VLAN1)with the IP address of the default gateway of the DHCP pool, please give it a try and feed back us.

HTH,

Mohammed Mahmoud.

New Member

Re: 2811 + HWIC-4ESW - DHCP on the switch ports ?

I tried this, but it seems not to work..

ip dhcp excluded-address 192.168.71.0 192.168.71.127

ip dhcp excluded-address 192.168.72.0 192.168.72.127

!

ip dhcp pool dhcp_pool_71

network 192.168.71.0 255.255.255.0

default-router 192.168.71.1

dns-server 192.168.71.1

!

ip dhcp pool dhcp_pool_72

network 192.168.72.0 255.255.255.0

default-router 192.168.72.1

dns-server 192.168.72.1

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0/0

switchport access vlan 71

spanning-tree portfast

!

interface FastEthernet0/0/1

switchport access vlan 72

spanning-tree portfast

!

interface FastEthernet0/0/2

!

interface FastEthernet0/0/3

switchport mode trunk

!

interface Vlan1

ip address 172.22.180.70 255.255.255.0

ip nat outside

ip virtual-reassembly

!

interface Vlan71

ip address 192.168.71.1 255.255.255.0

!

interface Vlan72

ip address 192.168.72.1 255.255.255.0

!

Purple

Re: 2811 + HWIC-4ESW - DHCP on the switch ports ?

Did you create the layer 2 vlans in the vlan database for those vlans you assigned to the switchport, if not it won't work. Do a show vlan-switch brief and see if your vlan 71 and 72 show up .

New Member

Re: 2811 + HWIC-4ESW - DHCP on the switch ports ?

Your are right, the vlans didn't show up in the vlan database, i configured vtp before, but somehow while testing i must lost the entries in the database. I added the vlans per hand and now

it works fine. Thanks alot !

730
Views
5
Helpful
4
Replies
CreatePlease to create content