Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

2811 Router need interface specific routes and gateway

I am trying to have a diffent default-gateway and routes for the each of the two FastEthernet interfaces on my Cisco 2811 Router

This is currently how it looks:

interface Multilink1

ip address 67.xxx.xxx.126 255.255.255.252

ppp multilink

ppp multilink fragment disable

ppp multilink group 1

!

!

!

interface Serial0/0/0

description Quest Internet T1

no ip address

encapsulation ppp

no keepalive

no fair-queue

ppp multilink

ppp multilink group 1

no shutdown

!

interface Serial0/1/0

no ip address

encapsulation ppp

no keepalive

no fair-queue

ppp multilink

ppp multilink group 1

no shutdown

interface FastEthernet0/0

ip address 69.xxx.xxx.65 255.255.255.224

speed auto

full-duplex

no shutdown

speed auto

interface FastEthernet0/1

ip address 192.168.21.1 255.255.255.0

no shutdown

duplex auto

speed auto

For anything traveling though the FE0/1 interface, I want to use the below routes:

ip route 0.0.0.0 0.0.0.0 192.168.21.2 (Back to PIX, then gets filtered by Websense)

ip route 172.16.0.0 255.252.0.0 192.168.21.4

ip route 172.20.0.0 255.252.0.0 192.168.21.4

ip route 192.168.33.0 255.255.255.0 192.168.21.4

For anything traveling though the FE0/0 interface, I want to use the below routes:

ip route 0.0.0.0 0.0.0.0 67.XXX.XXX.125 (WAN Gateway back to ISP)

I would like to segragate the two interfaces, as if they were different routers.

Is this possible?

2 REPLIES

Re: 2811 Router need interface specific routes and gateway

Hi Matt

You can try configuring the below commands.

ip route 0.0.0.0 0.0.0.0 192.168.21.2 interface FastEthernet0/1

ip route 172.16.0.0 255.252.0.0 192.168.21.4 interface FastEthernet0/1

ip route 172.20.0.0 255.252.0.0 192.168.21.4 interface FastEthernet0/1

ip route 192.168.33.0 255.255.255.0 192.168.21.4 interface FastEthernet0/1

ip route 0.0.0.0 0.0.0.0 67.XXX.XXX.125 interface FastEthernet0/0

also i see no nat enabled in your config..

If you are trying to access internet using this you need to create nat configs accrodingly.

regds

Re: 2811 Router need interface specific routes and gateway

Hello,

this can be achieved with the help of a VRF, which works like a separate router:

ip vrf FE00

rd 65000:1

interface Multilink1

ip vrf forwarding FE00

ip address 67.xxx.xxx.126 255.255.255.252

ppp multilink

ppp multilink fragment disable

ppp multilink group 1

!

interface Serial0/0/0

description Quest Internet T1

no ip address

encapsulation ppp

no keepalive

no fair-queue

ppp multilink

ppp multilink group 1

no shutdown

!

interface Serial0/1/0

no ip address

encapsulation ppp

no keepalive

no fair-queue

ppp multilink

ppp multilink group 1

no shutdown

interface FastEthernet0/0

ip vrf forwarding FE00

ip address 69.xxx.xxx.65 255.255.255.224

speed auto

full-duplex

no shutdown

speed auto

interface FastEthernet0/1

ip address 192.168.21.1 255.255.255.0

no shutdown

duplex auto

speed auto

ip route 0.0.0.0 0.0.0.0 192.168.21.2

ip route 172.16.0.0 255.252.0.0 192.168.21.4

ip route 172.20.0.0 255.252.0.0 192.168.21.4

ip route 192.168.33.0 255.255.255.0 192.168.21.4

ip route vrf FE00 0.0.0.0 0.0.0.0 67.XXX.XXX.125

There will not be any connectivity between FE0/0 and FE0/1

Hope this helps! Please rate all posts.

Regards, Martin

180
Views
5
Helpful
2
Replies