Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

2821 Routing problem

I have a 2821 router with a hp switch connected to 0/0 and 0/1. Both switches have a pc connected, but I cannot ping from pc to pc. Doing a show arp in the router shows both pc's, but a show arp in either pc does not show the other pc but it does show the hp switch ip address with a '0000.0000.0000' mac address marked as invalid.

With debug arp I get a message '0000.0000.0000 wrong cable message.'

I get the impression the problem is at level 2 but I am certain all my cabling works ok, So the only other thing is the router is not allowing arp packets from 0/0 to 0/1 and back.Can anyone shed any light on this?

The relavent part of my config looks like this:

ip subnet-zero

!

!

ip cef

!

!

!

!

!

!

interface GigabitEthernet0/0

ip address 10.31.150.203 255.255.255.0

ip access-group 1 in

ip directed-broadcast

duplex auto

speed auto

no mop enabled

!

interface GigabitEthernet0/1

ip address 193.126.89.211 255.255.255.0

ip access-group 2 in

ip directed-broadcast

duplex auto

speed auto

no mop enabled

!

router rip

network 10.31.0.0

network 193.126.89.0

!

ip classless

ip route 10.31.150.0 255.255.255.0 193.126.89.209

ip route 193.126.89.0 255.255.255.0 10.31.150.210

!

ip http server

!

access-list 1 permit any

access-list 2 permit any

!

control-plane

!

  • Getting Started with LANs
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: 2821 Routing problem

Your DFGWs configured on the PCs are not the same ip addresses that you have configured on your router. If you want to use this router to route between these two subnets you will have to change your DFGWs on the PCs to match the routers interfaces. I hope this helps...

5 REPLIES

Re: 2821 Routing problem

Hello,

can you try and take the access lists off your interfaces ?

interface GigabitEthernet0/0

ip address 10.31.150.203 255.255.255.0

--> no ip access-group 1 in

ip directed-broadcast

duplex auto

speed auto

no mop enabled

!

interface GigabitEthernet0/1

ip address 193.126.89.211 255.255.255.0

--> no ip access-group 2 in

ip directed-broadcast

duplex auto

speed auto

no mop enabled

Regards,

GNT

New Member

Re: 2821 Routing problem

Hello GNT

I have tried removing access list from the interfaces, but this doesn't seem to have helped. The access list were as the router is in a development environment set up to 'permit any'.

Re: 2821 Routing problem

Hi,

First of all remove the static routes. You dont need them as you are already running rip and these networks are covered under that. Another thing I have noticed is that these routes have wrong next hop ip configured.

Please let us know the IP/mask/gateway set on your host PC's. Also check if the interfaces are up/up on the router or on the switch side.

HTH,

-amit singh

New Member

Re: 2821 Routing problem

Both interfaces are up/up

PC1 IP address is 10.31.150.13 mask: 255.255.255.0

Gateway 10.31.150.1

PC 2 IP address is 193.126.89.232 mask:255.255.255.0

Gateway 193.126.89.1

Have removed static routes.

New Member

Re: 2821 Routing problem

Your DFGWs configured on the PCs are not the same ip addresses that you have configured on your router. If you want to use this router to route between these two subnets you will have to change your DFGWs on the PCs to match the routers interfaces. I hope this helps...

134
Views
6
Helpful
5
Replies