Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

about multi-NAT

Dear Sirs,

Cisco828 was able to confirm the function.

Table 9 Feature List by Feature Set for the Cisco 828 Routers

Address Conservation

NAT Many to Many(multi-NAT) Yes

http://www.cisco.com/en/US/products/sw/iosswrel/ps5012/prod_release_note09186a0080081189.html

It is not possible to confirm it with other models.

Does not bbb operate excluding multi-NAT ?

What is equivalent to multi-NAT a function excluding Cisco828 ?

Best regards,

2 REPLIES
VIP Purple

Re: about multi-NAT

Hello,

multi-NAT, or many-to-many, is simply using a pool of target IP addresses, and an access list containing the source IP addresses, as in this example:

ip nat pool POOL1 10.10.10.1 10.10.10.254 netmask 255.255.255.0

ip nat inside source list 1 pool POOL1

!

access-list 1 permit 192.168.1.0

This is supported on all routers. I am not sure if the terminology ´multi-NAT´ is used that often, but it is the most basic (and most common) way of implementing NAT.

HTH,

GP

Re: about multi-NAT

Hi

Are you pointing something inline with usage of Route-maps to facilitate the translations ??

something like mentioned below ??

having different local address getting natted to different global pools ??

ip nat pool provider1-space 171.69.232.1 171.69.232.254 prefix-length 24

ip nat pool provider2-space 131.108.43.1 131.108.43.254 prefix-length 24

ip nat inside source route-map provider1-map pool provider1-space

ip nat inside source route-map provider2-map pool provider2-space

!

interface Serial0/0

ip nat outside

!

interface Serial0/1

ip nat outside

!

interface Fddi1/0

ip nat inside

!

route-map provider1-map permit 10

match ip address 1

match interface Serial0/0

!

route-map provider2-map permit 10

match ip address 2

match interface Serial0/1

regds

146
Views
10
Helpful
2
Replies
CreatePlease to create content