Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Adsl connection not working? Please help

Hey guys,

I'm going crazy trying to get my cisco 1701 adsl modem to work.

My setting are below, please tell me what is wrong???

User Access Verification

Password:

Gateway>enable

Password:

Gateway#show run

Building configuration...

Current configuration : 1517 bytes

!

! Last configuration change at 01:33:16 UTC Fri Mar 1 2002

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Gateway

!

boot-start-marker

boot-end-marker

!

enable secret xxx.

enable password *******

!

no aaa new-model

ip subnet-zero

!

!

ip dhcp excluded-address 192.168.1.254

!

ip dhcp pool Haqsta

network 192.168.1.0 255.255.255.0

default-router 192.168.1.254

dns-server 203.x.x.191

!

!

ip cef

ip audit notify log

ip audit po max-events 100

ip ssh break-string

vpdn enable

!

vpdn-group pppoe

request-dialin

protocol pppoe

!

no ftp-server write-enable

no scripting tcl init

no scripting tcl encdir

!

!

!

!

no crypto isakmp enable

!

!

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 8/35

pppoe-client dial-pool-number 1

!

dsl operating-mode auto

!

interface BRI0

no ip address

shutdown

!

interface FastEthernet0

ip address 192.168.1.254 255.255.255.0

ip nat inside

ip tcp adjust-mss 1452

speed auto

full-duplex

!

interface Dialer1

mtu 1492

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

ppp pap sent-username *****@*****.net.au password 0 ********

!

ip nat inside source list 1 interface Dialer1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip http server

ip http secure-server

!

!

!

access-list 1 permit 0.0.0.254 255.255.255.0

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

password ******

login

!

!

end

Gateway#

4 REPLIES

Re: Adsl connection not working? Please help

Hello could you be more specific in what kind of problems you have?

what is not working? do you have layer 1 issues? layer 2? layer3 issues?

Please let us know,

Vlad

New Member

Re: Adsl connection not working? Please help

This is just a small home network with the 1701 as the firewall with a 8 port switch.

The problem is i can not get any access out on my clients. I can not ping any where so i think i do not have the right access for my clients to be able to browse or i have not configured the pppoe connection right....

Does all my settings look correct?? AM i missing something?

Re: Adsl connection not working? Please help

HI

access-list 1 permit 0.0.0.254 255.255.255.0 why u have used this i think it should be like this

access-list 1 permit 192.168.1.0 0.0.0.255 can u try changing this and see.

Thanks

Mahmood

New Member

Re: Adsl connection not working? Please help

No that did not help.

This is the exact document i have followed.

Sample Configurations

DSL Router With Built-In Modem - DHCP

o DHCP and DSL requires you to get a pppoe password and username from your ISP. Most ISPs have a homepage where you can register to get the username and password, ask customer service for the URL. You should substitute this username and password for PPP "username" and "password" listed below.

o Cisco IOS doesn't support DHCP DSL and NAT. If this is so, then putting an Internet accessible web server on your home network would be impossible using the routers mentioned above in this configuration.

o Here is a sample configuration for a Cisco home router. Some of the commands listed are part of Cisco's default settings. Do the "show run" command before starting to configure your router to see what commands you'll really need.

o Remember to be in "config" mode to enter these commands and remember to do a "write memory" at the end to permanently save the configuration

Cisco DSL Router With Built-in Modem Configuration (DHCP)

!vpdn enableno vpdn logging !--- Configure the router's PPPoE client so that it!--- can setup a session with the ISP!vpdn-group pppoe request-dialin protocol pppoe !--- Configure the home / SOHO network interface's!--- IP address!--- The "ip nat" statement tells your router that!--- this interface:!--- 1) uses NAT!--- 2) is the inside "private" interface!interface FastEthernet0 ip address 192.168.1.1 255.255.255.0 ip nat inside !--- Configure the DSL interface!--- Your ISP may provide you with a different pvc!--- value not necesarily "1/1"!interface ATM0 no ip address no atm ilmi-keepalive bundle-enable dsl operating-mode auto hold-queue 224 in!interface ATM0.1 point-to-point pvc 1/1 pppoe-client dial-pool-number 1 !--- Cisco prefers to run the PPPoE client on a virtual!--- "dialer" interface!--- This is tied to the real ATM DSL interface with the !--- "dialer pool" command. The default ethernet MTU!--- size has been reduced from 1500 to accommodate!--- the PPPoE header overhead.!!--- The "ip nat" statement tells your router that!--- this interface:!--- 1) uses NAT!--- 2) is the outside "public" interface!interface Dialer1 ip address negotiated ip mtu 1492 ip nat outside encapsulation ppp dialer pool 1 !--- Here are the commands to configure authentication!--- with with your ISP. This example uses the "CHAP"!--- method.!--- Commands for using the "PAP" method are included at!--- the end of this box! ppp authentication chap callin ppp chap hostname ppp chap password ! !--- Tells the router to NAT all traffic that passes!--- through it:!--- 1) From the inside to the outside,!--- 2) And whose IP address is in the 192.168.1.0 network!--- as given in access list 1!--- 3) Giving it an outside "public" address that is the!--- same as interface Dialer1 gets from the PPPoE!--- connection!ip nat inside source list 1 interface Dialer1 overloadip classlessip route 0.0.0.0 0.0.0.0 dialer1no ip http server!access-list 1 permit 192.168.1 0.0.0.255

o If your ISP tells you that you need to do the PAP, and not the CHAP, type of authentication then you'll have to replace the lines:

ppp authentication chap callin

ppp chap hostname

ppp chap password

with only these two:

ppp authentication pap callin

ppp pap sent-username password

Can some please help me fix what i am missing or have done wrong.

279
Views
0
Helpful
4
Replies
CreatePlease login to create content