Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CDP Not showing Neighbours

I am attempting to update our network diagrams and am finding with some sites that the neighbours do not show up.

CDP is enabled on the switch and router from what I can tell.

The router is a 3550 and switch is a 2950, for this particular site the core router will not show any neighbours, although if you connect to a switch it will show the router.

As with some switches will show their neighbours and others will not.

Any pointers in what to check, or even with this occuring is there an easy way to find out neighbours of a device without CDP working.

Thanks

Dan

10 REPLIES
New Member

Re: CDP Not showing Neighbours

Dan,

Have you tried comparing the configs between what's working from what's not working? Can you post the config?

hieu

New Member

Re: CDP Not showing Neighbours

Here is the config of the router..

!

! Last configuration change at 09:14:41 Eastern Mon Apr 30 2007

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname ---

!

enable secret xxx

!

clock timezone Easternstandard 10

clock summer-time Easternsummer recurring last Sun Oct 2:00 last Sun Mar 3:00

ip subnet-zero

ip routing

!

mls qos

!

spanning-tree extend system-id

!

!

!

interface Loopback0

description Management_Interface

ip address xxx.xxx.xxx.xxx 255.255.255.255

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20,100,300,1002-1005

switchport mode trunk

no ip address

!

interface GigabitEthernet0/1

description WAN_Interface

no switchport

ip address xxx.xxx.xxx.xxx 255.255.255.252

!

interface GigabitEthernet0/2

description Spare_trunk_Tie

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20,100,300,1002-1005

switchport mode trunk

no ip address

!

interface GigabitEthernet0/3

description Spare_trunk_Tie

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20,100,300,1002-1005

switchport mode trunk

no ip address

!

interface GigabitEthernet0/4

description Spare_trunk_Tie

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20,100,300,1002-1005

switchport mode trunk

no ip address

!

interface GigabitEthernet0/5

description Spare_trunk_Tie

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20,100,300,1002-1005

switchport mode trunk

no ip address

!

interface GigabitEthernet0/6

description Spare_trunk_Tie

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20,100,300,1002-1005

switchport mode trunk

no ip address

!

interface GigabitEthernet0/7

description Spare_trunk_Tie

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20,100,300,1002-1005

switchport mode trunk

no ip address

!

interface GigabitEthernet0/8

description Spare_trunk_Tie

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20,100,300,1002-1005

switchport mode trunk

no ip address

!

interface GigabitEthernet0/9

description Spare_trunk_Tie

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20,100,300,1002-1005

switchport mode trunk

no ip address

!

interface GigabitEthernet0/10

description Spare_trunk_Tie

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20,100,300,1002-1005

switchport mode trunk

no ip address

!

interface GigabitEthernet0/11

description Spare_trunk_Tie

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20,100,300,1002-1005

switchport mode trunk

no ip address

duplex full

speed 1000

channel-group 1 mode on

!

interface GigabitEthernet0/12

description Server_Switch

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20,100,300,1002-1005

switchport mode trunk

no ip address

duplex full

speed 1000

channel-group 1 mode on

!

interface Vlan1

description Not in Use

no ip address

shutdown

!

interface Vlan10

description IT_Faculty

no ip address

ip access-group ITfaculty in

!

interface Vlan20

description ITFaculty

ip address xxx.xxx.xxx.xxx 255.255.254.0

ip access-group ITfaculty in

!

interface Vlan100

description Data

ip address xxx.xxx.xxx.xxx 255.255.254.0

!

interface Vlan300

description Voice

ip address xxx.xxx.xxx.xxx 255.255.254.0

ip helper-address xxx.xxx.xxx.xxx

!

ip classless

ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx name LastResort

ip http server

!

Hall of Fame Super Silver

Re: CDP Not showing Neighbours

Daniel

I believe that there is a significant clue about what is going on in this statement from your post: "The router is a 3550 and switch is a 2950, for this particular site the core router will not show any neighbours, although if you connect to a switch it will show the router." I believe that it confirms what the config shows which is that CDP is running on the router.

My guess is that CDP is not running on the switch interfaces. It would be helpful if you would post the output of show cdp interface from both the router and the switch.

HTH

Rick

New Member

Re: CDP Not showing Neighbours

*** Example From Switch ***

6073--MG12ES001#show cdp

Global CDP information:

Sending CDP packets every 60 seconds

Sending a holdtime value of 180 seconds

Sending CDPv2 advertisements is enabled

6073--MG12ES001#

6073--MG12ES001#show cdp interface

FastEthernet0/1 is up, line protocol is up

Encapsulation ARPA

Sending CDP packets every 60 seconds

Holdtime is 180 seconds

FastEthernet0/2 is up, line protocol is up

Encapsulation ARPA

Sending CDP packets every 60 seconds

Holdtime is 180 seconds

FastEthernet0/3 is up, line protocol is up

Encapsulation ARPA

Sending CDP packets every 60 seconds

Holdtime is 180 seconds

*** Example from router ***

6073--AG23LR002#show cdp

Global CDP information:

Sending CDP packets every 60 seconds

Sending a holdtime value of 180 seconds

Sending CDPv2 advertisements is enabled

6073--AG23LR002#show cdp inter

6073--AG23LR002#show cdp interface

GigabitEthernet0/1 is up, line protocol is up

Encapsulation ARPA

Sending CDP packets every 60 seconds

Holdtime is 180 seconds

GigabitEthernet0/2 is down, line protocol is down

Encapsulation ARPA

Sending CDP packets every 60 seconds

Holdtime is 180 seconds

GigabitEthernet0/3 is down, line protocol is down

Encapsulation ARPA

Sending CDP packets every 60 seconds

Holdtime is 180 seconds

Thanks

Hall of Fame Super Silver

Re: CDP Not showing Neighbours

Daniel

Thanks for posting the additional information. While it does not give me the answer, perhaps it allows us to get a bit deeper into the issue. It does show that CDP is globally enabled on the router and on the switch.

I note that the output indicates that the router gig0/1 is an access port and is up/up but that gig0/2 and gig0/3 are trunk ports and are down/down. Is there some issue with these ports? Perhaps we need some output to be posted to show who sees neighbors on what interfaces.

HTH

Rick

New Member

Re: CDP Not showing Neighbours

Hi Rick,

From the information I have been able to gather, it appears there are no devices on these ports mentioned above, there are devices connected only to those ports showing as up/up.

Hope I am on the right track here :)

Dan

Hall of Fame Super Silver

Re: CDP Not showing Neighbours

Dan

If there are no devices connected on these ports it would certainly explain why they are down/down.

Rick

New Member

Re: CDP Not showing Neighbours

Hi Dan,

I think you should specify which port on the switch and the router were being used to connect to each other in order to avoid the confusion of up/up or down/down.

Jeff

Purple

Re: CDP Not showing Neighbours

I have seen this at times with cisco and it does behave as you have suggested . A few times I have been able to fix it by doing a "clear interface " on the attaching interfaces and cdp would start showing up again otherwise you may be stuck either living with it or reload the devices to see if that would fix it . Might want to consider upgrading the 3550 it looks like it is still running 12.1 code which is way out of date for the 3550 .

New Member

Re: CDP Not showing Neighbours

Thanks all for you reponses and time, we have updated the names on each switch to bring them into standard and they are now showing up on CDP.

Got love these problems.

Dan

1268
Views
12
Helpful
10
Replies