Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

cisco 1812 dhcp problem

Hi,

I've got a question. I configured my cisco to give IP addresses automatically to other PC's on network. The problem is getting a new address or renewing takes a long of time. For example when I run my DHCP server on Linux then renewing and getting times of new addresses takes about few seconds. On Cisco it takes more than 20-30 seconds. Sometimes especially on OS's from Linux branch I've got timeouts and need to tune manually timeouts in dhcp-client.

Can I do something with it ? Are there any tips & tricks to tune dhcp server on Cisco ?

When I configure static IP for some PC's (f.e. servers) getting IP's times are the same.

p.s. Router is new and now it has basic configuration and for the present doesn`t have any ACL and firewall rules yet.

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Re: cisco 1812 dhcp problem

Is your dhcp client connected to a cisco switch? If so make sure port-fast is enabled on all ports that connect PCs. If this is not enabled their will be a delay until the DHCP discover packets are forwarded because the switchport is still going through all its STP timers.

10 REPLIES
Hall of Fame Super Gold

Re: cisco 1812 dhcp problem

Jaroslaw

Taking that long to assign DHCP addresses seems unusual. Perhaps a good place to start would be to post the entire config of the router so that we might see if there is some config reason that impacts operation of DHCP.

If that does not reveal the problem it might be helpful to run debug for DHCP and to post the debug output.

HTH

Rick

New Member

Re: cisco 1812 dhcp problem

Hi, thank You for an answer.

Here is my entire running config.

hell#sh run

Building configuration...

Current configuration : 4032 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname hell

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

enable secret 5 xxxxxxxxxxxxxxxxx

!

no aaa new-model

!

!

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.0.0

!

ip dhcp pool SERWER

host 192.168.0.10 255.255.255.0

hardware-address 001a.6449.a8d2

default-router 192.168.0.1

dns-server 192.168.1.1

!

ip dhcp pool LAN

network 192.168.0.0 255.255.255.0

dns-server 192.168.1.1

default-router 192.168.0.1

!

!

no ip domain lookup

!

multilink bundle-name authenticated

!

crypto pki trustpoint TP-self-signed-2576536838

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2576536838

revocation-check none

rsakeypair TP-self-signed-2576536838

!

!

crypto pki certificate chain TP-self-signed-2576536838

certificate self-signed 01

!!!!certificate here!!! quit

!

!

username xxxxxx privilege 15 secret 5 xxxxxxxxxxxxxx

!

!

!

!

!

!

interface FastEthernet0

ip address dhcp

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet1

no ip address

shutdown

duplex auto

speed auto

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

interface FastEthernet2

switchport access vlan 2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface FastEthernet5

!

interface FastEthernet6

!

interface FastEthernet7

!

interface FastEthernet8

!

interface FastEthernet9

switchport access vlan 2

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-FE 2$

ip address 10.10.10.1 255.255.255.248

ip tcp adjust-mss 1452

!

interface Vlan2

description LAN

ip address 192.168.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

ip route 0.0.0.0 0.0.0.0 192.168.1.1

ip route 192.168.0.0 255.255.255.0 Vlan2

ip route 192.168.1.0 255.255.255.0 FastEthernet0

!

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat translation timeout 180

ip nat translation tcp-timeout 600

ip nat inside source list SIEC2NAT interface FastEthernet0 overload

!

ip access-list extended SIEC2NAT

permit ip 192.168.0.0 0.0.0.255 any

!

no cdp run

!

!

!

!

!

!

control-plane

!

banner login ^C

Sun Microsystem.

^C

!

line con 0

login local

line aux 0

line vty 0 4

access-class 23 in

privilege level 15

login local

transport input telnet ssh

line vty 5 15

access-class 23 in

privilege level 15

login local

transport input telnet ssh

!

end

Hall of Fame Super Gold

Re: cisco 1812 dhcp problem

Jaroslaw

Thank you for posting the config of the router. I do not see anything in it that would explain the delay in processing DHCP. Perhaps it would be helpful if your could run debug dhcp and debug ip dhcp server events and post the output.

HTH

Rick

Re: cisco 1812 dhcp problem

The problem is the hostname on your router of 'hell.' Telling packets to go to 'hell' always causes an issue. Packets don't like to be told that...

Okay, seriously, like Rick said, post your debugs. :)

-brad

www.ccbootcamp.com

(please rate the post if this helps!)

Bronze

Re: cisco 1812 dhcp problem

Is your dhcp client connected to a cisco switch? If so make sure port-fast is enabled on all ports that connect PCs. If this is not enabled their will be a delay until the DHCP discover packets are forwarded because the switchport is still going through all its STP timers.

New Member

Re: cisco 1812 dhcp problem

Hi,

I followed by your issues and the configuration shown below gives 100% success.

interface FastEthernet9

switchport access vlan 2

duplex full

speed 100

spanning-tree portfast

I specified also duplex mode and speed not to let router and PC negotiate that values. Now not many devices works on 10 MBits so the negotiation is not useful.

I have found an cisco webpage with manual where is described that kind of problem. I pasted it for anyone who would have a problem with it.

http://www.cisco.com/warp/public/473/12.html

Thanks anyone for help me :-).

Regards,

Jarek

p.s. ccbootcamp ;-)... yeah I wondered if that 'hell' hostname won`t be a problem and I had an idea to rename my router but I still belived that it can`t be a problem ;-). God loves us ;-).

Re: cisco 1812 dhcp problem

Glad you fixed your prob. But I would still take a look at the debugs if I were you so you can understand what was happening with the packets a bit better. It's a great troubleshooting step you can utilize in the future. :)

-brad

www.ccbootcamp.com

(please rate the post if this helps!)

New Member

Re: cisco 1812 dhcp problem

Hi :-).

I have watched on debug infos, but nothing special there I saw. Everything works fine for me now. I`m preparing device to work and we will see after new year how does it handle it on all PC's in company (about 60). If it won`t work I will not have time for play with it and will need to run alternate dhcp server on Linux until I will not find a problem.

Anyway I`m sure everything will work fine ;).

New Member

Re: cisco 1812 dhcp problem

Jarek,

Not sure if you did this or not yet but:

I noticed that you hard coded the speed and duplex on the switch ports. In order to achieve maximum performance you'll have to hard code the speed and duplex on the workstations NIC's themselves or there will be a miss match.

Craig

New Member

Re: cisco 1812 dhcp problem

Hmm.. I thought hard coding duplex mode and speed of switch port will give me maximum performance because when they will not need to negotiate that values but router enforces them to workstation, doesn't it ? The time should be shorter because negotiation process of that values will be hard coded. Anyway at the present NIC's don`t need to work in 10Mbps. The minimum value is 100Mbps.

From the other way to the swichport will be connected only server and the other switch which will connect all the other stations.

Regards,

Jarek

1070
Views
0
Helpful
10
Replies
CreatePlease to create content