Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 2620 eigrp/ospf issues

Greetings,

I'm having issues getting a Cisco 2620 and a Dell Powerconnect 6024 to redistribute via eigrp/ospf correctly which are both at a remote location. I have attached a basic diagram to better show the topology. We have been unable to access the remote site from our main site (which is using a cisco 3600) without a static route for each subnet at the remote site. Hopefully this makes sense.

Cisco 2620 Config:

Building configuration...

Current configuration:

!

!

!

!

!

ip subnet-zero

!

lane client flush

cns event-service server

!

!

!

!

!

interface FastEthernet0/0

ip address 10.100.187.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

ip address 10.100.181.10 255.255.255.252

no ip mroute-cache

no fair-queue

!

router eigrp 100

redistribute connected

redistribute ospf 1

network 10.0.0.0

no auto-summary

!

router ospf 1

redistribute connected

redistribute eigrp 100 subnets

network 10.100.0.0 0.0.255.255 area 0.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.100.181.9

no ip http server

!

!

banner motd ^CCC

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Cisco 2620 eigrp/ospf issues

Timothy

There are a couple of things that I am not clear about concerning your situation. Your diagram shows a single subnet between the Cisco and the Dell. Is everything in the Dell in that single subnet? If so I am not sure why you are running OSPF, since there will not be any OSPF routes to redistribute.

If the diagram is incomplete and there are routes in OSPF that need to redistribute to EIGRP then there is an issue in the configuration. There is no default metric configured under router EIGRP. Without a default metric routes from another protocol (OSPF) will not redistribute into EIGRP.

I think it is also an interesting question whether the 2620 and the 3600 routers are forming EIGRP neighbor relationships. Failure to form EIGRP neighbor relationships could also cause the symptoms that you describe.

HTH

Rick

6 REPLIES
New Member

Re: Cisco 2620 eigrp/ospf issues

1) are you recieving routes on the 2620 from the dell?

1a) are the expected neighbors showing up?

2) are you recieving any routes on the 2620 from the 3600

2a) are the expected neighbors showing up

3) are you recieving any routes on the 3600 from the 2620?

Hall of Fame Super Silver

Re: Cisco 2620 eigrp/ospf issues

Timothy

There are a couple of things that I am not clear about concerning your situation. Your diagram shows a single subnet between the Cisco and the Dell. Is everything in the Dell in that single subnet? If so I am not sure why you are running OSPF, since there will not be any OSPF routes to redistribute.

If the diagram is incomplete and there are routes in OSPF that need to redistribute to EIGRP then there is an issue in the configuration. There is no default metric configured under router EIGRP. Without a default metric routes from another protocol (OSPF) will not redistribute into EIGRP.

I think it is also an interesting question whether the 2620 and the 3600 routers are forming EIGRP neighbor relationships. Failure to form EIGRP neighbor relationships could also cause the symptoms that you describe.

HTH

Rick

New Member

Re: Cisco 2620 eigrp/ospf issues

Rick,

The diagram I posted was very basic. We have 10 VLAN's at this remote location with different subnets for each one. All of the VLAN's are setup on the Dell.

What should the configuration look like then under the router eigrp? I posted the configuration in my first post which looks like this:

router eigrp 100

redistribute connected

redistribute ospf 1

network 10.0.0.0

no auto-summary

The 2620 and the 3600 are showing each other as eigrp neighbor's so again it leads me to believe that I have the configuration wrong on the eigrp.

New Member

Re: Cisco 2620 eigrp/ospf issues

Rick,

Your tip on the metric was correct! I specified the default metric for ospf. Please let me know if i should make changes to this line. The connection is a T-1.

redistribute ospf 1 metric 100 10 255 1 1500

Tim

Hall of Fame Super Silver

Re: Cisco 2620 eigrp/ospf issues

Tim

I am glad that you now have it working. While some people I know will try to tune the default metric to accurately reflect the performance of the local link, I usually do not bother. As long as the OSPF routes are redistributed it will not change the routing decisions whether the default metric is very small, very large, or somewhere in between.

Thanks for using the rating system to indicate that your issue was resolved (and thanks for the rating). It makes the forum more useful when people can read about an issue and can know that they will read the solution to the issue. I encourage you to continue your participation in the forum.

HTH

Rick

New Member

Re: Cisco 2620 eigrp/ospf issues

I am receiving ospf routes from the Dell to the 2620 and the expected neighbors are showing up.

The eigrp neighbor's are showing up correctly on the 2620 and the 2620 is receiving routes from the 3600. However when I look at the 3600 I don't see any routes from the 2620 even though the eigrp neighbor's are showing up.

At this point the only way for us to communicate to the dell from the main office is to put a static route on the 3600. This leads me to believe that I have the wrong eigrp configuration on the 2620 since the 3600 is not receiving updates.

538
Views
0
Helpful
6
Replies