Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 3750 etherchannel configuration

I have cisco3750 switch i am trying to make ether channel on that switch below is the configuration i have done on same switch

interface GigabitEthernet1/0/23

switchport mode trunk

speed auto 10 100 1000

duplex full

channel-group 1 mode on

!

interface GigabitEthernet1/0/24

switchport mode trunk

speed auto 10 100 1000

duplex full

channel-group 1 mode on

spanning-tree bpdufilter enable

interface Port-channel1

switchport mode trunk

kindly suggest that configuration is proper or any other configuration is required

second switch is nortel l2 switch, we are creating l2 etherchannel

  • Getting Started with LANs
4 ACCEPTED SOLUTIONS

Accepted Solutions
New Member

Cisco 3750 etherchannel configuration

as far as I know Nortel supports LACP. you need to specify channel-protocol LACP. furthermore, port-channel and interface configs must be identical

New Member

Cisco 3750 etherchannel configuration

yes. like

interface xxxx

channel-protocol lacp

New Member

Cisco 3750 etherchannel configuration

Hello Kamal,

Actually for the Ether-Channel to come up, the configuration on both physical interfaces have to be identical, not the configuration between the physical interfaces and the port-channels. As a matter of fact, you can have "some" configuration under the physical interfaces and the rest, under the port-channel.

Good practice is to place the minimum configuration under the physical interfaces to have them join the port-channel group, and once joined, place all other configurations under the port-channel.

Another good practice, if you have a multi-vendor environement, you better not use LACP. Although LACP is a standards based protocol, different vendors may have slightly different implementations for it. Better go for static ether channel, as you have in your original post.

when you configure speed auto, you do not need to specify 10, 100 and 1000. These options are only there if you want to limit the speed negotiation. By default all of them wil be attempted.

Having said that, please see below the steps:

config t

!

default interface Gig1/0/23

default interface Gig1/0/24

!

interface GigabitEthernet1/0/23

channel-group 1 mode on

!

interface GigabitEthernet1/0/24

channel-group 1 mode on

!

Then make sure the interfaces have joined the Ether-Channel by entering the command:

show etherchannel summary

Then enter the rest of the commands under the port channel:

!

interface Port-channel1

switchport mode trunk

duplex full

speed auto

spanning-tree bpdufilter enable

!

New Member

Cisco 3750 etherchannel configuration

Just an additional input, prior to configuration, it's best practice to shutdown the interfaces before the etherchannel configuration. I had an experience wherein the etherchannel won't work for some reason.

So in this case, shutdown gi 1/0/23 and 24 first, configure with etherchannel, then no shut.

9 REPLIES
New Member

Cisco 3750 etherchannel configuration

as far as I know Nortel supports LACP. you need to specify channel-protocol LACP. furthermore, port-channel and interface configs must be identical

New Member

Cisco 3750 etherchannel configuration

Thanks emmanuel for ur prompt help so I need to put lacp protocol at my cisco switch.

New Member

Cisco 3750 etherchannel configuration

yes. like

interface xxxx

channel-protocol lacp

New Member

Cisco 3750 etherchannel configuration

Thanks a lot I will made these changes

New Member

Cisco 3750 etherchannel configuration

Hello Kamal,

Actually for the Ether-Channel to come up, the configuration on both physical interfaces have to be identical, not the configuration between the physical interfaces and the port-channels. As a matter of fact, you can have "some" configuration under the physical interfaces and the rest, under the port-channel.

Good practice is to place the minimum configuration under the physical interfaces to have them join the port-channel group, and once joined, place all other configurations under the port-channel.

Another good practice, if you have a multi-vendor environement, you better not use LACP. Although LACP is a standards based protocol, different vendors may have slightly different implementations for it. Better go for static ether channel, as you have in your original post.

when you configure speed auto, you do not need to specify 10, 100 and 1000. These options are only there if you want to limit the speed negotiation. By default all of them wil be attempted.

Having said that, please see below the steps:

config t

!

default interface Gig1/0/23

default interface Gig1/0/24

!

interface GigabitEthernet1/0/23

channel-group 1 mode on

!

interface GigabitEthernet1/0/24

channel-group 1 mode on

!

Then make sure the interfaces have joined the Ether-Channel by entering the command:

show etherchannel summary

Then enter the rest of the commands under the port channel:

!

interface Port-channel1

switchport mode trunk

duplex full

speed auto

spanning-tree bpdufilter enable

!

New Member

Cisco 3750 etherchannel configuration

To configure LACP you have two config option

Option1

======

interface

  channel-group 1 mode on

  channel-protocol lacp

Option2

======

interface

channel-group 1 mode active

New Member

Cisco 3750 etherchannel configuration

Thanks ibrahim

New Member

Cisco 3750 etherchannel configuration

Dear Ibrahim / Emmaunel,

so i need to create channel

interface Port-channel1

  channel-group 1 mode on

  channel-protocol lacp

or

interface Port-channel1

channel-group 1 mode active

and remove my old port channel

New Member

Cisco 3750 etherchannel configuration

Just an additional input, prior to configuration, it's best practice to shutdown the interfaces before the etherchannel configuration. I had an experience wherein the etherchannel won't work for some reason.

So in this case, shutdown gi 1/0/23 and 24 first, configure with etherchannel, then no shut.

467
Views
0
Helpful
9
Replies