Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 831 and AT&T DSL

Hi all.

I have a 2wire DSL router configured as a layer 2 bridge and directly connected to it is a Cisco 831.

I would like to have the Cisco 831 running as a PPPoE client for the DSL connection and NAT for my LAN.

However, I cannot get my configuration to work.

When I place a Linksys WRT54G behind the bridge, it connects via PPPoE with no problems but I would really like to place the 831 on the outside of my LAN.

debug pppoe events on the 831 (directly connected to the bridge) shows the following repeating loop:

Mar 31 : Sending PADI: Interface = Ethernet1

Mar 31 : padi timer expired

Mar 31 : Sending PADI: Interface = Ethernet1

Any help debugging the bba-group, vpdn and interface configurations would be very appreciated.

---------------------------------

Current configuration : 4650 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Cisco831

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool sdm-pool

import all

network 10.10.10.0 255.255.255.248

default-router 10.10.10.1

lease 0 2

!

!

ip cef

ip domain name yourdomain.com

vpdn enable

!

vpdn-group 1

request-dialin

protocol l2tp

domain global

!

!

username xxxxxxxx privilege 15 secret xxxxxxxx

!

!

!

!

bba-group pppoe global

virtual-template 1

!

!

interface Ethernet0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-Ethernet 10/100$

ip address 10.10.10.1 255.255.255.248

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1412

!

interface Ethernet1

description $ETH-WAN$

no ip address

ip mtu 1492

ip nat outside

ip virtual-reassembly

duplex auto

pppoe enable group global

pppoe-client dial-pool-number 1

!

interface Ethernet2

no ip address

shutdown

!

interface FastEthernet1

duplex auto

speed auto

!

interface FastEthernet2

duplex auto

speed auto

!

interface FastEthernet3

duplex auto

speed auto

!

interface FastEthernet4

duplex auto

speed auto

!

interface Dialer0

ip address negotiated

ip mtu 1452

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname xxxxxxxx

ppp chap password xxxxxxxx

ppp pap sent-username xxxxxxxx password xxxxxxxx

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip nat inside source list 1 interface Dialer0 overload

!

access-list 1 permit 10.10.10.0 0.0.0.7

dialer-list 1 protocol ip permit

!

line con 0

login local

no modem enable

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

end

1 REPLY
New Member

It has been a really long

It has been a really long time since I have used AT&T DSL, I was able to find an old 831 config for you. This was a working config when this device was in use.

Regards,

Sam

318
Views
0
Helpful
1
Replies