Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DHCP and VLANS

Hello, I'm trying to configura simple VLAN in packet Tracer, In my company we have a rooter 2811 and a switch 2960 Catalyst 48TT.

In the packet tracer I use 2811 and 2960 24 TT and 2 PC's, I try to configure 2 vlan's vlan 10 use the port 5 in wtich is conected the PC0 and vlan 20 the port 6 in switch with PC1, The rooter is conected to the switch throught the 2 fastethernet lines to the switch gigabitethernet ports. Both PC's have an DHCP request failed. I hope somebody can explein me what I'm not doing well. I'm attach the packet tracer file.

This is the roote configuration:

enable
conf t
host R1
int fa0/0
no shut
int fa0/0.1
encapsulation dot1q 10
ip add 192.168.0.1 255.255.255.0
no shut
exit
int fa0/0.2
encapsulation dot1q 20
ip add 192.168.1.1 255.255.255.0
no shut
exit

ip dhcp pool IP10
net 192.168.0.0 255.255.255.0
default 192.168.0.1
exit
ip dhcp exc 192.168.0.1 192.168.0.10

ip dhcp pool IP20
net 192.168.1.0 255.255.255.0
default 192.168.1.1
exit
ip dhcp exc 192.168.1.1 192.168.1.10
exit

copy run start

sh ru

exit

This is the switch conf:

enable
vlan database
vlan 10 name 10
vlan 20 name 20
exit

configure t
interface fast 0/5
switchport access vlan 10
end

inter fa 0/6
switchport access vlan 20
end
write memory

4 REPLIES
Hall of Fame Super Silver

Re: DHCP and VLANS

Hello Eduardo,

the switch interface connecting to the router has to be configured as an 802.1Q trunk

int f0/x

switchport

switchport trunk enc dot1q

switchport mode trunk

Hope to help

Giuseppe

New Member

Re: DHCP and VLANS

I think maybe

"switchport trunk enc dot1q" command will not work.

So, you can run only this command "switchport mode trunk"

Regards,

Dasuntha

New Member

Re: DHCP and VLANS

Hi

please Find attached file

i was complete the configuration and everything work fine

do show run and check configuration and tell me if you don’t understand

New Member

Re: DHCP and VLANS

Thanks khaked, my packed tracer can't open the file, but anyway the problem was allready

resolved, I has to put the conection in mode trunk.

2716
Views
0
Helpful
4
Replies