Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

DHCP Configuration

Hi,

I have this topology:

I can configure a dhcp pool in the Router B, this dhcp pool is for the VLANC 10.0.0.0, this work?

Configuration:

Router A

interface GigabitEthernet0/1

description LANs

interface GigabitEthernet0/1.10

description VLANB

ip address 172.16.0.1 255.255.255.0

interface GigabitEthernet0/1.20

description VLANC

ip address 10.0.0.1 255.255.255.0

ip helper-addres <192.168.0.2 - ip address of the RouterB>

interface GigabitEthernet0/1.30

description VLANA

ip address 192.168.0.1 255.255.255.0

Note : the only ip address of the RouterB is the 192.168.0.2.

RouterB:

interface GigabitEthernet0/1

ip address 192.168.0.2 255.255.255.0

exit

i

ip route 0.0.0.0 0.0.0.0 192.168.0.1

ip dhcp excluded-address 10.0.0.1 10.0.0.10

ip dhcp pool VlanC

network 10.0.0.0 255.255.255.0

default-router 10.0.0.1

exit

this configuration of the DHCP pool in the Router B, will work?

2 REPLIES
Purple

DHCP Configuration

Hi,

first on router A you need to configure the encapsulation and vlan first before putting an IP address so

Router A

interface GigabitEthernet0/1

description LANs

interface GigabitEthernet0/1.10

description VLANB

encap dot1q 10

ip address 172.16.0.1 255.255.255.0

interface GigabitEthernet0/1.20

description VLANC

encap dot1q 20

ip address 10.0.0.1 255.255.255.

interface GigabitEthernet0/1.30

description VLANA

encap dot1q 1 30

ip address 192.168.0.1 255.255.255.0

Otherwise the config should  work.

Regards.

Alain.

Don't forget to rate helpful posts.

Re: DHCP Configuration

Hi,

Your configuration looks fine to me. Seems you got a switch in between. As alian point out, if you want to use sub-interfaces on routerA. You need to configure 802.1q.

HTH

Toshi

Sent from Cisco Technical Support iPhone App

475
Views
0
Helpful
2
Replies
CreatePlease to create content