Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

DHCP not giving IP's to wireless clients

Hello,

I am configuring an 877w router.

I have configured my DHCP pool, no problems. I tested it using my local LAn, all clients are getting the ip's from the pool I specified.

However, when I scan and try to connect to my SSID, it starts connecteing 'forever' and states a problem: my client can't get an IP lease from my DHCP server. When I give my Windows XP box an available ip from the same NAT pool, it connects to the network, but it can't ping my gateway (although its setup..). I also can't access any network recources. I can ping my loopback IP and my local setup IP.

I'm kind of, lost at the moment.

4 REPLIES
New Member

Re: DHCP not giving IP's to wireless clients

Normally, this 169.x.x.x ip address is shown when the AP is not able to get an IP address from a DHCp server. So, check whether a DHCP server is available to provide Ip address and properly configured. Else, configure a static ip address to the AP.

Re: DHCP not giving IP's to wireless clients

Can you post your config?

New Member

Re: DHCP not giving IP's to wireless clients

There you go mate

Octacis#sh running-config

Building configuration...

!

version 12.4

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

hostname Octacis

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 debugging

logging console critical

enable secret -----

!

aaa new-model

!

!

aaa group server radius rad_eap

!

aaa group server radius rad_mac

!

aaa group server radius rad_acct

!

aaa group server radius rad_admin

!

aaa group server tacacs+ tac_admin

!

aaa group server radius rad_pmip

!

aaa group server radius dummy

!

aaa authentication login eap_methods group rad_eap

aaa authentication login mac_methods local

aaa authorization ipmobile default group rad_pmip

aaa accounting network acct_methods start-stop group rad_acct

!

aaa session-id common

!

resource policy

!

clock timezone PCTime 4

ip subnet-zero

no ip source-route

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 10.99.99.65

!

ip dhcp pool sdm-pool1

import all

network 10.99.99.64 255.255.255.192

dns-server 212.x.x.59

default-router 10.99.99.65

!

!

ip tcp synwait-time 10

no ip bootp server

ip domain name alkhaldi.net

ip name-server 212.x.x.59

ip ssh time-out 60

ip ssh authentication-retries 2

!

!

crypto pki -- removed to make post less than 4000 characters-

quit

username xxx privilege 15 secret xxx

!

!

!

bridge irb

!

!

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

description $ES_WAN$$FW_OUTSIDE$

pvc 8/35

pppoe-client dial-pool-number 1

broadcast-key vlan 1 change 45

encryption vlan 1 mode ciphers tkip

!

ssid Al-Jabri.net

vlan 5

!

ssid Alkhaldi.net

vlan 2

authentication open

guest-mode

infrastructure-ssid optional

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0

54.0

station-role root

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.2

encapsulation dot1Q 2 native

ip address 192.168.0.1 255.255.255.0

no snmp trap link-status

no cdp enable

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$FW_INSIDE$

no ip address

bridge-group 1

!

interface Dialer0

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1452

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip route-cache flow

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname p4789860

ppp chap password xxx

ppp pap sent-username - password 7 -

!

interface BVI1

description $ES_LAN$

ip address 10.99.99.65 255.255.255.192

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1412

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 1 interface Dialer0 overload

!

logging trap debugging

access-list 1 remark INSIDE_IF=BVI1

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 10.99.99.64 0.0.0.63

dialer-list 1 protocol ip permit

no cdp run

radius-server attribute 32 include-in-access-req format %h

radius-server vsa send accounting

control-plane

bridge 1 protocol ieee

bridge 1 route ip

banner login ^CAuthorized access only!

Disconnect IMMEDIATELY if you are not an authorized user!^C

-removed lines to make post less than 4000 characters-

scheduler max-task-time 5000

scheduler allocate 4000 1000

scheduler interval 500

end

New Member

Re: DHCP not giving IP's to wireless clients

I'm not sure what you're trying to do here.

You're wired LAN is probably getting the addresses from network 10.99.99.64 255.255.255.192 due to being in VLAN 1.

If you want the wireless to get addresses from the same pool, you would need to change the encapsulation on interface Dot11Radio0.2 to 'dot1q 1 native', and get rid of the ip address.

If you're wanting a seperate pool, you'll need to create the second dhcp pool, create vlan 2, and create bvi2. You'd want to put the ip address of 192.168.0.1 on interface bvi2.

http://www.cisco.com/en/US/products/hw/routers/ps380/products_configuration_guide_book09186a0080627060.html

Thanks.

321
Views
0
Helpful
4
Replies
CreatePlease to create content