Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

DHCP snooping

Hi to All,

I have multiple VLANs configured on a L2/L3 switch (cisco 3750) and one DHCP server configured on wan [using ip helper-address on the switch I forward the DHCP request on a L3 interface.

It' s possible / How can I enable dhcp snooping on the switch ?

It's possible / How can I configure the TRUSTED PORT (the port vs the DHCP server)

FOLLOWING THE CONFIGURATION:

SWITCH

!

!

interface GigabitEthernet1/0/1

description ** DHCP pc 192.168.2.0/24 **

switchport access vlan 2

switchport mode access

load-interval 30

!

interface GigabitEthernet1/0/2

description ** DHCP pc 192.168.2.0/24 **

switchport access vlan 2

switchport mode access

load-interval 30

!

interface GigabitEthernet1/0/3

description ** DHCP pc 192.168.2.0/24 **

switchport access vlan 2

switchport mode access

load-interval 30

!

interface GigabitEthernet1/0/24

description ** TO WAN ROUTER **

no switchport

ip address 192.168.254.254 255.255.255.252

!

!

interface Vlan2

description ** LAN **

ip address 192.168.2.254 255.255.255.0

ip helper-address 192.168.1.254

!

ip forward-protocol udp bootpc

!

IF I TRY TO CONFIGURE THE DHCP SNOOPING I CAN'T CONFIGURE THE TRUST PORT (on the "wan" interface):

SWITCH#conf t

SWITCH(config)#ip dhcp snooping vlan 2

SWITCH(config)#

SWITCH(config)#

SWITCH(config)#interface GigabitEthernet1/0/24

SWITCH(config-if)#ip dhcp ?

client DHCP client configuration

limit Limit DHCP Lease

relay DHCP relay configuration parameters

server Configure DHCP server behavior

1 REPLY

Re: DHCP snooping

You must also enable dhcp snooping globally, not just on the vlan. The steps are described here:

http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.1/13ew/configuration/guide/dhcp.html#wp1073367

regards,

Leo

555
Views
0
Helpful
1
Replies
CreatePlease to create content