Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DHCP - stacked catalyst 3750's

i know this is quite possible but i am unsure if the switches i will be using can do this alone.

ive got IP endpoints that will be piggy backed to PC's at the desks. they will both be on seperate VLAN's. i am curious if they can pull addresses from two different DHCP scopes.

i can code the VLAN tag into the phone and am wondering if that will be sufficient to pull the address from the second scope, and if the PC's without the tag will pull from the first. thanks in advance.

6 REPLIES
New Member

Re: DHCP - stacked catalyst 3750's

i forgot to mention, the phones being piggy backed to the pc's means all switch ports are going to be trunk ports.

New Member

Re: DHCP - stacked catalyst 3750's

Hi Allen,

The phones is Cisco IP Phone? If yes, you can config switchport as access port and use voice vlan command. The IP Phone will use the voice vlan and the PC will use the data vlan.

e.g.

interface FastEthernet1/0/1

switchport access vlan 10

switchport mode access

switchport voice vlan 20

For DHCP scope issue, you can define two dhcp scope in the c3750 switches, c3750 will lease different ip address to PC and IP Phone according to different vlan setting.

e.g.

ip dhcp pool voice

network 192.168.20.0 255.255.255.0

default-router 192.168.20.1

option 150 ip 192.168.20.250

ip dhcp pool data

network 192.168.10.0 255.255.255.0

default-router 192.168.10.1

New Member

Re: DHCP - stacked catalyst 3750's

ah ok. i didn't know you could configure two VLAN's using an access port. much appreciated, i'll test it out as soon as i get to stage the devices. thanks again.

New Member

Re: DHCP - stacked catalyst 3750's

er, i'm sorry it's too early to think. the phones aren't cisco end points, they're inter-tel's. but they support almost every VLAN feature an end point can, so i don't think that'll be an issue.. once again i'll test it out soon and use the good advice given. ;)

New Member

Re: DHCP - stacked catalyst 3750's

Your switch should support two vlans per interface onc being a data VLAN and the other tagged as VOICE VLAN#. We have done this in quite a few places. The one thing I can't help out with is the non-Cisco phone site. Like the other poster stated Cisco Switches do support this.

Good Luck.

www.staticnat.com

New Member

Re: DHCP - stacked catalyst 3750's

Hello, if the phone supports that you choose an VLAN for the phone and another VLAN for the PC switchport on the IPT, it should logical make that PC-port an untagged port and then the phone itself would tag the packet with the VLAN tag of our choice. And then you have a trunk connecting the phone to the swtich. Then you are back to assigning the DHCP scope on the switch or using an IP-helper on the router to point at an microsoft/other brand server.

277
Views
0
Helpful
6
Replies
CreatePlease to create content