Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DHCP Through a 2821 router

I had a client successfully loging on to a dhcp server through a 2821 router, this was with the clients address reserved on the server.

When I attempted to reload the router having erased the startup-config the router tried to get its ip address from the dhcp server (I think)

Since this I have not been able to get the client to logonto the dhcp server through the router, it still logs on ok if the router is bypassed.

The server IP address is 183.113.195.80

The clients resrved address is:183.113.195.226

Running Config below...........

!version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

no service dhcp

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

ip subnet-zero

!

!

ip cef

!

!

!

!

!

!

interface GigabitEthernet0/0

ip address 183.113.195.65 255.255.255.224

ip helper-address 183.113.195.80

ip helper-address 183.113.195.81

ip helper-address 183.113.195.82

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 183.113.195.225 255.255.255.248

ip helper-address 183.113.195.80

ip helper-address 183.113.195.81

ip helper-address 183.113.195.82

duplex auto

speed auto

!

ip classless

ip forward-protocol udp bootpc

!

ip http server

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

login

!

scheduler allocate 20000 1000

!

end

Can anyone offer help or suggestions.

2 REPLIES
New Member

Re: DHCP Through a 2821 router

You've multiple ip-helper addresses listed under the Gi0/0 which assisted your workstattion to find the DHCP server and obtain IP address leases. Are you running DHCP on a Windows server now? You can have the client reserved ip address set up as a "reservation" in Windows DHCP scope if you want, but I am not sure what seems to be the issue that you're concerning about. Are you looking to have the client obtains ip addresses directly from the router or from another DHCP server?

hth,

hieu

New Member

Re: DHCP Through a 2821 router

Are you running DHCP on a Windows server now? YES Windows Server 2003. The clients ip address is reserved in the windows dhcp.

I do not want the router to manage dhcp but permit the initial dhcp transactions to occur through it. Thus giving the client its ip address.

T.

540
Views
0
Helpful
2
Replies
CreatePlease to create content