Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Disabling 3750 interface snmp traps

I constantly receive trap information on 3750 switch for interface up/down and would like to disable this notification. Is there some way to disable the notifications for workstation interfaces and keep trunk interfaces active? Thank you for any assistance

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Disabling 3750 interface snmp traps

Configure 'no snmp trap link-status' on ports for which you don't want to receive link status alarms.

SW1-3550(config)#int f0/1

SW1-3550(config-if)#no snmp trap ?

link-status Allow SNMP LINKUP and LINKDOWN traps

mac-notification MAC Address notification for the interface

SW1-3550(config-if)#no snmp trap link-status

SW1-3550(config-if)#do show run int f0/1

Building configuration...

Current configuration : 171 bytes

!

interface FastEthernet0/1

switchport mode access

no snmp trap link-status

HTH

Sundar

4 REPLIES

Re: Disabling 3750 interface snmp traps

Do you want to disable all traps or just interface up/down? Can you post a "show run | inc snmp" and remove the community?

New Member

Re: Disabling 3750 interface snmp traps

I want to disable the fastethernet interfaces for up/down and if possible keep the gig trunk ports.

sh run | inc snmp

snmp-server community xxxxxxx RO 66

snmp-server community xxxxxxx RW 66

snmp-server location Somewhere

snmp-server contact Someplace at x12345

I included ACL 66 below....

access-list 66 permit 10.20.50.38

access-list 66 permit 10.20.20.120

access-list 66 permit 10.20.20.121

access-list 66 permit 10.20.50.22

access-list 66 permit 10.20.23.0 0.0.0.255

access-list 66 permit 10.10.21.0 0.0.0.255

access-list 66 permit 10.30.21.0 0.0.0.255

access-list 66 permit 10.24.1.0 0.0.0.255

access-list 66 deny any

Re: Disabling 3750 interface snmp traps

Configure 'no snmp trap link-status' on ports for which you don't want to receive link status alarms.

SW1-3550(config)#int f0/1

SW1-3550(config-if)#no snmp trap ?

link-status Allow SNMP LINKUP and LINKDOWN traps

mac-notification MAC Address notification for the interface

SW1-3550(config-if)#no snmp trap link-status

SW1-3550(config-if)#do show run int f0/1

Building configuration...

Current configuration : 171 bytes

!

interface FastEthernet0/1

switchport mode access

no snmp trap link-status

HTH

Sundar

New Member

Re: Disabling 3750 interface snmp traps

Sundar...

Thank you so much..... I love ya man!!!

It fixed the issue!!

1208
Views
5
Helpful
4
Replies
CreatePlease to create content