Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Green - Home Lab Setup problem - Help Appreciated

Below you will find my config for a 2520 Router and an AS2509-RJ. I am attempting to reverse telnet from my AS to 2520. However when I try this I end up telnetting back to the AS. (Very confusing, but confirmed as the only password accepted is test1.)

From my AS I am entering:

Telnet R1 2001

Note: Setup is as follows.

AS(RJ45-1) via Rolled cable to 2520 (console port)

Can someone help me out?

R1_2520 Config:

Current configuration : 760 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname R1_2520

!

enable secret xxx

enable password xxx

!

!

!

!

!

ip subnet-zero

ip tftp source-interface Ethernet0

!

!

!

!

interface Loopback0

ip address 169.1.x.x.255.255.255

!

interface Ethernet0

ip address 10.1.1.1 255.255.0.0

!

interface Serial0

no ip address

no ip mroute-cache

shutdown

!

interface Serial1

no ip address

shutdown

!

interface Serial2

no ip address

shutdown

!

interface Serial3

no ip address

shutdown

!

interface BRI0

no ip address

shutdown

!

ip classless

no ip httpserver

!

!

line con 0

line aux 0

line vty 0 4

password xxx

login

!

end

R0_2509 Config:

Current configuration : 976 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname R0_2509

!

enable secret xxx

enable password xxx

!

!

!

!

!

ip subnet-zero

no ip domain-lookup

ip host R1 2001 10.101.1.1

!

!

!

!

interface Loopback0

ip address 10.101.1.1 255.255.255.255

!

interface Ethernet0

ip address 10.10.10.10 255.255.0.0

no ip mroute-cache

shutdown

no cdp enable

!

interface Serial0

no ip address

no ip mroute-cache

shutdown

!

interface Group-Async0

ip unnumbered Ethernet0

async mode interactive

group-range 1 8

!

ip classless

ip httpserver

!

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

no cdp run

!

line con 0

password test1

login

no exec

transport preferred telnet

line 1 8

password test1

login

no exec

transport preferred telnet

line aux 0

line vty 0 4

password lions

login

no exec

transport preferred telnet

!

end

Debug Info from Telnet:

4d20h: TCB001E7458 created

4d20h: TCB001E7458 setting property TCP_TOS (11) 273F4F

4d20h: TCB001E7458 bound to UNKNOWN.11073

4d20h: TCP: sending SYN, seq 541398595, ack 0

4d20h: TCP0: Connection to 10.101.1.1:2001, advertising MSS 1474

4d20h: tcp0: O CLOSED 10.101.1.1:2001 10.101.1.1:11073 seq 541398595

OPTS 4 SYN WIN 4128

4d20h: IP: s=10.101.1.1 (local), d=10.101.1.1 (Loopback0), len 44, sending

4d20h: TCP0: state was CLOSED -> SYNSENT [11073 -> 10.101.1.1(2001)]

4d20h: IP: s=10.101.1.1 (Loopback0), d=10.101.1.1 (Loopback0), len 44, rcvd 3

4d20h: tcp0: I LISTEN 10.101.1.1:11073 10.101.1.1:2001 seq 541398595

OPTS 4 SYN WIN 4128

4d20h: TCP: connection attempt to port 2001

4d20h: TCP: sending RST, seq 0, ack 541398596

4d20h: TCP: sent RST to 10.101.1.1:11073 from 10.101.1.1:2001

4d20h: IP: s=10.101.1.1 (local), d=10.101.1.1 (Loopback0), len 40, sending

4d20h: IP: s=10.101.1.1 (Loopback0), d=10.101.1.1 (Loopback0), len 40, rcvd 3

4d20h: tcp0: I SYNSENT 10.101.1.1:2001 10.101.1.1:11073 seq 0

ACK 541398596 RST WIN 0

4d20h: TCP0: state was SYNSENT -> CLOSED [11073 -> 10.101.1.1(2001)]

4d20h: TCP0: bad seg from 10.101.1.1 -- closing connection: seq 0 ack 541398596 rcvnxt 0 rcvwnd 0

4d20h: TCP0: connection closed - remote sent RST

4d20h: TCB 0x1E7458 destroyed

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Green - Home Lab Setup problem - Help Appreciated

So, now we're sure the connection is broken. Let's analyze the problem this way.

There are 3 components in this connection:

1.The 2520's console port

2.rollover cable

3.The 2509's line ports

If one of the above components have any problem, it will cause a broken connection.

First let's check the 2520's console port. Can you login to the 2520 by directly conecting the console port to your PC? If so, this can be excluded from being a probable cause.

Second, change the rollover cable. Is it improved then? If so, the rollover cable you were using is bad. If not, the rollover cable can be likely excluded from being the probable cause.(One possibility is that all the rollver you have are bad, but not likely)

Third, plug your rollover cable to line 2, then type "telnet 10.101.1.1 2002", and see whether you can login to the 2520. If not, repeat the process on line 3, line4 ,...,and line 8.

If all the 8 lines cannot be used, there is the last chance. Remember your aux port? It's your line 9. Before repeat the above process, add some command lines in your confiuration:

line aux 0

no exec

transport preffered telnet

then type "telnet 10.101.1.1 2009

Good lucks

SSLIN

(I have had the same problem before; it's just the cable problem)

7 REPLIES

Re: Green - Home Lab Setup problem - Help Appreciated

Hi,

I try your configuration in my home lab. It works for me.Notice you have configured a password in async lines:

line 1 8

password test1

login

The password is the same as the console password. So, when you reverse telnet to the 2520 you will be prompted to enter the password and the only password accepted is of course the "test1". It's quite normal.

After you enter the password, what is the prompt show on the teminal screen? It's R1_2520 or R0_2509?(I think it's a good idea to decide which router you are in by it's hostname instead of the password you enter.)

My debugging output is quite different from yours.Which debug command did you use?(I used "debug telnet") I'm trying to maka simalar debugging output because I was confused with the debugging output.(The debugging output shows the connection is failed but the fact that you are prompted a password means this is a successful connection, isn't it?)

Hope this help and wish you good lucks in your lab.

SSLIN

New Member

Re: Green - Home Lab Setup problem - Help Appreciated

I will take the password out on the line 1 8. The prompt never shows up. Also my Router is a 2509-RJ would that cause my problem?

The prompt never shows up. As for the debug, I think the debug command was all.

Re: Green - Home Lab Setup problem - Help Appreciated

So, now we're sure the connection is broken. Let's analyze the problem this way.

There are 3 components in this connection:

1.The 2520's console port

2.rollover cable

3.The 2509's line ports

If one of the above components have any problem, it will cause a broken connection.

First let's check the 2520's console port. Can you login to the 2520 by directly conecting the console port to your PC? If so, this can be excluded from being a probable cause.

Second, change the rollover cable. Is it improved then? If so, the rollover cable you were using is bad. If not, the rollover cable can be likely excluded from being the probable cause.(One possibility is that all the rollver you have are bad, but not likely)

Third, plug your rollover cable to line 2, then type "telnet 10.101.1.1 2002", and see whether you can login to the 2520. If not, repeat the process on line 3, line4 ,...,and line 8.

If all the 8 lines cannot be used, there is the last chance. Remember your aux port? It's your line 9. Before repeat the above process, add some command lines in your confiuration:

line aux 0

no exec

transport preffered telnet

then type "telnet 10.101.1.1 2009

Good lucks

SSLIN

(I have had the same problem before; it's just the cable problem)

New Member

Re: Green - Home Lab Setup problem - Help Appreciated

Hello

Maybe I didn't read your mail as good as I should but aren't you telnetting to the L0 on the 2509?

And shouldn't it be better to add a no shut to E0 on the 2509?

Greetings

Re: Green - Home Lab Setup problem - Help Appreciated

Hi, americain

Both loopback and ethernet intefaces can be used in a reverse telnet session in case they are both up/up.

Cheers

SSLIN

New Member

Re: Green - Home Lab Setup problem - Help Appreciated

Hello CSCO10892433

Thank you for your feedback. As far as I know a loopback never goes down. So it should always be up when configured of course.

The question was why there was a telnet session to a loopback adres and if this wasn't to the local loopback adres since it isn't clear from what router he is telnetting.

Greetings

Re: Green - Home Lab Setup problem - Help Appreciated

Hi, americain

It's a good question. What is the target device of a telnet session if the target ip adress is himself. The key point is the port number it uses. Typically, telnet uses port number 23. For this case, it uses 2001~2009. If a router use 2xxx (where x =0~9) as the port number in a telnet session, it will try to establish a telnet session through async lines this router have(That is, all packet in this telnet session will go out the async line instead of a ethernet interface). And the target device of this telnet session will be a device in the other end of the async line. Sometimes it is a modem attached to this async line. More often, where we can see in the Teminal Server senairo, it is another router attached to the async line.

Here is a typical Terminal server senario you can refer to:

http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a008014f8e7.shtml

Let me know if you have any further question.

SSLIN

139
Views
0
Helpful
7
Replies