Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Help on Configuring a 2621 routers FE for DHCP client.

I do not know if this is the right forum for this but here it goes. I am trying to configure FE0/0 on my 2621 to be a DHCP client and get it ip address from my Cable Modem. I am stumped on why the option is not present under the interface ip tree. Could it be the IOS version? I have included my show run. any assistance would greatly be appreciated.

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 2621_Alpha

!

!

!

!

!

!

ip subnet-zero

!

ip dhcp pool 1

default-router 192.172.5.1

!

ip audit po max-events 100

ip dhcp-server 192.172.5.1

!

!

controller T1 0/1

!

controller T1 0/2

!

!

interface FastEthernet0/0

no ip address

no ip directed-broadcast

duplex auto

speed auto

!

interface Serial0/0

ip address 192.168.1.1 255.255.255.0

no ip directed-broadcast

no ip mroute-cache

clockrate 64000

!

interface FastEthernet0/1

ip address 192.172.10.40 255.255.255.0

no ip directed-broadcast

shutdown

duplex auto

speed auto

!

ip classless

ip route 192.172.10.0 255.255.255.0 192.168.1.2

no ip http server

!

!

line con 0

password *********

login

transport input none

line aux 0

line vty 0 4

password **********

login

!

no scheduler allocate

2 REPLIES
Bronze

Re: Help on Configuring a 2621 routers FE for DHCP client.

Hello,

the ´ip address dhcp´ command was introduced in IOS version 12.1(2)T. You are running 12.0, so you would have to upgrade your IOS in order for the command to be supported...

Regards,

Nethelper

Community Member

Re: Help on Configuring a 2621 routers FE for DHCP client.

Thank you, That is what I was thinking but was not sure.

Very Appreciative

DSapko

175
Views
0
Helpful
2
Replies
CreatePlease to create content