Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

How to setup iphelper and cgmp

I have one catalyst 3550 switch that feeds three buildings via direct fiber connections to each building (each building as several catalyst 3500xl switches)

I want each building to have a vlan

building 1 = ip ranges from 10.0.8.1 - 10.0.15.255 (location of my dhcp, application, imaging servers - that server all buildings)

building 2 = ip ranges from 10.0.16.1 - 10.0.23.255

building 3 = ip ranges from 10.0.24.1 - 10.0.31.255

I would like to be able to use my dhcp server to give out addresses to all buildings (in the proper ip ranges), plus allow "cgmp"? multicasting in order to allow mass imaging from my imaging server.

Our isp (they house the 3550) have tried to get this to work, but my dhcp server will only give out 10.0.8.1-10.0.15.255 to all buildings, but we can assign static ip addresses to pcs in any range provided that we use the ranges "gateway" address ie 10.0.16.1, 10.0.24.1.

I have read in a few post that I need something called ip-helper for the dhcp, we are not sure how to set this up

We have not tried cgmp yet as I am not sure where to start or if it is even a option based on my setup.

can anyone give me some configuation examples that would get me up and going or at least in the right direction

also how would I intergrate multicasting into the whole scheme??

I have attached a diagram of my setup.

10 REPLIES
Hall of Fame Super Silver

Re: How to setup iphelper and cgmp

Your diagram is interesting and helpful but lacks some details that would help us to provide more precise answers. The configuration of helper addresses is relatively straightforward. On the layer 3 interfaces on the 3550 for building 2 and building 3 you would configure this: ip helper-address 10.0.8.21 (since your diagram does indicate that the DHCP server is address 10.0.8.21). When this is configured the PC will send a DHCP request to its broadcast address. The DHCP request will be received by the layer 3 interface for that VLAN on the 3550 and forwarded to the DHCP server. Assuming that the DHCP server has been configured with appropriate scopes for the various address ranges, the server should assign appropriate address to the PCs.

HTH

Rick

New Member

Re: How to setup iphelper and cgmp

so the config on the 3550 would look something like this?

interface Ethernet 1

ip address 10.0.8.1 255.255.248.0

interface Ethernet 2

ip address 10.0.16.1 255.255.248.0

ip helper-address 10.0.8.21

interface Ethernet 3

ip address 10.0.24.1 255.255.248.0

ip helper-address 10.0.8.21

I am not exactly sure how the 3550 is currently setup, though I know there are one vlan for each building. I can get a listing of the current config and post it this week.

New Member

Re: How to setup iphelper and cgmp

ok, looked at the 3550 today, looks like the 3550 has all my buildings currently on one vlan. So I have been looking through a 3550 manual, plus what have have learned from this forum I have come up with the config listed below (I did not put any cgmp stuff in yet). Isp was not available to test this, but does it look like I am on the right track?

___________________________________________________

ip subnet-zero

ip routing

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

interface FastEthernet0/1

description to building 1

switchport access vlan 2

switchport mode dynamic desirable

!

interface FastEthernet0/2

description To building 2 (has dhcp server)

switchport access vlan 3

switchport mode dynamic desirable

!

interface FastEthernet0/3

description to building 3

switchport access vlan 4

switchport mode dynamic desirable

!

interface FastEthernet0/4

switchport mode dynamic desirable

!

(Ports 0/5 to 0/23 are same as 0/4)

interface FastEthernet0/24

description WAN to isp (my 3550 is connected to another switch on the isp side)

switchport access vlan 101

switchport trunk allowed vlan 101

switchport mode dynamic desirable

speed 100

duplex full

!

interface Vlan2

ip address 10.0.16.1 255.255.248.0

ip-helper 10.0.8.21

shutdown

!

interface Vlan3

ip address 10.0.8.1 255.255.248.0

shutdown

!

interface Vlan4

ip address 10.0.24.1 255.255.248.0

ip-helper 10.0.8.21

shutdown

!

interface Vlan101

description Wan to isp

ip address 10.20.0.14 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.20.0.1

no ip http server

Hall of Fame Super Silver

Re: How to setup iphelper and cgmp

The shutdown on VLANs 2, 3, and 4 should be changed to no shutdown. But otherwise I think the config is reasonable for putting each building into a separate subnet and for allowing access to the DHCP server.

Since you are using private address space I wonder if it should be translated as you send it to your provider. But that may be outside the scope of the question that you asked.

HTH

Rick

New Member

Re: How to setup iphelper and cgmp

thanks!

we will try it and see what happens.

one thing though, will my application servers be able to communicate with my other vlans as the config is written.

the 3550 manual mentioned using a secondary ip address command

ie - interface vlanX

ip address 10.0.16.1 255.255.248.0

ip address 10.0.8.1 255.255.248.0 secondary

ip address 10.0.24.1 255.255.248.0 secondary

for something that sounded a whole lot like allowing other vlans to communicate but it was a little confusing on what situations called for it

Hall of Fame Super Silver

Re: How to setup iphelper and cgmp

The use of secondary addresses would put all three subnets into a single VLAN. I do not believe that this is the functionality that your message described. In particular your DHCP server would have difficulty in giving correct addresses per building if they were all in the same VLAN. And without knowing much about your environment I would hesitate to put all the groups into a single VLAN. The config as you showed it should allow the application servers to communicate between subnets.

The secondary address command is for situations where you want multiple subnets to be on a single layer 3 interface (on a single VLAN, and in a single broadcast domain).

HTH

Rick

New Member

Re: How to setup iphelper and cgmp

Here are the directions for mutlicast. However, be aware that there are caveats if you are using symantec ghost as your imaging server.

If you ever decide to change methods, drop me a line, we've put together a free method using open source products, and it's about 30% faster than ghost and altiris. I'll give you the instructions freely.

New Member

Re: How to setup iphelper and cgmp

I do not see any directions or any links for the instructions?

I use zenworks imaging (novell), though I am always interested in better and free ways.

New Member

Re: How to setup iphelper and cgmp

New Member

Re: How to setup iphelper and cgmp

hello friend,

I was reading over posts about symantec ghost and mulicasting (which i am having current problems with trying to image across vlans, and my implication a cisco 2821 router), and i saw your thread about an open source alternative to ghost and altiris, and faster. I am intersted.

Thanks for the info in your thread, it seems helpful.

376
Views
17
Helpful
10
Replies
CreatePlease login to create content