Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Installing extra DRAM causes problems with flash

I have a 3725, which has two memory banks and a maximum DRAM capacity of 256Mb. The flash is a 32Mb CompactFlash card.

The router originally had 128Mb of PC100 SDRAM in one slot, the other slot was empty.

Since I had another working stick of 128Mb PC100 SDRAM (it had recently been harvested from an old webserver whose time with us has come to an end) I decided to install it.

Oddly, as soon as I powered the router back on it wouldn't boot from flash:

loadprog: bad file magic number: 0x0

boot: cannot load "flash:"

Aha, I thought, I must have knocked into the flash card when I installed the DRAM. So I reseated it - still the same. Via rommon, I was able to erase the flash and copy a different image to it using xmodem with no problems, and I could view the contents with dir flash. but as soon as I tried to boot from it, I got the same error.

However, the router was recognising the new DRAM size with no problems, e.g.

System Bootstrap, Version 12.2(8r)T2, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 2002 by cisco Systems, Inc.

c3725 processor with 262144 Kbytes of main memory

Main memory is configured to 64 bit mode with parity disabled

The strangest thing is - when I removed the extra DRAM module the router was able to boot from flash again.

Bearing in mind that a) the router recognised the extra DRAM perfectly and b) DRAM is separate from flash - how do you think this could happen?

Thanks!

4 REPLIES

Re: Installing extra DRAM causes problems with flash

Hello!

Maybe this link will help you:

http://www.cisco.com/en/US/products/hw/routers/ps282/products_tech_note09186a008075fd05.shtml#tbtb2

In summary it is written there that:

"Router boots into ROMmon, with these

messages on the console:

-device does not contain a valid magic number

-boot: cannot open "flash:"

-boot: cannot determine first file name on device "flash:"

Possible causes include:

corrupted software image

faulty Flash memory

faulty DRAM

bad memory slot

More details on the document. Check the memory. Try to boot with one 128 at the time and see if any of them is making problems.

Good luck!

Cheers,

Calin

New Member

Re: Installing extra DRAM causes problems with flash

Hi,

Thanks for the reply! I have since replaced the flash (needed 64Mb for a new image) so the image and flash have been ruled out.

Looks like the only other possibilities will be fauly DRAM or slot. I will try one at a time and get back to you.

Cisco Employee

Re: Installing extra DRAM causes problems with flash

Hi,

In general, this problem is attributed to running an older version of ROMMON which does not support 256MB or there is a compatibility issue between the device and DRAM.

Below is the link regarding the ROMMON upgrade for the 3725:

http://www.cisco.com/en/US/docs/routers/access/3700/hardware/notes/256memrm.html

Reference link for upgrading memory on the 3700 router:

http://www.cisco.com/en/US/docs/routers/access/3700/hardware/notes/3700mem.html

The Cisco part number for the 256MB upgrade on Cisco 3725 router is:

MEM3725-128U256D=

Thanks,

Hamam

New Member

Installing extra DRAM causes problems with flash

As of today, I have now had this same problem two times... both times I have isolated it to DRAM issues on 2 different 2811 chassis

I receive the same error messages at boot time:

loadprog: bad file magic number:      0x0

boot: cannot load "flash:"

...using known good working CF cards with IOS files that other identical model routers boot from.

In the 1st case, I removed a bad 256MB DRAM chip (that was previously working just fine) and the router booted.

In the 2nd case today, I simply reseated a single 512MB DRAM chip and the router booted.

... so, if you find yourself banging your head against the wall with a good CF card and good IOS file... reseat the memory 1st and/or replace it 2nd

510
Views
0
Helpful
4
Replies
CreatePlease login to create content