Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Internet connection sharing problem??

Hi all,

I am very new to Cisco world.I am having a problem with my internet connectivity for the small business netwok.I was using windows XP pro in 4 boxes and was sharing my internet connection using Internet connection sharing(ICS).One of the Windows XP pro is connected to the Broadband using USB modem.But recently i have added one more box with windows server 2000.now I can't share Internet.Then I read from some article about using routers as NAT.

I got a Cisco 2503 router ,I just want to know can I use this router for NAT and How I can configure for making my internal connection secure and share internet connection.otherwise how can I solve the problem ???

anytype of suggestions/help/advice will be really appreciated.

with rgds ..smith

3 REPLIES
VIP Purple

Re: Internet connection sharing problem??

Hello,

using NAT on a Cisco 2503 router is fairly straightforward. You define an inside and an outside interface, as well as the addresses that need to be translated. The configuration would look like this:

interface Ethernet0

ip address 192.168.1.1 255.255.255.0

ip nat inside

!

interface Serial0

ip address 212.136.23.5 255.255.255.252

ip nat outside

!

ip nat inside source list 1 interface Serial0 overload

!

access list 1 permit 192.168.1.0

!

ip route 0.0.0.0 0.0.0.0 Serial0

All your clients would have IP addresses in the range 192.168.1.0/24, and their default gateway would be the IP address of the Ethernet0 interface, 192.168.1.1. When accessing the Internet, the internal (192.168.1.0/24) addresses of your clients would be translated to the IP address of the Serial 0 interface. This is called Port Address Translation (PAT), because many IP addresses are translated to one pubic IP address, connecting through different ports.

That said, be aware that the 2503 does not support broadband connectivity (PPPoE or PPPoA), which are mainly used by ISPs. You would need to get a public IP address from a provider, which you then could assign to your serial interface. In addition, you would get a frame relay or leased line connection from a provider, which tend to be expensive. If all you need is Internet access for your small home network, this might be overkill...

What exactly is the problem with your ICS ? Is only the W2K server not working, or none of the other clients either ?

Regards,

GP

New Member

Re: Internet connection sharing problem??

Hi,

My main problem is my win2k system does not have internet connetctivity and not showing on the workgroup.

Like you said I can easily configure ethernet0 but what about the serial0,what type of cable and media(device) goes into the serial port?

Also how can i make my broadband to connect with cisco router?which cisco router supports broadband and how??To make my 2503 to work with broadband what else i need???

Thanks in advance.

smith

VIP Purple

Re: Internet connection sharing problem??

Hello Smith,

the 2503 is not capable of handling anything broadband-related. For connectivity with the serial port, you would need an X.21 or V.35 cable, but I think this will do not much good in your situation, since you would also have to get an (expensive) leased line or frame relay...

My suggestion is: forget about integrating the 2503...

How many clients do you have configured for ICS ? I think ICS specifies a limit of 10 computers...

You might want to have a look at the document linked below:

Windows 2000 Internet Connection Sharing

Client Installation

http://www.windowsnetworking.com/j_helmig/w2kicsci.htm

Regards,

GP

232
Views
0
Helpful
3
Replies
CreatePlease login to create content